1 Reply Latest reply: Jun 22, 2012 11:09 AM by Kurt Lang
berkuraler Level 1 Level 1 (0 points)

My fonts ***** after i installed 10.6.8 Mac OSX.  Can u solve that problem?

 

I cant open my fonts in freehand or photoshop cs5, before i could but now it cant find the font in the program. I can see font in suitcase and folders also. But graphic programs cant get it. Can u fix it please?

 

Thanx

Berk Uraler


iMac, Mac OS X (10.6.7)
  • 1. Re: About the Mac OS X v10.6.8 Snow Leopard Font Update
    Kurt Lang Level 7 Level 7 (31,990 points)

    Every so often, an update will cause the font cache files, or Font Book's database to go haywire. If Font Book is on the drive, and Suitcase is your normal font manager, get rid of Font Book. Having more than one font manager on your system at a time is never a good idea. On top of that, Font Book's database can actually prevent other managers from working correctly. I'd do this:

     

    Removing Font Book


    1) Open Font Book, then its preferences. Uncheck the box for "Alert me if system fonts change". Close the preferences and shut down Font Book. Put the Font Book application in the trash and delete it. Copy it off to another drive first if you would ever want to get back to it for some reason. It can then just be placed back in the Applications folder.

     

    2) Restart your Mac and immediately hold down the Shift key when you hear the startup chime to boot into Safe Mode. Keep holding the Shift key until OS X asks you to log in (you will get this screen on a Safe Mode boot even if your Mac is set to automatically log in). Let the Mac finish booting to the desktop and then restart normally.

     

    This clears Font Book's database and the cache files for the user account you logged into in Safe Mode. The main goal in this step is to remove the orphaned Font Book database. With the Font Book application no longer on the hard drive, a new one cannot be created. Which is what we want.

     

    3) Next, clear all font cache files from the system. Close all running applications. From an administrator account, open the Terminal app and enter the following command (or copy/paste it from here):

     

    sudo atsutil databases -remove


    This removes all font cache files. Both for the system and the active user account. After running the command, close Terminal and immediately restart your Mac.