13 Replies Latest reply: Dec 4, 2012 6:27 PM by jamerz3294
jrosati Level 1 Level 1 (0 points)

Just since yesterday (when I coincidentally--?--updated all of the new software) I can't access Twitter.com properly anymore.

I'm not having issues with any other sites, and no one else seems to be having issues with Twitter.


I can't utilize the pop-up windows (to create or send a new tweet--the "send" button is greyed-out); I can't use the "@connect" page; I can't use the "search" function; and I can't load more than 10-20 of the most recent Tweets.


I've cleared the cache and cookies, restarted, checked for additional updates, and pretty much I dunno what to do next... =/

MacBook Air, Mac OS X (10.6.8)
  • Carolyn Samit Level 10 Level 10 (101,760 points)

    Might be a corrupted Twitter preference file  (.plist)


    Open the Finder. From the Finder menu bar click Go > Go to Folder


    Type this exactly as you see it here:




    Click Go


    Move the com.twitter.twitter-mac.plist file to the Trash.


    Quit then relaunch Safari. Try Twitter.


    If that didn't help:  Go > Go to Folder




    Click Go


    Move the Cache.db file to the Trash.


    Quit and relaunch Safari to test.

  • jrosati Level 1 Level 1 (0 points)

    ah, I really appreciate your response! ...but unfortunately neither of those files can be found on the computer!

  • Linc Davis Level 10 Level 10 (177,970 points)

    Select  ▹ System Preferences ▹ Network ▹ Advanced ▹ TCP/IP ▹ Configure IPv6: Off. Apply the change and test. You must apply the change before it takes effect.

  • jrosati Level 1 Level 1 (0 points)

    That didn't work either
    I definitely applied the settings, then restarted and double checked them.


    Thank you for trying.

  • Linc Davis Level 10 Level 10 (177,970 points)

    Are there any other devices on the same network that you can use to access the site? Do they behave the same way?

  • jrosati Level 1 Level 1 (0 points)

    I've tried each of the three Twitter accounts I run at home and at work on the same Air, and none of them work on either network.

    When I access Twitter from my iPhone the accounts work fine (which leads me to believe it's a Safari problem rather than a Twitter problem...)

  • Linc Davis Level 10 Level 10 (177,970 points)

    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box. Don't use the Safari-only Guest login created by Find My Mac.


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem(s)?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault in Mac OS X 10.7 or later, then you can’t enable the Guest account. The Guest login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:


    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    *Note: If FileVault is enabled under Mac OS X 10.7 or later, or if a firmware password is set, you can’t boot in safe mode.


    Test while in safe mode. Same problem(s)?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • jrosati Level 1 Level 1 (0 points)

    Well, it appears it *was* localized to my user account. When I logged in under the guest account, for a few seconds, the screen looked exactly the same (greyed out "Send Tweet" button), but it reset back to the normal button and worked.


    When I logged back in to my main account, the same thing happened--looked broken for a few seconds then reverted back to normal.


    So, I have no idea how you did it, or what the actual problem was, but you've inadvertently fixed my problem! Thank you

  • jrosati Level 1 Level 1 (0 points)

    DAMMIT. I've spoken too soon. It reverted back to the "broken" way when I just logged back in.


    I'm going to restart in safe mode now...

  • jrosati Level 1 Level 1 (0 points)

    Okay: So in Safe Mode, Twitter works normally.


    When I log back in to my regular account, in regular mode, it no longer works.  =/

  • jrosati Level 1 Level 1 (0 points)

    I've figured something out:


    In my own account, I use the Private Browsing option.


    Each of the times I was using another account, or logging into safe mode, I wasn't using it.


    After logging in and out and trying various options, I've learned that I am unable to use Twitter on any account (or in safe mode) when I have Private Browsing turned on.


    I've always browsed privately, but this problem only just started. Any idea how to fix it?

  • Linc Davis Level 10 Level 10 (177,970 points)

    Use Private Browsing only when needed. It's not meant for continuous use.

  • jamerz3294 Level 1 Level 1 (0 points)

    When I tried to Go to the following folder, ~/Library/Preferences/com.twitter.twitter-mac.plist It said "The Folder can't be found" Any other ways to got to it? I have OSX v 10.8.2 on my MacBookAir. Every time I try to go to Twitter.com, it starts to load, then redirects to Virtue.com?! HELP!