4 Replies Latest reply: Jun 25, 2012 3:26 AM by John Whitehead
John Whitehead Level 1 Level 1
expertise.photosformac
Photos for Mac

A freshly reinstalled iWork v4.1 won't let me launch any of the applications. All crash instantly with a report the salient part of which appears to be

 

"Application Specific Information:

dyld: launch, loading dependent libraries

 

 

Dyld Error Message:

  Symbol not found: _SFAAutosaveUserActivityException

  Referenced from: /Applications/iWork '09/Pages.app/Contents/MacOS/Pages

  Expected in: /Library/Application Support/iWork '09/*/SFArchiving.framework/Versions/A/SFArchiving"

 

Does this mean anything to anybody?

 

Thanks for your help

 

Best

 

J

Solved by fruhulda on Jun 25, 2012 2:46 AM Solved

You cannot completely delete iWork by moving the iWork '09 folder to the Trash. Instead, use Yvan Koenig's script:

 

          •          Go to http://www.box.com/s/00qnssoyeq2xvc22ra4k

          •          Choose public_YK > for_iWork'09 > other_iWork'09 items

          •          Click on uninstall iWork '09.zip, decompress it, open it in AppleScript Editor and click the Run button

Restart the computer and do the installation from the CD again. And the updates as I don't think the CD has the Pages 4.1 version.