Previous 1 2 3 4 Next 45 Replies Latest reply: Oct 21, 2015 4:01 AM by pricecominc
tylerskis Level 1 (0 points)

I have a 2012 MacBook Air 11". i7 2.0 512gb 8gb. I've had it for 3 days. From the beginning it is very hot and the fan is running at what seems like top speed constantly. A fully charged battery lasts 1.5 hours for email, web, and MS office apps. It's like there is something running in the background that is sucking the battery fast. I don't notice any speed reduction but I'm not using anything very intesive.

I have used a 2011 macbook air 11" 1.8 256gb 4gb for the last year and typically got 3-4 hours of battery life. That computer didn't get this hot unless there were multiple apps running and some CPU intense processes like google earth or video rendering.

I've called apple support and their suggestion is to take it to the apple store. If there is a known problem and or solution that doesn't require a full day of driving and waiting that would be better.

Thanks in advance.


MacBook Air (11-inch, Mid 2012), Mac OS X (10.7.4)
  • stedman1 Level 9 (69,784 points)
  • tylerskis Level 1 (0 points)

    stedman, thanks that was helpful.

    The process "Dock" is taking 94.5% of my CPU and the process "WindowServer" is taking 15%.

    Can you tell me what those are?

  • stedman1 Level 9 (69,784 points)

    You're welcome. Are you using VM Fusion on your computer? It may cause your issue. See the article below.

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=display KC&externalId=2011360

  • tylerskis Level 1 (0 points)

    I'm not using VM Fusion. I did have parallels installed on my last MBA and transferred the data over to this but I have never even opened the app on this computer. I have uninstalled Parallels but am still getting the process "Dock" taking 92%+ of my CPU. I quit the dock process and it just comes right back on.

  • ktamlyn2012 Level 1 (0 points)

    Same exact situation here. I am interested in a solution.

  • tylerskis Level 1 (0 points)

    ktamlyn2012,

    Have you found any solution?

    I've updated parallels, reinstalled it, restarted my computer a bazillion times. Nothing.

  • maxfromnm Level 1 (0 points)

    I have the same problem, exactly.  Macbook Air just out of the box today.  Transferred everything over from my old MacBook Pro.  Haven't opened Parallels yet, but getting the rapid fan and the problem where "Dock" is taking up a large percentage of the CPU.  

  • tylerskis Level 1 (0 points)

    I don't think it has anything to do with Parallels. I've tried it 3 times now. Seems like the problem is when copying user info.

    Since everything I do is on the cloud I just didn't transfer any info.

    So I installed dropbox, evernote, my IMAP emails and now it's just fine. I still have about a half day left for all my info to be downloaded but I'm enjoying my 4+ hour battery life right now.

  • ktamlyn2012 Level 1 (0 points)

    Not sure what happened on my end but the problem stopped. It appears that there were some large updates being downloaded in the background that ran the battery down. Maybe this was under the catagory "dock", though that doesn't make complete sense to me. After the download was complete I rebooted and the battery estimate went back to about 6 hours at 93% charged.

     

    I have Parallels and there is an update this month. Maybe that has something to do with it as well.

  • MakNet Level 1 (0 points)

    +1 for "Dock" process with 90%+ of CPU. I quit and my battery estimate went way up and fans turned off. Any idea what this process could be? It seems to have respawned, but is using 0% of the CPU for now...

  • LosiMD Level 1 (0 points)

    I have a 2012 macbook air 11'' with 2.0ghz i7, 8gb ram, and 256gb storage....experienced same "dock" process overheating issues....found this from another thread and it solved the problem:

     

    Hey Everyone,


    TL;DR: Genius went through preference files and found the corrupt one -- works fine now


    Background: I had a mid-2011 MBP with lion, and transferred to my mid-2012 11" mba. I soon discovered that the "dock" process was using up >85% of my cpu, and causing all sorts of related problems (fan speeds, temp, battery life).


    Solution:

    Went to the genius bar and this is what he did:


    Replaced the mba (since I bought it yesterday), and transferred all my data to the new computer. Result: same problem


    Created a new user on the mba. Result: problem solved


    So he renamed my existing library folder ("\Users\*username*\Library\) to

    "library old". Then, from the new user's account (he logged in as "root" user) and copied/pasted the clean "library" folder into into my original user's library (replacing the existing one).*


    *here he did some terminal stuff to show hidden folders b/c the user's library is hidden


    Then he copied, folder by folder (then file by file when we isolated the problem to be in the preferences folder), my files from "library old" into "library," after each folder, logging out (cmd+shift+q), relogging into my user account, and running activity manager to see if the "dock" application was still acting up.


    After ~1.5hours, we identified "com.apple.desktop.plist" and "com.apple.desktop.plist.lockfile" as the corrupt files and deleted them.

    Result: problem solved.



    Hope this helps!

  • LosiMD Level 1 (0 points)

    So to summarize:

     

    You must delete the following files in your library folder:

    com.apple.desktop.plist

    com.apple.desktop.plist.lockfile


    FYI...You probably already know this, but some may not: your Library folders are hidden by default in Lion. To get to your /Library or /Users/yourusername/Library (also known as the ~/Library) folders in Lion:

    • Launch Finder and click Go > Go to Folder and type: /Library or ~/Library
    • Hold the Option key while clicking the Go menu item, which reveals your ~/Library folder in the menu.
    • Make it permanently visible by entering the following command in Terminal, then press the Enter key:
      chflags nohidden ~/Library

     

    Hope this helps.

  • Brian Thull Level 1 (0 points)

    The same thing occurs on the Macbook Pro 15" 2012 (non-retina).   I tried this and it worked like a charm!   Thanks for the tip.

  • Lisa O Level 1 (45 points)

    Thanks This worked for me too!

Previous 1 2 3 4 Next