12 Replies Latest reply: Jun 30, 2012 2:03 AM by fat_geo
fat_geo Level 1 Level 1


i have recently updated aperture to 3.3 and it seems to have "lost" a lot of the versions i had!

a load of versions seem to have totally disappeared - ie i had a project with a number of files in it, this number has now been reduced (a few of the versions were marked as "rejected" - would this have been a problem??) and then there are other projects - where if you hover over the project name it says "X versions" then you open it and there are a lot less than X versions visible?!

any ideas on how i can repair this? i have time machine backups available?



iPad, Mac OS X (10.7.3)
  • fat_geo Level 1 Level 1

    further to this, i have managed to find the files that were missing by locating them in the aperture library package and have copied them to my desktop with a view to reimport them. 

    however, would still be very keen to find out where they are sat currently within aperture so as to avoid dupes etc. - they are clearly there, i have tried removing invisible filters etc, and the fact they are still sat in the library suggests they havent vanished completely...

    most strange.

    would a rebuild help??!

  • uva14 Level 1 Level 1

    I had a similar problem. A rebuilding of the library fixed it. Look at FAQ at the EpertureExpert website if you need a tutorial how to do this. Hope this helps.

  • fat_geo Level 1 Level 1

    have tried this a rebuild - still no luck!!

    its so annoying, as i have deleted an "empty" album - and when in trash you can view the images?

    any other tips - this is driving me crazy

  • Owen A Level 2 Level 2

    Aperture 3.3.1 came out yesterday, you may want to update and see if that fixes the issue for you.

  • léonie Level 10 Level 10
    Photos for Mac

    and when in trash you can view the images?

    When you select the images in the trash and ctrl-click, there should be an option "Put back" available. Have you tried it?


    You say you have tried the following:

    • - clear invisible filters - what about the visible filters? You say you have "rejected" items - these will only be visible, if the filter in the Browser shows "Show all", not "unrated or better". And are you sure, you did the "Double Caggiano" to clear the invisible filter correctly? Here is a post by Frank Caggiano with link to a video, that shows how to do it.
    • - rebuild library - have you also repaired the permissions?



    Have you installed tonight's upgrade to Aperture 3.3.1? If not, then do it. It is a bug fix for upgrading libraries.


    You say you have a Time Machine Backup. The safest way would be to restore the 3.2.4 library from the backup, and then to rebuild the library with Aperture 3.3.1 before you upgrade it to version 3.3.1.

  • Clem Level 3 Level 3

    to the OP - try using the latest version of 3.3.1 to _Repair_ your library and post back reuslts.

  • Owen A Level 2 Level 2

    Ditto what Clem said, you should Repair the library before rebuilding in Aperture 3.3.1.

  • fat_geo Level 1 Level 1

    hey all, thanks so much for help thus far!


    to leonie's points - i have tried frank caggiano's filter removal - still the same! and when you try to put back photos from trash, it just reverts to the previous state.


    Clem - i am rebuilding my library again since update to 3.3.1 and will be sure to post back.

  • léonie Level 10 Level 10
    Photos for Mac



    to _Repair_ your library

    The Aperture 3.3.1 release notes state clearly that "rebuilding" is recommended before upgrading to a new version, not "repairing": Look at the "Addditional Information": Before upgrading, it is recommended (though not required) that you perform a rebuild of your Aperture library.


    That is why I go directly for the "rebuild". Repairing did not help in all cases.




  • fat_geo Level 1 Level 1

    oh sorry, should have said - i did rebuild before the update, and have repaired since.


    seems like nothing is really working - i think i can fudge it - as i have all the original photos, so can reimport them - just a bit of a pain to do so!!

  • léonie Level 10 Level 10
    Photos for Mac

    oh sorry, should have said - i did rebuild before the update, and have repaired since.

    Did you rebuild before the update with Aperture 3.3. or with Aperture 3.3.1? The 3.3.1 update is supposed to do the update better; but this will only help if you start from the original backed up library - rebuild and then upgrade.

  • fat_geo Level 1 Level 1

    hey - yep i rebuilt in 3.3, then upgraded to 3.3.1 - there was no change.

    i tried a repair following the upgrade as well - and no luck here sadly.  am going through manually - bit of a pain, but getting there

    thanks for all your help!!