2 Replies Latest reply: Jun 26, 2012 9:20 AM by RainDelay
RainDelay Level 1 Level 1 (0 points)

As far as I can tell everything is setup correctly but every time I try to connect I get this message:

 

You were disconnected by the communication device. Try reconnecting. If the problem continues, verify your settings.

 

Console Log:

 

6/25/12 5:11:40.382 PM pppd: PPTP connection established.

6/25/12 5:11:40.443 PM pppd: Connect: ppp0 <--> socket[34:17]

6/25/12 5:11:40.447 PM pppd: PPTP error when reading socket : EOF

6/25/12 5:11:40.447 PM pppd: PPTP error when reading header : read -1, expected 12 bytes

6/25/12 5:11:40.447 PM pppd: PPTP hangup

6/25/12 5:11:40.448 PM pppd: Connection terminated.

6/25/12 5:11:40.454 PM pppd: PPTP disconnecting...

6/25/12 5:11:40.455 PM pppd: PPTP disconnected

 

I am trying to connect to a Linux based VPN server.  I have double checked my username and password multiple times, made sure the MTU is set the same on client, server, and router, and tried turning the encryption off and on on the server and the client.  Nothing has made a difference, I get the same error every time.  I am able to FTP and SSH into the Linux box. 

 

Any suggestions of other things to try would be much appreciated.  I saw some threads about editing config files on my mac but this is a brand new machine that I have had for a week running an OS that is on it's fourth point release.  I really should not have to muck around with config files but at this point I'm ready to try anything. 

  • Topher Kessler Level 6 Level 6 (9,595 points)

    Looks like it might be a configuration error on the server's end. The VPN makes a connection and tries to read the server's configuration to create a socket for communication, but runs into a formatting error when it is passed an "End of File" character instead of a required component of the socket. Can you try connecting to another VPN server, or perhaps try an L2TP connection instead of PPTP?

  • RainDelay Level 1 Level 1 (0 points)

    The VPN server only supports PPTP and OpenVPN.  I was able to connect using OpenVPN.  I'm going to try find a Windows machine to test the PPTP with and see if that is able to connect. 

     

    If the issue is a formatting error on the server side I'm not sure where to start troubleshooting that.