Previous 1 2 Next 27 Replies Latest reply: Jan 18, 2013 1:36 PM by Joseph Corl
Joseph Corl Level 1 Level 1

Aarg!  Once again an iPhoto 11 upgrade has deleted ALL my modified photos and left only the thumbnails!  Even photos that have been in my library for years suffered, just like last time.


This happened a little over a year ago when I upgraded from iPhoto 9 to 11.  Thousands of modifieds (which are the ones I want to keep!) were simply zapped into non-existence.  The actual files deleted, not the thumbnail.  A few escaped then, but now they too have been simple erased off my hard drive!


Once again Apple has struck.  I ran the innocent sounding iPhoto update that came yesterday, 650.39, and today, again any photo I modified with Photoshop only bring up a black screen when double clicked. When I try to "edit" in iPhoto is says "Image Cannot Be Edited:  This photo was previously editted with another application (Yep, Photoshop CS 5.1....and saved as standard jpeg's....not exactly esoteric Apple!) or with an early version of iPhoto (gee, since you own iPhoto and I've 'updated' this library at least 4 or 5 times over the last 7 years you'd think that would be a non-issue Apple).  Duplicate this photo to edit it.


Are you kidding?  My modified photos are no in the finder.  A "reveal modified" brings up the top level directory.  You zapped them!  I can't duplicate them because there is nothing there!


I can choose "edit in external editor' and the original pops up in Photoshop.  But that pesky modified, Apple knew I really didn't need that photo I took two hours to tweak....any more than I needed them a year ago.


Yes, I tired rebuilding the thumbnails.  No help.  Took about 3 hours.


Beware the iPhoto upgrade!

  • LarryHN Level 10 Level 10
    Photos for Mac

    Maybe if you quit emotional RANTing and provided information someone could help


    Like how did you access the photos to edit in PS and how did you save them


    Interestimgnthat no one else has reported this for upgrades to iPhoto '11



  • Joseph Corl Level 1 Level 1

    Gee that's helpful.

  • LarryHN Level 10 Level 10
    Photos for Mac

    So was your RANT


    Have a great day



  • Joseph Corl Level 1 Level 1

    A simple Google search bring up hundreds of users who have had the same problem. Check out LizCastro and elscorcho0 on the Apple site alone, among many others like Chester4444  My RANT is not mine alone.  LizCastro writes, "I think it's unconscionable for Apple to release software that deletes people's photo libraries." but no one berated her.  And she is dead on right that this is Apple's problem.  They didn't fix it then and it has recurred now.

  • Terence Devlin Level 10 Level 10

    I re-read the thread you linked to (which refers to iPhoto 11's first release, in October 2010, and with respect, you're the only person on the thread with this specific issue - the contents of the Modified folder disappearing. Other people complained about all of the Library or date based chunks.


    We're now coming up on two years and 8 or 9 updates to iPhoto 11. You're the only person reporting this issue - and again, it's a quite specific phenomenon.  What happens if, as iphoto asks you to do, you duplicate the photo prior to editing?


    How is your Library set up? Managed or Referenced? Stored where? Any details that can help us understand why you've been smitten with this thing twice.

  • Joseph Corl Level 1 Level 1

    Thanks, Terence.  On the original update to 11 I waited until June 2011 to update to Lion and iPhoto on my new iMac i7 machine.  Just like Liz and many others, mine hung halfway through and I had to force quit and restart.  But my thumbnails survived.  This was acutally bad because I didn't discover the deletions until weeks later, after Time Machine had overwritten all useful versions of my 90Gb library.


    I manually restored all I could from various back ups, but lost some except for the originals.  That was nearly a year ago and I've only used standard approaches to editing photos:  right clicking within iPhoto to choose "edit in external editor," Photoshop in my case; or at times editing within iPhoto.   Of course I had rebuilt the library and all the other normal fixes to no avail. 


    But this new deletion of modifieds has affected photos added and edited since the fateful update to '11.  That's what's so bothersome!  And it didn't hang this time.


    Trying to duplicate does nothing.  There is nothing to duplicate.  Not even a dialogue box pops up warning that it didn't work.  The computer appears to search for a couple seconds, then silence. 


    Double clicking one of these photos to enlarge bring up a black screen with warning triangle.  Strangely, though, the link to the original is still there and all the nested folders for the modifieds (Previews now) are still in the library along with all the data and faces data.


    Everything is copied to my start up drive in one place, allowing iPhoto to handle all the management.


    A very few modifieds still survived in their Preview folder but the link is gone.  These will not duplicate either.  Pulling up "reveal modified" only takes me to the very top level of the Finder.  However reveal original will navigate to the original photo.  In all caseds the folder structure remained in tact.  


    Perhaps my machine hung at a different point in the initial update to 11??

  • Terence Devlin Level 10 Level 10

    I'm trying to get my head around why this quite specific issue might arise - I've been on the forum a while now and simply never heard of this one before.


    When you rebuilt the Library did you make a new one or repair the old one?

  • Joseph Corl Level 1 Level 1


    MaCNN did report similar "partial" deletions Oct. 25 2010, but it seems to have been more the exception: "Some people are losing part or all of their photo libraries when upgrading from iPhoto '09 to iPhoto '11, a part of the new iLife '11 suite, according to complaints."


    This time with the 650.39 update I first rebuilt thumbnails, then worked down the list to "repair" library and finally "rebuild" library.   No effect.


    I notice digging in to iPhotos file folders and subfolders that over the years apparently they seemed to have used various sub folder schemes.  I see new photos organized like this example:  Previews > 2012 > 02 > 06 > 20120206-192532 and then the actual file.  But, with photos created several years back I see at least two very different schemes:  Previews > 2005 > Oct 14, 2005 > the file;  OR Previews > 2005 > album name > the file; OR even Previews > 2005 > the file.  And in the same 2005 folder, for example, I see the newest subfolder scheme (Previews > 2005 > 09 > 22 > 20050922-000305 > the file(s) with photo dates from Sept. 22 2005 to Oct 4 2005, but are all in the 2005>09>22 folder.  Comparing to the version in the Masters folder:  Masters > 2005 > Sep 22, 2005 > the file.


    I haven't been able to see a pattern of which modifieds have broken links, verses total deletions, vs unscathed (which are very few, and all very recent).


    I should add that because 2900 images are very old Nikon ED 5000 slide and film or other scans, I used the Batch Change command to modify the date with the "modify original" checked.  Some go back to the late 1800's and early 20th centruy.  However, neither the Masters or Preview have any subfolders prior to 1959!  That's strange.  Why create some, but not all year folders?  This also if part of the angst of losing the modifieds, twice!  There were sometimes hours of research to pin down a  date for an old photo. And that's why I chose the modify original starting in Aug. 2011. 


    But it seems Apple may again have changed the subfolder date scheme as a more recent scan from an 1871 photo is in a Masters > 2012 >06 > 26 > 20120626-232759, yet the date is correct in the iPhoto display and it even found it's proper date-sort location when I re-imported it from a back up I did last month.   Strangely, that same >26 folder has dozens of totally empty subfolders with 8 digit date stamp and six digit id.  Where did they go?  It seems they were all piled in the same folder with the 1871 photo!


    Right now my concern is that if I manually re-do all my photos so all my mods have been reimported as new "masters" will I possibly lose them all again if i modify any of them?  Will I need to totally blow away my preview folder contents after I've done all that reimporting to "clean up" my library.  Even the Masters seems to have lots of empty orphaned folders.

  • JaRosti Level 1 Level 1



    This has happen to me too! I am totally livid! All the photos that I modified are the ones that are the most important to me and they are all gone! I lost very important pictures of my kids. First step, first day of pre-school, etc! How will I ever get those back!

  • Joseph Corl Level 1 Level 1

    I found on many of my modifieds this time that the original was still there, even when the "preview" (modified) was deleted.


    But, like you, on some, and even some recent additions, BOTH original and modified were deleted.  This includes several Nikon jpeg film scans added as recently as late May, then given a minor tweak in Photoshop.


    For my Recent photos that experienced total deletion the common factors were:


    1) after being added as jpg scans to iPhoto (with iPhoto copying it to the library and all on the home drive, nothing fancy) they were modified in Photoshop as an "external editor" by right clicking the thumbnail


    2) iPhoto duplicates the photo and that is what opens in Photoshop and what I edited in each case


    3) after editing, I deleted the unmodified "original" and kept only the duplicate (a new master??) that iPhoto created when I chose "edit in external editor"


    4) then I set the date in Batch change back to the date of the actual film photo was taken, with the "modify original" checked so the EXIF is updated.  In this case the dates were all in 1981.


    After this latest update (described at top) it removed some of these newer additions, which should have had the latest sub-folder scheme within the iPhoto library.  Subsequent edits to a photo once duplicated by iPhoto for "external editor" do not create an additional duplicate.  So what's going on?  Did it not create a new "master" when it duplicates as you launch Photoshop as the editor by right clicking?


    --As for a fix, I don't know one.  Here is the manual process I'm going through:


    I'm currently going through each photo of almost 19,000 and having to search my back up to find my modified version, setting its EXIF date in Reveal (iPhoto doesn't always seem to actually do this) then deleting the master photo from iPhoto--yes, totally wiping it out so that the mix of old sub-folders schemes is deleted--then dropping the modified in so that as far as iPhoto will ever know it is a "master" and the EXIF date has already been set to the past for pre-digital images.  Those taken with a digital camera are good to go.  My second post above describes the crazy mix of folder schemes in the iPhoto package.  That can't be good.  I want to get to a libary that has 100% the final (hopefully) org scheme.

  • Terence Devlin Level 10 Level 10

    3) after editing, I deleted the unmodified "original" and kept only the duplicate (a new master??) that iPhoto created when I chose "edit in external editor"


    It's not a new master, and that's the source of the issue. You've deleted the master and therefore the versions get deleted too.


    Where are you deleting the master from?

  • Joseph Corl Level 1 Level 1

    Terence, that was my thought but testing it just now with a photo I imported, then right clicked to edit in external editor (Photoshop) I notice it's no longer automatically creating a duplicate like before when you choose "external editor."  So I closed the photo w/o any changes, used the duplicate menu command, then edited the duplicate.  Using reveal in finder takes me to the identical file on both the original and dupe!  The directories are the same.  Somehow one file is serving both "masters."  And, I can delete the original, empty trash, and the photo remains in the same Masters sub-folder. 


    I re-ran this test but now Edited the duplicate I made using the "edit in external editor" right click on the thumbnail.  Saved changes.  Now that edited version has both a "master" and "modified," acc. to the menu.  The modified is in the Previews as you would expect.  Still the "master" for both is the exact same file in the Masters sub-folder.  But deleting the original and emptying trash did not delete the modified.  Not yet, at least.  And, there is still a file in the Master's folder too.   I wonder if a library rebuild would purge it?  It shouldn't since a master still exists as well as modified in Previews  But  If so, would be nice for Apple to warn: "Hey, we found versions w/o a corresponding master, do you want us to trash them or would you like to review them" or other kinder, gentler option."

  • Terence Devlin Level 10 Level 10

    Since iPhoto 11 there is no "Modified Version" any longer. iPhoto works exactly like Aperture: All edits are just entries in the database and they are applied live to the master image when you view it.


    (In earlier versions an actual modified file was created.)


    In iPhoto 11 what you see in the Previews folder is just the same an Aperture preview - a handy shortcut for other apps to use via Media Browsers - saves you the bother of exporting just to email etc. But it has no part of your edit history.


    This is for photos edited with iPhoto.


    For images edited with external editors, then the edited version is indeed stored in the Previews folder.


    But in either case, these are linked to a Master, and if you delete the Master then you lose the anchor that holds it all together.


    I'm still not clear on where you're deleting the master from?


    BTW: Removing files from the HD in iPhoto 11 requires emptying the iPhoto trash and then the System Trash

  • Joseph Corl Level 1 Level 1

    I always delete from within iPhoto using the trash can icon.


    I wonder about files where I first edited in Photoshop as described above, but subsequently edited in iPhoto (crop usually).  This latest update now has a feature that asks to duplicate it to edit in iPhoto if you edited it in Photoshop previously.


    With the latest update I can't actuallly test what i did before:


    1. import
    2. choose edit in external and iPhoto creates a duplicate to edit in PS
    3. save changes
    4. delete original (everything was still fine at this point btw)
    5. then edit in iPhoto (crop or other)
    6. rebuild library (which happened on the updates both a year ago and now)


    Testing it now, where iPhoto insists on making a dupe to edit a previously Photoshopped file, it created a new master in a sub-folder bearing the image name.  This probably will safeguard things going forward, but obviously was disasterous for previous files using steps 1-6 above.

Previous 1 2 Next