1 Reply Latest reply: Jun 25, 2012 9:32 PM by léonie
Psilocybe Level 1 Level 1 (10 points)

After migrating my data to a new 2012 MacBook Air, Aperture crashes. all software updates installed, newest version of Aperture redownloaded and re-updated.

 

This is the following message I get upon instant crash:

 

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 

Process:         Aperture [10593]

Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

Identifier:      com.apple.Aperture

Version:         3.3 (3.3)

Build Info:      Aperture-250049000000000~11

Code Type:       X86-64 (Native)

Parent Process:  launchd [1073]

 

 

Date/Time:       2012-06-25 20:08:45.752 -0700

OS Version:      Mac OS X 10.7.4 (11E2705)

Report Version:  9

 

 

Interval Since Last Report:          208337 sec

Crashes Since Last Report:           41

Per-App Crashes Since Last Report:   7

Anonymous UUID:                      BE09C041-F2FC-4EDE-8A44-1309CD36798E

 

 

Crashed Thread:  0

 

 

Exception Type:  EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

 

 

Application Specific Information:

dyld: launch, loading dependent libraries

 

 

Dyld Error Message:

  Library not loaded: /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText

  Referenced from: /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit

  Reason: image not found

 

 

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 

 

any ideas?

  • léonie Level 9 Level 9 (69,280 points)

    That error message says, that a framework (CoreText) cannot be loaded, that is used by the ProKit Framework. The ProKit.framework is looking in the wrong location - CoreText has been moved to the Applicationservices Framework.

     

    Did you install any software recently (third party applications, plug-ins)?

     

    Then I'd recommend to reinstall the Operating system, to fix the Library.

     

     

    Regards

    Léonie