0 Replies Latest reply: Jun 26, 2012 10:13 AM by Mythos_gr
Mythos_gr Level 1 Level 1 (10 points)

I bought a 500gb Verbatim external store 'n' go hard drive already formated in HFS+ with FW and USB3 interface and had been using fine with over FW for a couple of months. Once when the cable was unplugged by mistake (The sockets are all jigly, don't know why) I couldn't mount the drive but then I used the USB cable and it worked fine.

 

I kept on using in on FW till one day I was low on battery while I was using the external drive and my mac just switched off! It doesn't, for a misterious reason give me the low on power message anymore. When switched the computer back on my mac couldn't read the drive. I was getting an actual error message saying that the drive was not readable. Tried the usb cable but I was getting the same message. I went to the genius bar and by using disk warrior we were able to get the folders and the files on the root of the drive but nothing inside those folders and there should be 4 levels of folders.

 

Now my guess is that something somehow messed up the partition table but I might be wrong. Does anyone know of any tool or any way I could restore my lost data?

 

Any help will be very appreciated!


MacBook Pro 15.4" 2.4, Mac OS X (10.6.5), Windows XP Boot Camp 500Mhz G4 Cube OS X 10.4 Server 4x 700MHz G