Previous 1 2 Next 24 Replies Latest reply: Apr 4, 2016 1:14 PM by FlyingFree4ever
NJFH Level 1 Level 1

When my macbook is awoken from standby the trackpad moves the cursor around as normal but will not respond to a tap or a click. A restart won't get it working again, but a little later it will start working once more. At the moment I can't identify what gets it going, possibly by clicking using the magic mouse but can't be certain of that.


Any ideas? Others seem to report erratic behaviour, but the problems seem slightly more mechanical due to oversensity of the trackpad or the trackpad not  working at all.

MacBook Pro, Mac OS X (10.6.8)
Reply by ralphbolliger on Sep 14, 2012 9:21 AM Helpful

Hi there!


I had the same issue a few minutes ago. After a restart and a PRAM reset I noticed that my Magic Mouse in my notebook transport bag was turned on. A book lay on the mouse. After I turned the mouse off, everything was fine again.


Hope that helps. :-)


Greetings from Switzerland



All replies

  • TheSmokeMonster Level 4 Level 4

    I don't know about you but sometimes if there is a cord touching the trackpad, the trackpad sees it as a finger so it think's you're still clicking from before.


    if that's not the issue, make sure you're fully up to date (run software update) and then make sure you have the most up dated drivers for any pen tablets you might have.


    lastly I would do a PRAM reset which does address mouse issues.



    Important: If your computer does not retain parameter RAM (PRAM) settings when it is turned off, this generally indicates that the battery needs to be changed. Refer to Macintosh Family: Batteries and Part Numbers.

    Be sure to learn about when to reset NVRAM and PRAM before attempting these steps.

    Resetting PRAM and NVRAM

    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.

    Your computer's PRAM and the NVRAM are reset to the default values. The clock settings may be reset to a default date on some models.

    Resetting PMU on PowerBook or iBook computers

    In some troubleshooting situations, if resetting PRAM does not resolve an issue, resetting the PMU may be the next appropriate step. For information on when this is appropriate and for instructions on how to reset the PMU in your PowerBook computer, see Resetting PowerBook and iBook Power Management Unit (PMU).

  • ralphbolliger Level 1 Level 1

    Hi there!


    I had the same issue a few minutes ago. After a restart and a PRAM reset I noticed that my Magic Mouse in my notebook transport bag was turned on. A book lay on the mouse. After I turned the mouse off, everything was fine again.


    Hope that helps. :-)


    Greetings from Switzerland



  • peterfuj Level 1 Level 1

    Thanks Ralph,


    It looks like I had the exact same problem. My magic mouse was accidentally turned on in my notebook bag. I turned it off and all is well.


    Thanks again for the help,



  • Rocam Level 1 Level 1

    hmmm.. i had the same problem... sitting upstairs playing Poker...


    My girlfriend was cleaning downstairs and put a paper tissue box ontop of my magic magic mouse causing the problem... pfff really frustrating..

  • tushar10 Level 1 Level 1

    I had the same issue... I was using my magic mouse before I shutdown my computer and magic mouse was still powered on after my computer restart. I restarted computer several times but did not help. After reading this post, I turned off my magic mouse and restarted computer again and trackpad click was working fine. I didnot needed to reset the PRAM and NVRAM.


    I hope it helps!




  • Bozzy324156 Level 1 Level 1

    Exact same problem: Magic Mouse in laptop bag, left powered on, was messing with my cursor. Had it not been for this forum, I might never have figured this out. Thanks, Ralph.

  • Eric Liebman Level 1 Level 1
    Photos for Mac

    Wow...  problem solved!!   Thanks to everyone for this post... sure enough, my magic mouse was 10 feet away under a pile of papers and was 'clicked' down..    I would never have figured that out...!!

  • Ms.Laks Level 1 Level 1

    Amazing thanks so much..I was getting all stressed out for no reason!

  • topfunky Level 1 Level 1

    Fixed it for me, too. My mouse was at the bottom of a suitcase. Crazy!

  • LucyLou2 Level 1 Level 1

    As I was reading your reply, I was jealous. I just knew my problem couldn't be fixed so easily.  I am at home and my Magic Mouse was at work on my desk. Out of desperation, I checked my laptop bag, and there was my Magic Mouse!  Thank you, thank you, thank you!

  • jonfrost Level 1 Level 1

    I've found a very easy way to reproduce this issue with the magic mouse. If you are holding the magic mouse click as you switch it off with the underside power switch, it gets into this state. Basically the magic mouse button is permanently pressed and this prevents the touchpad click from working.


    Probably a similar problem if the magic mouse goes to sleep with the button pressed down (like it might be in the bottom of a bag)??


    It should really release the buttons when it loses connection to the mouse.

  • twheeler 77 Level 1 Level 1

    In case anyone has the same issue as above but not relating to the Magic Mouse (I don't use one), it may be from dust or crumbs in the clickpad (if mechanical models). Try holding the laptop upside down and tapping the clickpad hard several times.  This worked for me.  I promise to ease up on the cookies, ha.

  • djdemonstr8 Level 1 Level 1

    I just purchased a Mac mini today with the wireless keyboard and Magic Trackpad. I had to use a hard wired mouse to do the initial start up, but now after the computer is up and running, the track pad mouse is moving but I cannot "click" anything.


    This is the only mac in the house and I do not have any other mac hardware around, like mice or anything. Any ideas?

  • djdemonstr8 Level 1 Level 1

    Ok, I feel stupid. I guess I didn't select "one tap click" in the trackpad preferences. I solved my own problem.

Previous 1 2 Next