9 Replies Latest reply: Dec 27, 2012 12:23 PM by Sp33doMcGee
Keetje Level 1 Level 1 (0 points)

I've found hunderds of questions that look alike but not one has solved it.

I have a Time Capsule with 2 TB hard disk. In all descriptions of the TC Apple states that an extra drive can be attached through the USB.

I did that. Wanting to create an extra network drive.  I connected a (Apple formatted) WD Essential to the USB. With te newest airport configuration programm I do not see the hard drive. I do see it with version 5.6.  BUT: I cannot see what is on it and so (not) select anything. I don't see it with the finder. I did do everything to make sharing possible. When connected directly to IMac it works fine. In airport I selected sharing etc etc.  I don't want the disk to be used as a backup system (via Time Machine). Just an extra network disk. Please help.

Time Capsule, iOS 5.1.1
  • Kenichi Watanabe Level 7 Level 7 (30,460 points)

    In the currect version of AirPort Utility, you need to go to the Disks tab.  Select the partition to share and Enable file sharing (check the checkbox), with the desired security options.


    Once that is set up, the shared device (not disk) should appear in a Finder window, in the sidebar under SHARED.  Select the device in the sidebar to connect to the shared disk (over to the right), using whatever security options you set up in AirPort Utility.  At that point, the shared disk will be mounted and you will be able to see the contents.

  • Keetje Level 1 Level 1 (0 points)

    Thanks for your answer. In the current version the disk is not te be seen.....not in airport utility not in Finder.  In the old version (5.6) it is and i already did those obvious things. As i described the device does not show up in Finder. anybody?...

  • Kenichi Watanabe Level 7 Level 7 (30,460 points)

    In my experience, not all external hard drives work reliably with my AirPort Extreme Base Station.  I had one that would connect, but it was extremely slow for data access.  I tried a different USB external drive, and it worked much better.


    I would suggest trying a different USB drive.  As a test, you could probably even use something like a USB flash drive, that is formatted for Mac.  Speaking of formatting...


    One consideration is the formatting.  I saw that you said it was "Apple formatted," but does that mean it started out being formatted for Windows.  If so, did you reformat it by erasing the volume using Disk Utility?  If you did, it may have retained the partition map scheme used by Windows.


    What you should do (and may want to repeat to make sure), is run Disk Utility and select the drive, NOT the volume indented under the drive, in the Disk Utility sidebar.  Then, go to the Partition tab (not the Erase tab).  Select 1 partition as the Partition Layout, and click the Options button.  Select either GUID Partition Table (default for Intel Mac) or Apple Partition Map (default for PowerPC Mac).  Either one should work; I'd go with the default choice for your primary Mac.  Click Apply to re-partition that drive.  Then, try it again on the Time Capsule.

  • Keetje Level 1 Level 1 (0 points)

    Thanks for your suggestions! I don't think the format is a problem. The disk is recognized by the airport utility (5.6).  I reformatited the disk the moment i took it out of It's box for yes the WD essential came as a Windows-formatted entity. Later I did partition the disk (guid). So i think i did do everything right, at least considering formatting disk. When connected directly to the IMac everything works fine.

    I have some questions:

    Why does the new airport utility not recognize / see the disk (version 5.6 does....)? So: what is the difference?

    What is necessary for the Finder to see a disk connected to the Time Capsule?

  • Kenichi Watanabe Level 7 Level 7 (30,460 points)

    I don't have a Time Capsule; I have an AirPort Extreme Base Station, which is similar except for not having the built-in storage.  Since your question got moved from the initial category (where you posted it) to Time Capsule, maybe someone else who has a Time Capsule will pop by with some advice.  If you don't get any more replies (other than from me), you may want to summarized what you learned so far, and post a new question (in this category).  New questions often get more views and responses.


    With a Time Capsule, you can share the built-in hard drive as general network storage (not just for Time Machine  purposes), is that correct?  Does that work for you?  Can you set that up using the latest version of AirPort Utility?


    If you set that up, I'm guessing it would appear in a Finder window in the same way.  The Time Capsule appears in the Finder window sidebar, under SHARED.  When you select it, the Time Machine's built-in shared volume appears to the right, and you can mount it using whatever security settings you used.  If you have an external drive attached to the Time Capsule as well, and it is set up to be shared, it appears as a second shared volume.  It is still just that one Time Capsule under SHARED in the Finder window's sidebar, but to the right, there are now two shared volumes.  But I don't have a Time Capsule, so I'm not sure about that...


    I don't know why the latest version of AirPort Utility does not see the external drive volume?  If possible, I would try another USB storage device (even if it's a 4GB thumb drive), to confirm it does work, and it's not a hardware problem on the Time Capsule's USB port.


    Also, if you have not tried so far, you may want to reset your Time Capsule (to give it a fresh start).




    This also has some relevant information about attaching a USB drive.



  • Chiu Keung Man Level 1 Level 1 (0 points)

    I found mine in Finder under Time Capsule in the side bar. i.e. click on Time Capsule first then it is listed on the right side.


    Oh... also, in the Airport Utility, make sure that enable file sharing is ticked.


    My question is how do I format a drive connected to the USB port of the Time Capsule? But not asking here... I will figure it out eventually.  Just too lazy to unplug it and connect straioght to my laptop :s

  • Kenichi Watanabe Level 7 Level 7 (30,460 points)

    how do I format a drive connected to the USB port of the Time Capsule?

    You have to format it while it is connect to the USB port of the computer.  You can't use the Time Capsule (or AirPort Extreme Base Station) to partition/format the drive.

  • Chiu Keung Man Level 1 Level 1 (0 points)

    Thanks Kenichi. I guess I can't take the lazy route.


  • Sp33doMcGee Level 1 Level 1 (0 points)

    I did this and it worked perfectly on the first drive I tried. (USB)


    Thanks Watanabe