5 Replies Latest reply: Jun 28, 2012 10:17 AM by stevejobsfan0123
SumanAli Level 1 Level 1 (0 points)

i opened up the app store on my ipod touch (3rd gen) to get an app, but there was a problem with the layout, usually when you look at an app, it previews pictures below the information, when i opened the app store, and clicked on a random app, these pictures werent there, instead there were rectangles/ tables/ columns? below the information :/

i also found that when i clicked on the "free" button to install the app, it disappears and then nothing happens, i have tried reseting the ipod by clicking on the on/off button and the home button at the same time untill the apple logo shows up, ive tried connecting it to my pc and opening up itunes, ive tried turning my ipod on and off and ive also checked my internet connection which is working fine :/ this problem only occurred today, it was working fine yesterday

please help :s


p.s i can update existing apps using the app store on my ipod, it just wont let me install any new ones :/

 



iPod touch