4 Replies Latest reply: Nov 13, 2012 7:40 AM by Stephane Plaisance
eweill Level 1 (0 points)

I am working with CUDA for my graduate degree and would like to be able to use it on my new laptop but for some reason I am unable to get it to work properly.  I have an older mid-2009 MBP that has a working version of CUDA.  I installed XCode from the App Store and then installed the 3 different files from NVIDIA needed to work with CUDA (CUDA Device Driver, CUDA toolkit, and Computing SDK).  After installing all of these and making sure my path variables are correct in the .bash_profile file, I tried running the deviceQuery only to find that I can't.  Here is the error message that I get.


[deviceQuery] starting...



./deviceQuery Starting...



CUDA Device Query (Runtime API) version (CUDART static linking)



cudaGetDeviceCount returned 38

-> no CUDA-capable device is detected

[deviceQuery] test results...



> exiting in 3 seconds: 3...2...1...done!


I'm not sure what the problem is.  I have tried downloading CUDA 4.2 and 4.0 and both give the same result.  If anyone has run into this problem will you please share with me what you did to solve it?  Thanks.

MacBook Pro with Retina display, Mac OS X (10.7.4)