10 Replies Latest reply: Mar 10, 2013 3:05 AM by vespuccio
threeapple Level 1 Level 1

Fresh Windows 7 install with updates.

Fresh iTunes 10.6.3 install with quicktime.

Core2 Q6600, 8gb ram, 256gb SSD, ATI 6870

 

My HD video movie/podcast playback in itunes is still choppy and stuttering. Seek time when skipping video segments takes seconds for video to catch up to audio. Once in a while the video will skip for freeze. Fresh install on new computer and CPU utilization while video is playing is only 30% so its not hardware issue, and all new fresh installs so its not installation issue. My hard drive is SSD so its not loading slow.

 

However, all the SD video plays fine. Zero issues. Something must be wrong with iTunes/Quicktime for windows. All my HD 720 or 1080p content plays fine using 3rd party players like VLC.

 

 

Anyone found a fix or work around?

  • wiclee Level 5 Level 5

    See if this article will help:

    Troubleshooting iTunes for Windows Vista or Windows 7 video playback performance issues

    http://support.apple.com/kb/TS1718

  • threeapple Level 1 Level 1

    Tried it with no success. GDI safemode didnt do much. I dont have flash usb. Resolution already native at full 1680x1050

  • wiclee Level 5 Level 5

    Repair your QuickTime.

     

    Control Panel > Programs n Features > highlight QuickTime, click CHANGE then REPAIR.

     

    If that doesn't improve, go to

    Control panel

    Sound (Hardware n Sound)

    Under Playback tab, highlight each device and click Properties button

    Go to Advanced tab and change Sample Rate to 16bit 48000hz (DVD Quality) or 96000hz (Studio Quality), OK n OK.

  • threeapple Level 1 Level 1

    That didn't work either. Any other suggestions?

  • wiclee Level 5 Level 5

    Do you have wifi sync turned on?  If so, turn it off temporary and try again.

  • threeapple Level 1 Level 1

    nope. Sync over iphone is not enabled or checked.

  • Austin4221 Level 1 Level 1

    This was happening to me and driving me nuts.  I found someone online that had me go into Realtek HD Audio Manager and change the "Default Format" around.  I set mine to "16 bit, 192000 Hz (Studio Quality) and that fixed my iTunes for playing shows.  I actually had to try all the 16 bit setting until I found the one that worked for me.  Hope it helps....

  • TripleR309 Level 1 Level 1

    Same here, still having this trouble. I have windows 7 and im not sure if its the RAM (though it meets the requirements of apple) any luck? =/ or even a way to watch it in SD if needed? either way, i want to watch it without it becoming unsynced.

  • JustinRossi Level 1 Level 1

    This is nearly the exact solution that worked for me! Thank you, Austin4221.

     

    What I did is the following:

     

    Within "Control Panel", I chose "Sound".Control Panel.png

    Then, on the "Playback" Tab, I chose the "Default Device".Sound.png

    Then, on the new window, I chose the "Advanced Tab". Default Device.png

    Within the "Default Format" section, I started with the highest quality and then went down the options one by one until the video played back properly.

     

    I hope this help you.

     

    Thanks again, Austin4221.

  • vespuccio Level 1 Level 1

    Hi

        Changing the audio playback rate nailed it !!    Why was mine set at the highest rate and studio quality ? who knows certainly haven't changed it .

     

    Thanks a million this issue was driving me nuts !