8 Replies Latest reply: Aug 23, 2013 11:12 AM by Fotoking
Natalia_Lanfear Level 1 Level 1 (0 points)

I have a series of problems with my Thunderbolt display 27` (connected to MacBook Air i5):


1. When Thunderbolt is connected, wifi speed is VERY slow (e.g. 20 kbit/sec), while when it`s disconnected and I use MacBook Air - wifi speed is ok (e.g. 1Mbit/sec).


2. When I disconnect MBA and then connect again, Thunderbolt doesn`t see the usb keyboard connected to it. Sometimes it helps to restart, sometimes it doesn`t.


3. When connecting to MBA it takes a LONG time for TB to realise it should start, if connected/disconnected a couple of times only a manual restart helps.


Is there any way to solve these issues?


Many thanks in davance!

Thunderbolt Display, Mac OS X (10.7.4)
  • Bluedevil2001 Level 1 Level 1 (0 points)

    I have issue 1 as well.  Solutions please?

  • smkd Level 1 Level 1 (0 points)

    Same issue as 1/


    When a second display is connected thru thunderbolt on my late 2011 mbp, i lost wifi bandwidth. If i disconnect the secondary screen everything comes back to normal.


    Note i've same setup at home and no problem, it's very annyoing and i can't figure it out.

  • rich.plevin Level 1 Level 1 (0 points)

    There seems to be a general problem with Thunderbolt. In my case, I've had problems both with the firewire and the ethernet adaptors, where I frequently have to monkey with the connections (plug in and out, unplug external display...) to get either to work. There are others in this forum complaining about major USB issues (dropped keystrokes, etc.) and display issues. I've had the "external screen full of static" problem intermittently, too.


    So all fingers seem to point to Thunderbolt. FWIW, I'm running 10.8.3 on a late-2012 retina MBP with a Dell U2412M monitor (1920 x 1200) connected. Thunderbolt firmware version 14.1. (And oddly, although I'm happily using my external monitor, the System Report indicates no Thunderbolt devices are connected.


    Is anyone else having multiple Thunderbolt problems?

  • Mykii Level 1 Level 1 (0 points)

    Strange, I have some other random issues as well-- my TBD's ethernet doesn't work and the USB goes out intermittantly. There's also some weird screen blob that appears if I wake it up right after it goes to sleep. This is both on my 2012 11" MBA and my 2011 15" MBP... and I'm running the new software updates for Thunderbolt as well as 10.8.4.

    Perhaps I'll just take it in for AppleCare

  • Fotoking Level 1 Level 1 (0 points)

    YES - my side Cinema Screen keeps blinking off and on, then completely off!. VERY annoying and about time Apple came up with a FIX!.

  • Fotoking Level 1 Level 1 (0 points)

    I just noticed you said you might take it to AppleCare. They cannot help, been there done that.

  • Mykii Level 1 Level 1 (0 points)

    I'm having crazier issues now-- the TBD won't wake up anymore. I can hit the mouse button and then the Apple on the MacBook will light up, then turn back off. The TBD doesn't even do switch on at all.

  • Fotoking Level 1 Level 1 (0 points)

    My only issue (as far as I know) is that the side screen blinks off and on after a short while of being on. Then eventually it goes off and does not come back on. The only option I have found is to turn off ALL power for a few minutes and then re-start the I-Mac and the side screen comes back - but again only for a short time and then OFF again. Does not seem to cause any other problems with the I-Mac. To say the least VERY aggravating, especially after having to spend over $30 for the Thunderbolt connector!. GGGRRRR. Where are the Mac EXPERTS????.