Previous 1 2 Next 23 Replies Latest reply: Feb 22, 2013 3:08 PM by Stock^
mlinklater Level 1 Level 1

Hi - when I try to preview my book on my iPad my device doesn't show up on the preview list. I have latest versions of everything, a new iPad and I'm running the iBooks app on the ipad.


Anyone give any suggestions as to why iBooks Author can't see my iPad ?



  • K T Level 7 Level 7

    Connect your iPad directly to your computer...not thru a hub or external drive.


    Open iBooks on your iPad, then use Preview from iBooks Author.

  • MichiHenning Level 4 Level 4

    Quitting and restarting iTunes and IBA often helps.



  • mlinklater Level 1 Level 1

    Thanks guys - tried both those suggestions but it still doesn't show up. 8(


    Not impressed Apple.

  • MichiHenning Level 4 Level 4

    Does you iPad work otherwise? Is it visible in iTunes and can you sync with it?


    If you export a book as .ibook and drop it into iTunes, can you sync the book with your iPad then?


    By the way, you do know that you need to connect your iPad with a USB cable for the IBA preview feature to work?



  • AARCO Canary Islands Level 1 Level 1

    Same problem :-(

  • JMF Level 3 Level 3

    +1 for me.


    Did a clean uninstall of iBooks Author with App Cleaner, reinstalled. Fresh reinstall of iOS 5 on an iPad 2. iBA does not list it under "Devices". When I plug it in, it flashes for a split second, then disappears. Restarted the iPad and the Mac. Definitely running the latest version of iBooks for iPad and it's open when I try to preview. Nothing works.

  • MUresidenteinstein Level 1 Level 1

    Do you have ibooks open on your ipad?  That was my problem - opened it, synced, then closed and reopened IBA - finally asked me to prepare a preview for ipad and it worked!

  • JMF Level 3 Level 3

    Yes. Reinstalling OS X was the only solution. Works now.

  • Antonis20vt Level 1 Level 1


    I have the same problem on my MacbookAir. The iPad shows for a split second on the device list and then disappears.


    Needless to say that I am doing everything right... connecting my iPad2 and having iBooks 2 running.

    I have the latest ibook2, latest version and fully updated MacOS X Lion, latest iTunes which I re-installed in order to try and solve the issue without any positive outcome, latest version of iBook Author which I also re-installed without any luck.


    Furthermore, my iPad2 works fine with a collegues MacBook Air, while a second iPad that we have at the office also does not work on my Mac. Same cables used at all times.


    On the other hand, I can see the iPad via iTunes and I can sync ibooks created with iBook Author (created + exported) using iTunes without any problem at all!


    I can see some errors related to iBooks Author at my Mac's console, but I really cannot understand what they mean...


    for example:


    AMDeviceCopyValue (thread 0xad2432c0): Device 1 got error 0xe8000016 copying value [(null), UniqueDeviceID].


    AMDeviceSlowLookupBreak (thread 0xad2432c0): AMDeviceLookupApplications was called without specifying an options dictionary containing kLookupReturnAttributesKey. This usage is inefficient and may cause performance problems. Break on AMDeviceSlowLookupBreak to debug.



    etc etc etc....



    Apple... Please help... this is very frustrating.

  • JMF Level 3 Level 3

    I called Apple about this and got up to Tier 3 tech support. The only solution (for me) was to do a completely clean reinstall of OS X. After a fresh install, I tested iBooks Author and it worked just fine. However, after restoring my settings from a Time Machine backup, the bug resurfaced. Ergo, whatever was corrupt was also imported and was therefore borked again.


    I thought perhaps my own user account was corrupt, so I made a second test account. Same problem, it never saw the iPad. Whatever was wrong was wrong at the system level.


    The only way I was able to remedy this was to do a clean install of OS X and reinstall my stuff manually. I couldn't recover from TM because it kept importing the bug.


    YMMV but that was the only solution that worked for me.

  • Antonis20vt Level 1 Level 1

    Thus, are you still waiting for a resolution from Tier-3 tech support or thery were not able to help? Did they aske for your Mac's logs?


    I just tested it on one of the iMacs in our office and it has exactly the same problem as my Air... A common thing between my Air and the iMac is that both have xCode 4.3 + xCode 4.5 Preview 3 + SDK 6.0 installed, while the Air of my collegue that works fine has only xCode 4.3.

    It might be completely irrelevant, but I am trying to find a pattern here just in case we can isolate the cause of the issue.


    We are going to run some tests on a couple more Macs very soon in to see if it leads to any conclusions.

  • JMF Level 3 Level 3

    Tier 3 support and I agreed that there was nothing else to troubleshoot aside from reinstalling OS X. I am not waiting on a resolution, and they were not able to solve my dilemma.


    I had XCode 4.5 DP2 installed at the time and iOS 6 on an iPad 3, and iOS 5 on an iPad 2. Neither iPad was seen by iBA at the time. I don't believe I can get into specifics in this forum without violating the Developer NDA. I will say after reinstalling OS X, the iPad was seen, even with dev builds of Xcode installed.


    I'd be interested in learning if you discover a pattern and find a solution. Please keep me posted on this thread of your findings, especially if you can fix it without having to reinstall OS X. If you solve it, I will also send along your fix to the gentlemen who helped me at Tier 3. Maybe it will benefit others that way, too.


    Good luck.

  • Antonis20vt Level 1 Level 1

    Hi all!


    After numerous tests, it seems we have defined the cause of the problem.


    YES the problem is most likely caused by the installation of XCode DP 4.5 + iOS6 sdk.


    We tried 6 different Macs. The 2 that had DP installed were facing the iBooks preview issue. All other 4 Macs were working perfectly fine.

    Then, just to make sure, we installed XCode 4.5 DP on one of the Macs that was working perfectly fine afew minutes ago... and voila! It immediatelly stopped previewing properly!!!


    The sad fact is that the problem is NOT solved when XCode 4.5 DP is removed...


    Thus happy we pinpointed the cause of the problem... but sad that we still have no solution. We hope that Apple will provide a fix ASAP.

  • jem5519 Level 1 Level 1

    I am in the same boat as you. Getting the exact same flash behaivor with IBA and plugging in my iPad. I too installed XCode 4.5 briefly and uninstalled it (whatever that really means). I don't want to do a clean install of OS X. Does anyone have an issue number for this "gift from XCode 4.5?"

Previous 1 2 Next