5 Replies Latest reply: Jun 30, 2012 12:00 PM by mende1
candycefrompa Level 1 Level 1

i have the mac os x 10.4.11 and i want to install itunes but it says i need a new version. this is ridulous. alls i want to do is plug my iPod touch in but it says i need to install a new iTunes. I am so fed up with apple today

Solved by Allan Eckert on Jun 30, 2012 11:57 AM Solved

The new version of iTunes probably needs either 10.5 or 10.6 to install.

 

If your Mac meets the hardware requirements for 10.6 that would be the cheaper way to go.

Reply by mende1 on Jun 30, 2012 12:00 PM Helpful

Snow Leopard costs 29$, so it isn't as expensive as Leopard

All replies