Previous 1 2 Next 16 Replies Latest reply: Jan 12, 2015 6:15 AM by ViktorLin
Whitefamily996 Level 1 Level 1

Can any one help, my remote app works for a while then says enable home sharing , but it's already enabled and I'm still able to stream content just not use the remote app?

iPad, iOS 5.1
  • bhertz Level 1 Level 1

    I have been having a problem similar to what you are describing. I have been using the Remote App on several of my devices for quite some time. Just recently I have found that the App will connect to my main iTunes library and let me control my music, but a short while later it can no longer find the library. If I exit iTunes and relaunch it; the App finds the library again. Very very annoying. This appears to be something in the main iTunes installation itself since I have an older, second library that the App can find reliably. Also, the closing and reopening of iTunes allows the connection to occur again, without any action taken on the Remote App itself.

  • freediverdude Level 1 Level 1

    Yes I have been having this problem also.   Just all of a sudden my remote app on the iPhone 4S will not connect to the Apple TV 3.   I confirm that home sharing is on, on all 3 devices, the iPhone, the Apple TV 3, and the iMac.  It's all up and running, Apple TV works fine with the Apple TV remote, Apple TV streams shows just fine, wifi is working, etc., but the remote app on the iPhone will not connect and work, says "turn on home sharing".  Very frustrating.  Usually the ONLY thing that will make it work is to reboot the router, which is a pain in the butt for me.  Also the Apple TV has been just randomly disconnecting from the wifi here and there, right in the middle of watching a show.  Just long enough to disconnect everything and go back to the main menu, and then it reconnects and I can go back into the show.  Again very frustrating.  And this really only has happened recently since the last update or two.  Nothing else has changed.  I've had the original Apple TV since the week it came out in 2006 or whatever, and then the Apple TV2 since that came out, and now the Apple TV3, and everything was pretty much fine until now.  Same router and everything.  So I'm not buying that it's a local problem with my network.

  • SHDub Level 1 Level 1

    have exactly the same problem, and did tune off and unplug router for a few minutes and the problem remains. Any other solutions?

  • Jookie7 Level 1 Level 1

    Also having the same problem. My phone and iPad just won't connect to apple tv. It's always been a crapshoot but now it's gotten even worse.

  • Winston Churchill Level 10 Level 10
    Mac OS X

    Intermittent problems are often a result of interference. Interference can be caused by other networks in the neighbourhood or from household electrical items.

    You can download and install iStumbler (NetStumbler for windows users) to help you see which channels are used by neighbouring networks so that you can avoid them, but iStumbler will not see household items.

    Refer to your router manual for instructions on changing your wifi channel or adjusting your multicast rate.

    There are other types of problems that can affect networks, but this is by far the most common, hence worth mentioning first. Networks that have inherent issues can be seen to work differently with different versions of the same software. You might also try moving the Apple TV away from other electrical equipment.

  • Dathonysmail Level 1 Level 1

    I have a similar issue. All of a sudden my remote app can only find my one apple TV 2. It can not fine my second one. I am stuck using the silver remote for the second Apple TV. Ideas?

  • TucsonRon Level 1 Level 1

    Same problem as others described here.  Have been using iPhone remote to operate my Apple TV2 quite nicely UNTIL recently the remotes goes to music library and DOES NOT let me use the Remote to operate my Apple TV.  Tried suggestions in this discussion.  Still DOES NOT let me use the Remote to my Apple TV2.  Like Dathonsmall said  I am stuck using the silver remote for the second Apple TV. Ideas?


  • martininberks Level 1 Level 1

    I had a similar problem with Apple Remote initially connecting ok to iTunes, allowing me to stream my iTunes Library via Apple TV2, and then randomly losing the connection. Very frustrating. I do not think this is an Apple TV 2 problem - I was able to stream Internet radio and music already loaded onto my iPad all day without problem via ATV2.

    I think the problem rests with latest release of I Tunes and Home Sharing.

    What seems to have cured it for me was to Restore my Apple TV2 to factory settings ( Menu>General>Reset>Restore) and, once the restore was complete, then reconfirm my Apple ID and Password in the Apple TV Home Sharing menu.

    It has been running for 3 days now, touch wood, without any dropouts.

    However, looking at the number of posts on similar related issues in Apple Support Communities this is a problem Apple needs to fix quickly with an update.

  • JH96 Level 1 Level 1

    I had this problem untill on windows vista, I reset my wireless network adapter settings. To do this, go to network sharing centre, manage network connections, and right click on wireless network connection. In the drop down menue, there is a diagnose button, click it. A box will appear saying report a problem to microsoft or the reset network adapter. Click reset. After a while, another box will appear saying it has been reset. Then open the app on an ios device and it should work perfectly. By the way, I only tested this on an iPad 2 Wifi only model, not yet on iPhone/iPod.

  • Ruud Altenburg Level 1 Level 1

    Similar problem here with fully up-to-date iMac (OS X 1.8.2 and iTunes 10.7), Apple TV 3 (OS 5.1) and Remote app. Remote finds the iTunes library, but as soon I click a *large* music track to play (about 60 min long), I'm being thrown out and getting the "Connecting to Apple TV" screen and/or the app simply crashes. Remote has problems displaying playlists from time to time, just showing the Loading... message.


    I have no such problems with using the real remote. Looks like the Remote could use an update...

  • greeedyy Level 1 Level 1

    All you have to do is restart your device and itunes it should work after. It works for me hope this helps

  • uneek777 Level 1 Level 1

    sorry, but this doesn't help at all.


    NOTHING helps. it always says no library found.

    i have tried EVERYTHING on the apple support site. but NOTHING HELPS!!!!!!

  • uneek777 Level 1 Level 1

    ...and i even deactivated the firewall. my mac is completely open to all the hackers now. and it still doesn't work. i really don't understand why it shouldn't be possible to remote control itunes from the iphone anymore...

  • uneek777 Level 1 Level 1

    now magically it works again - i signed out from the itunes store and signed in again and all of a sudden the remote app works again.


    wondering for how long...



Previous 1 2 Next