Previous 1 2 3 4 Next 48 Replies Latest reply: Jun 27, 2015 10:31 AM by rdh2001 Go to original post
  • Aearenda Level 1 Level 1

    I just registered so that I can offer thanks to STUPENDOUS! for the firmware update link. I could not find this on OWC's web site. I just got a new Macbook AIr, with USB3, and my Voyager Q would not work properly with it. Other USB3 devices were fine so long as the cable was not long. The firmware update fixed it. To make the update run as it is designed to run, do it on a machine running Windows XP natively. I didn't have one, and did it by trial and error using VirtualBox.


    The USB device ID and serial number changes during the update process, rather like a USB modem can. This will confuse software such as VirtualBox (and VMware, I assume), since VirtualBox etc. will not claim the 'new' device until told to.


    I used a Windows XP 32-bit VM running in VirtualBox to apply the update. Here is what I did - of course I'm working from memory here, since the update is now done, and I can't double-check everything. YMMV, don't blame me if yours goes wrong.

    1. I attached my Voyager Q (with a spare disk in the slot, otherwise nothing happens) using USB2 on an older Macbook Pro, which does not have USB3.
    2. I set VirtualBox to route the "OEM USB3-to-Sata bridge device" to the Windows XP VM, and started the VM.
    3. After letting XP recognise and install the drive, I started the firmware updater, and it triggered the first USB device ID change. The 'new' device was not claimed by VirtualBox. The firmware updater timed out and failed.
    4. Leaving the Voyager Q on so that the device ID did not change back yet, I shut Windows XP down, and set VirtualBox to route the new unrecognized USB device to the XP VM. It only showed the USB ID string as 'Unknown device 0525:8000 [FFFF]', no 'friendly' name. In theory, I should have been able to do this without closing the VM, but I didn't try.
    5. Then I turned the Voyager Q off to return it to normal, and started Windows XP in the VM again.
    6. I turned the Voyager Q back on again after XP had settled down, and restarted the firmware updater.
    7. After the device ID change, the device was reattached to the VM, and XP came up with a 'new hardware found' dialog; I told it not to search but rather to use the driver in the i386 drivers folder that was included with the firmware updater (in 'USB 3 Voy Firmware update (xp 32-bit only)\Drivers\PlxUsb\i386')
    8. The firmware updater had timed out again while I was doing this, so I turned the Voyager Q off, restarted Windows XP (again, this may not have been needed, but better safe than sorry), turned the Voyager Q on again, and restared the firmware updater.
    9. The first stage of the firmware updater now worked, and the device ID changed back - but with a different serial number, so I had to tell VirtualBox to claim it again! I repeated steps 4, 5 and 6, except that this time it had the same USB3-toSata 'friendly name' as it had at first, but the serial number change was noticed by VirtualBox otherwise this step wouldn't have been needed.
    10. This time the firmware updater said it had completed successfully!


    Fortunately the updater is very resilient to failure, and did not brick the Voyager Q. This was a real danger, and as I said, it might happen to you if you try this. Don't blame me if so. Have fun!

  • rogvideoproducer Level 1 Level 1

    I seem to still have this problem. My new MBPr arrived 12/28/12 and I have not been able to get the Voyager Q to work at better than USB2. I just downloaded the firmware update from newertech (the link is not public -- I had to have a support person give it to me) and installed it with an old XP laptop. According to the firmware updater the update was successful. However, the Voyager Q is still only seen as a USB2 device.


    I can note that I had the firmware update timeouts too and it just took a few times before it was able to complete.


    SInce I just downloaded the firmware update and it does not work for me and my MBPr is new I am not sure what to suggest. I'll try their tech support again.

  • STUPENDOUS!!! Level 1 Level 1

    I went to apply the updater, but it said that my Voyager Q was already at the version of the update. But it will not mount a drive on USB3 connection to my mid 2012 MacBook Air. I have spoken again to OWC but they basically say it's my problem, and have left me out in the cold pretty much. I live in NZ and it would cost so much to ship one or both Voyager Q docks back to OWC that it doesn't seem worth it. But meantime I have other USB3 devices that work fine with my MBAir, so I'm sure it ain't my USB3 ports on my MBAir. It has to be the Voyager Q dock.

  • Aearenda Level 1 Level 1

    I find it is sensitive to the cable length and/or quality - the shorter the better. Other than that, I've encountered no further problems on my MacBookAir5,1.

  • STUPENDOUS!!! Level 1 Level 1

    I have a very short and quite OK USB3 cable, but it won't mount a drive via USB3 on my MacBookAir5,2

  • Aearenda Level 1 Level 1

    With a drive mounted using USB2 (a USB2 hub will force it, or do it on an older Mac), what does System Information (Apple->About this Mac, click 'More info') show for your Voyager Q, under "Hardware->USB" then "USB High-Speed Bus->USB3-to-SATA Bridge Device"?


    On mine it says (omitting irrelevant bits to do with the drive itself):

    USB3-to-SATA Bridge Device:


    Product ID:          0x3100

    Vendor ID:          0x0525  (PLX Technology, Inc.)

    Version:           0.00

    Serial Number:          2020202020204D5043434E38593348555431424C

    Speed:          Up to 480 Mb/sec

    Manufacturer:          OEM

    Location ID:          0x26400000 / 3

    Current Available (mA):          500

    Current Required (mA):          500

    Partition Map Type:          GPT (GUID Partition Table)


    The serial number changed when the firmware was updated, and it looks like an ASCII string now - it says "MPCCN8Y3HUT1BL" preceded by 6 spaces. I'm using OS X 10.8.2  for this.

  • STUPENDOUS!!! Level 1 Level 1

    Unfortunately I am away from home until about Jan 22, but will check at that time. Thanks for your communication. I hope we can work it out.

  • bjornga Level 1 Level 1

    Great discussions, it's unfortunate that Newertech and OWC take no ownership. "We don't have a mac solution yet" is preposterous. I don't mind spending time to look for ways to keep going but the workaround using the windows fix is ludicrous. Reviews of the Voyager q on the largest internet store in the universe reflect the lack of support by OWC for the product. Next step: try a thunderbolt to firewire converter for the new macs. Any experience out there with the converter??

  • rogvideoproducer Level 1 Level 1

    rogvideoproducer wrote:


    I seem to still have this problem. My new MBPr arrived 12/28/12 and I have not been able to get the Voyager Q to work at better than USB2. I just downloaded the firmware update from newertech (the link is not public -- I had to have a support person give it to me) and installed it with an old XP laptop. According to the firmware updater the update was successful. However, the Voyager Q is still only seen as a USB2 device.


    I can note that I had the firmware update timeouts too and it just took a few times before it was able to complete.


    SInce I just downloaded the firmware update and it does not work for me and my MBPr is new I am not sure what to suggest. I'll try their tech support again.


    Well -- I have been a Mac user since the Mac Plus so I don't usually consider myself a "newbie"; however, in this case I apparently am. The issue I had was a missunderstanding that if you boot your rMBP and use a USB2 device the USB will then be configured for USB2 even if you later add a USB3 device. When I tried the Voyager Q a second time it operated as USB2 since that is how my rMBP was configured. After a reboot the rMBP reconfigured USB to be USB3. What I have learned is that if I reboot my rMBP I must immediately plug in a USB3 device or at some point down the road this problem will come back to frustrate me.


    This functionality seems very un-Mac-like to me. I am from the era when "Macs just work" and do not understand by a USB3 port is sometimes USB2 or USB3.


    I found this USB3 FAQ:


    It says:

    What happens if I plug in a USB 2 device into the USB 3 port first?

    If you plug in a USB 2 hub first, all devices connected or "daisy-chained" to that hub will operate up to the maximum transfer rate of USB 2 speed (480 Mbps).


    I can easily see how this applies to daisy-chaining. However, if the USB2 device is no longer connected and the only connected device is USB3 I would wish for the port to act as USB3.


    Hopefully this is of assistance to someone looking at this thread.

  • bjornga Level 1 Level 1

    Thanks for that rogvideoproducer. I have added it to my log.

  • ChazH Level 1 Level 1

    Based upon the original discussion, to the best of my knowledge, this issue still has not been corrected. I am waiting for Apple to fix the USB 3.0 issue, but so far, no luck.


    I have a friend who bought a 15" rMBP when it first came out. He has been in negotiations with Apple nearly ever since regarding USB 3.0. So, he has owned (and returned most) 14 USB 3.0 hubs, none have worked well. He owns 5 USB 3.0 drives, maybe more. We have gone through many troubleshooting steps, and found that some hubs worked better than others, and some drives better than others, but nothing was consistant. He has Win7 on  Bootcamp partition, so I had him try that, same thing, inconsistant results.


    We had another friend with a Win7 PC portable try what we had been doing with the rMBP, the PC worked flawlessly. Well, there was one minor thing, but I'm pretty sure it was a user error, not the machine's fault, and it was very minor as compared to the sometimes not recognizing drives on the rMBP.


    So, this points to most likely the SMC firmware on the rMBP, at date of writing this 2.3f32, and boot ROM is MBP101.00EE.B03 (it's .B02 on my friends rMBP), I checked these facts with the very latest that Apple has released at the Apple Store. It's unlikely the boot ROM will have an impact of the functioning of USB ports, more likely the SMC which controls nearly all interfaces.


    It is possible, but less likely that Apple has bad drivers in both Mac OS X 10.x for USB 3.0, and bad drivers for bootcamp. So I'd stick with the SMC firmware to be the most likely culprit.


    If anyone hears about a firmware update for rMBP, could you please post it on this thread? I will keep watching for the same.

  • luthierbytrade Level 1 Level 1

    I just had this issue with a new 27" iMac. (Shipping late 2012)


    As I read above, the issue is with OWC, not Apple. I've had problems getting help from OWC before so this is the final straw for me.


    I tried running the Firmware update via Parallels. Initially it did not even mount the drive in Windows 7, but I installed something called


    and then it recognized the USB3 in windows.

    However, when I tried to run the firmware update again (with the drive recognized) it always says "No supported drive found."


    Does anyone know how to install this firmware update using Parallels?



  • bewillia Level 1 Level 1

    For people who are having this problem and stumble onto this thread, I've finally been able to successfully upgrade the firmware on two Voyager docks via Parallels.  This is what I did.


    1) Format a new HDD as a MS-DOS (fat) drive in Disk Utility on the mac side.

    2) Open Parallels

    3) Instert the MS-DOS drive into Voyager and plug it in via usb3.  Mount it on your virtual windows machine.

    4) Once the drive has mounted in Windows (if it doesn't, I don't know what to tell you) open the firmware updater (found here) and run the update.  If it doesn't find the drive, close and try again.


    The drive will unmount from your system a couple times during the updating process.  You may have to tell Parallels to mount the device in your windows environment one or two more time.


    Good luck.

  • Crozlo Level 1 Level 1

    This worked for me via Windows XP!

    STUPENDOUS!!! wrote:


    I have the Updater and have written to OWC for instructions. Will report back here. USB 3 firmware Updater for Voyager Q 20(xp%2032-bit%20only).zip


    via iPhone


    I have had a Quad Interface NewerTech Voyager Q with USB 3.0 for several years now, but have never been able to use it's USB 3.0 interface with my 15" MBP Mid 2012 (which does support USB 3).  It would erratically mount and unmount, and hang whenever a data access attempt was initiated.


    After borrowing a Win XP Virtual Machine and performing the firmware update today, I FINALLY have USB 3.0 functionality!  Amazing that this firmware update is still out there but so incredibly difficult to find.


    The update almost failed a couple times - it was a little sketchy.  Upon the initial pass it disconnected the USB interface, and then windows automatic driver wizard took over and failed.  I added the drivers included with the firmware updater manually using the Windows wizard, then repeated the firmware update.  The firmware updater couldn't get passed "Resuming Update" for several minutes, so I closed the firmware updater and repeated it a THIRD time, and it was successful.  BTW I performed the firmware upgrade via USB 2.0, not that it would make sense for that to matter, but still.


    Sketchy to say the least, but now my Voyager Q is fully functional for USB 3.0 on my MacBook Pro mid-2012!


    Super happy.

  • STUPENDOUS!!! Level 1 Level 1

    I believe I might be due some "points" if several people are happy? ha ha... isn't that how it works?

    Anyway an update on my situation, I have now got a late 2013 MBPro 15" retina (Quad 2.6GHz 1TB SSD 16GB RAM) and I'm connected via Thunderbolt 2 to a Belkin Thunderbolt Express Dock. In the back of this are a bunch of USB 3.0 ports (amongst others FW800, Ethernet, Audio in/out) and all of these USB 3.0 portswork sweet with the Voyager Q SATA docks. I also have a dual SATA HDD Thunderbolt dock, so I can run 4x SATA drives at once now. It seems it might have been a hiccup with those mid 2012 MacBook Airs and a few other models, as mine still doesn't like the USB 3.0 connection to the Voyager Q dock, despite the update. But I'm not worried because I use the 15" for Final Cut Pro and pretty much everything else now.