1 2 3 4 Previous Next 46 Replies Latest reply: Aug 27, 2013 3:03 PM by qahtani
drbeckmd Level 1 Level 1 (0 points)

iTunes 10.6.3 home sharing not working properly.  I can access with my three ATV2's watch a movie later that same day it tries to access and ATV2 just keeps trying and never gets through to the library.  If I restart iTunes its fine then later can't access.  I am running iTunes 10.6.3 on a i7 Mac Mini with 10.7.4.  Sole job is to be iTunes server and an occasional HTPC with remote buddy running.  I disabled remote buddy ajax remote feature, and file sharing is on so I can load new tracks form other macs Thats it, a vanilla install with all updates.. No problem prior but not sure if problem free period was with 10.6 earler versions or 10.5 versions.  I update as warnings to do so come up.  The remote app has same problem accessing the Home Share.  I disabled home sharing on my iPhone and set to access the old method with 4 digit code and sees all the time and will play to my express base stations so seems to be home sharing issue because iPhone apps with home sharing on and ATV2s have issue accessing.

I'm never home but when I am I use this equipment loads and this weekend not reliable at all.  I have firewall disabled, and setup is as before and is working fine.  I am using Mini by ethernet and using AEBS 1st generation gigabit as router only wired to cable modem and whole house ethernet attached, latest version AEBS gigabit as a wireless bridge and 2 prior version 11n expresses and a 11g express, all expresses are set to wireless off and are connected to ethernet and then to a stereo in 3 different rooms.

I can't be only one.  Considering downgrading to last version of 10.5 but not sure how to do this.

How many of you are having trouble?

Any resolutions?

How to report to Apple?

How to downgrade safely? Or is it 10.7.4?


iTunes home sharing 10.6.3, Mac OS X (10.7.4)
  • 1. Re: iTunes 10.6.3 home sharing not working properly
    nanochow Level 1 Level 1 (0 points)

    I have the exact same problem using ATV3's.  Pretty sure it's an iTunes issue that happened during one of the recent upgrades.

  • 2. Re: iTunes 10.6.3 home sharing not working properly
    Troy The Man Level 1 Level 1 (0 points)

    Looks like this is a big problem affecting all iTunes and Apple TV users since the 10.6.3 update. I am constantly having to close down iTunes and re-open to activate Home Sharing.

    I am very surprised that Apple haven't released a 10.6.4 update yet to fix this, as it has been going on for over a month I think.

    Come on Apple, how hard can it be?

  • 3. Re: iTunes 10.6.3 home sharing not working properly
    Big Robs Level 1 Level 1 (0 points)

    I ran into the specific problem in another thread.  There are more than 100 connections from the apple TV's to iTunes.  You can do a netstat -a (windows or Mac), and verify the problem.  iTunes is smart enough to stop allowing more than 100 connections but stupid to allow the ATV to create so many connections.

     

    Now for what you really want!  Set all of your ATVs to wifi only.  Even setting the iTunes host to wifi might help also.  I think that wifi is more unreliable, and forces connections to drop, keeping the count under 100. 

     

    I also turned off ip v6.  That could help you also.  I originally had problems on a Mac mini, and built a windows 7 box to try to fix the problem.  The wifi trick worked on both platforms.  Several of us have bug reports into apple.  I have a wired house also, and am very angry to NEED to use slow wifi to overcome this problem.  The ATV gen 3 has been able to keep up with 1080p over wifi, so it doesn't hurt too much.  What really hurts is spending over 40 hours troubleshooting this bug.

  • 4. Re: iTunes 10.6.3 home sharing not working properly
    davek21 Level 1 Level 1 (0 points)

    I have run into the same problem numerous times.

     

    I have the latest AppleTV 2 software update and iTunes 10.6.3

     

    After an hour of pulling out my hair, on a whim I tried a last ditch effort and it worked. On my AppleTV 2 I turned off Home Sharing, then when I turned it back on, instead of just clicking my exiisting Apple ID, I signed back into Home Sharing as a different Apple ID, but using my same Apple ID and password. Essentially just re-entering my Apple ID and password... and Bang! it worked. Hope this helps.

  • 5. Re: iTunes 10.6.3 home sharing not working properly
    6tones Level 1 Level 1 (0 points)

    Apple TV3 can access Shared iTunes Library's but streaming from iTunes 10.6.3 to Apple TV3 doesn't connect. Have iMac 27", Macbook Pro '09 and TimeCapsule for router. The best senario for Apple"s sharing between it's own devices. However, still not success.

     

    Need update please!

  • 6. Re: iTunes 10.6.3 home sharing not working properly
    drbeckmd Level 1 Level 1 (0 points)

    I think I figured out a solution.

     

    1 I am using a new ATV3 and 2 ATV2s

    2 The post above about the connections that the ATV is making to iTunes or is it the other way around? I set my ATV3 to never sleep

    3 it worked, if I set the ATV3 to never sleep problem is solved

     

    Don't know why but ATV3 is the culprit, set it to never sleep, the light will stay on and access is fine by it and all other devices to the Mac Mini HTPC server.  My ATV2s are still set to sleep at 15 minutes.  Hope this helps someone.

     

    PS I did do a full reset to factory on the ATV3, no luck.  After a few hours after it has gone to sleep it screws up access by all other devices to the iTunes share.  Not sure if it is the device or is it iTunes 10.6.3 interaction with the device that is the problem.  The ATV3 is never even warm used or idle or asleep, so I assume power consumpiton on and idle is about the same as sleeping.

  • 7. Re: iTunes 10.6.3 home sharing not working properly
    John Harbaugh Level 1 Level 1 (45 points)

    I'm having the same problem in that Home Sharing errors out, "Home Sharing could not be activated because an error occurred (5599)".  I don't have any ATV's, just a wireless MacBook Pro,, Haven't found a solution yet but just started looking around.

  • 8. Re: iTunes 10.6.3 home sharing not working properly
    ukie.ws Level 1 Level 1 (0 points)

    Forcing ATV3 not to sleep is no the solution but rather a workaround.

    Apple needs to fix this quickly.

    Having to restart iTunes everyday on my macmini getting quite tiresome.

    Both of my macmini and ATV3 are connected through ethernet to the AEBS and running the latest version of iTunes, AirPort and iOS.

    Also, both the macmini and ATV3 have static IP's.

  • 9. Re: iTunes 10.6.3 home sharing not working properly
    dgilling Level 1 Level 1 (0 points)

    I'm having the same issue.  Everything was working fine with snow leopard and i just upgraded to Mountain lion and now nothing works.  If I pair my iphone and my ipad with my itunes library they work just fine, but if I try to use home sharing they won't work.  Very frustrating. 

  • 10. Re: iTunes 10.6.3 home sharing not working properly
    Devin Crutcher Level 2 Level 2 (270 points)

    I, too, am having issues with AirPlay, Home Sharing, and the Remote App since Mountain Lion.  None of my devices appear to see the AppleTV or each other.  I brought the MacBook Pro back to 10.7.4 to get my battery life back (separate issue, equally infuriating) and it does not appear to fix this problem either.  Updating the AppleTV to OS 5.0.2 also didn't help.

     

    I tried everything (Safe Boot, updating iTunes manually, resetting the router configuration, switching Home Sharing to a different Apple ID on all the devices, turned off IPv6) and nothing fixes these issues.

     

    No AirPlay, Home Sharing, or Remote App functioning on iPad 2, Mac Pro (ML), MacBook Pro (Lion), iPhone 4, or ATV2 (5.0.2). None of the devices appear at all to each other.

  • 11. Re: iTunes 10.6.3 home sharing not working properly
    Devin Crutcher Level 2 Level 2 (270 points)

    I also feel like I should mention the fact that my TiVo remote app hasn't been working lately, either.  It doesn't seem to see the TiVo box on my network.  I feel like this could be related because they both work in a similar way (on LAN only). I want to blame my router, but I just reset its configuration entirely.

  • 12. Re: iTunes 10.6.3 home sharing not working properly
    BigWorm76 Level 1 Level 1 (10 points)

    Same here, I am on 10.6.3.25 and the latest ios's and all idevices can connect into the AppleTV but not with the itunes win pc.  disabling ipv6 and the firewall didn't work.  this *****!!!!

  • 13. Re: iTunes 10.6.3 home sharing not working properly
    eugeniomtz Level 1 Level 1 (0 points)

    Hope this workaround fixes my problem!!... since buying the New appletv I am having this problem!!... I have iTunes for Windows!!

  • 14. Re: iTunes 10.6.3 home sharing not working properly
    ErikSamaniego Level 1 Level 1 (0 points)

    I had this issue for the last few months and decided to finally troubleshoot it.  I noticed I would have to restart itunes as my apple tvs (I have two atv 2 and one atv 3) would not connect to it after a few hours of idle time.  To fix it (as I read in the Apple discussions somewhere) I disconnected my ethernet cable on my ATV 3 and set it up via WIFI.  So far I have not had to restart iTunes in the last few days. 

     

    All of my devices are hardwired (even my iMac) with the exception of my ATV3.  I also noticed that the ATV3 is loading movies much faster.  I read somewhere that a hardwired ATV3 creates too many TCP streams and freezes up iTune's network module and that's why I was having to restart iTunes (I did not verify this claim with TCPDUMP).

1 2 3 4 Previous Next