Previous 1 2 3 4 Next 49 Replies Latest reply: Nov 1, 2013 4:55 AM by robk4
buddypj Level 1 (0 points)

It's like 80% of the time, I would open a video on youtube and the video would seem to play normally. The buffering bar (gray bar) would move before the red one and the video plays normally. But around 20seconds to a minute after that, the video would stop playing and both the gray and red bars would be at the beginning of the video and the spinning thingamajig would be there and the video cannot be played at all. This started about 2 months ago. It progressed from only a few videos but now I can't even watch a trailer properly. What can I do to resolve this? It's really disappointing and frustrating, guys.

 

I have the latest safari version and everything in my mac is up to date.


MacBook Pro, Mac OS X (10.7.2)
  • Carolyn Samit Level 10 (103,365 points)

    Quit Safari.

     

    Open System Preferences > Flash Player then select the Storage tab. Click: Delete All

     

    Now uninstall the Flash plugin then reinstall new >  Troubleshoot Flash Player | Mac OS

     

    Make sure to uninstall the currently installed Flash plugin first before reinstalling new.

     

    Launch Safari From your Safari menu bar click Safari > Empty Cache

     

    Now try a video.

     

    BTW... if you have the ClickToFlash extension installed, that can prevent Flash based video from streaming. It can also be installed as a plugin in /Library/Internet-Plug-Ins.

     

    And check to see if Safari is running in 32 bit mode. Right or control click the Safari icon in your Applications folder then click Get Info. If the box next to:  Open in 32 bit mode  is selected, deselect, quit then relaunch Safari.

  • buddypj Level 1 (0 points)

    Thanks for the swift reply. I did everything according to your instructions. I checked and rechecked everything but strangely, it's still the same. I attached a screenshot of the plug-ins that I have installed. What do you think could be the problem?

     

     

     

    Screen Shot 2012-07-02 at 10.21.17 PM.png

  • Linc Davis Level 10 (192,724 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box. Don't use the Safari-only Guest login created by Find My Mac.

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem(s)?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault in Mac OS X 10.7 or later, then you can’t enable the Guest account. The Guest login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    *Note: If FileVault is enabled under Mac OS X 10.7 or later, or if a firmware password is set, you can’t boot in safe mode.

     

    Test while in safe mode. Same problem(s)?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • ~Bee Level 7 (31,425 points)

    buddy --

     

    In looking at your plugins, DivX and Cooliris often result in problems.  But your statement that it started "about 2 months ago" might lead to suspecting Adobe PDF viewer or the flashpayer.xpt.  When did you update to Lion?

    Actually, there are more updates to 10.7 --

  • Carolyn Samit Level 10 (103,365 points)

    Move this plujgin to the Trash:  AdobePDFViewer.plugin

    Move CoolIris and DivX to the Trash. CoolIris has incompatiblity issues with Lion and DivX is preventing the trailers from streaming.

     

    Move the following to the Desktop

    DirectorShockwave

    OVSHelper plugin

    RealPlayer plugin

    nslQTScriptablePlugin.xpt

    Both Wacom plugins

     

    Move these files elsewhere on the hard drive. They do not belong in the internet plug ins folder.

    NPSVG3.zip

    NPSVG3Carbon

    NPSVG3Readme

     

    Try a video. If you can stream Flash content, try moving one plugin listed above back to the Internet Plugins folder to test.

    The are two Internet Plug-Ins folders. One is root:  /Library/Internet Plug-Ins the other is your Home folder ~/Library/Internet Plug Ins.

  • buddypj Level 1 (0 points)

    Hey guys!

     

    So far I've tried everything except the test suggested by Linc Davis (sorry, my work is intensely computer-dependent so, so far I can't find the time to do that as of the moment).

     

    To ~Bee: I've checked everything and my software is up-to-date. When I got this MB Pro, it had OSX Lion installed.

     

    To Carolyn Samit: I did all that to the plug-ins but I can't seem to "move" the contents that you said I should move. Moved CoolIris and DivX to the Trash, though.

     

    UPDATE: I turned extensions on (I turned it off earlier this year because Safari got slow and according to a thread here, extensions sometimes do that) and for some reason the youtube videos played normally, somewhat. I said somewhat because although the videos don't suddenly stop now, some videos don't play at all until the video has finished buffering.

     

    Any ideas about how the extensions might have caused this and how to make it normal again? Thanks!

     

    Here are the extensions that I have:

    Screen Shot 2012-07-03 at 2.15.31 PM.png

  • ~Bee Level 7 (31,425 points)

    DivX again!  Get rid of that, SafariStand, and Adblock. 

    Personally, I don't use any add-ons, but GlimmerBlocker.

    I'd recommend that you take them off, and then see how things go. 

  • buddypj Level 1 (0 points)

    Well, after all that, guys, still no improvement. :| Is there anyway to reset my Safari? And I mean reset everything related to Safari and start from a clean slate?

  • dickmar Level 1 (0 points)

    I have the exact same problem, I would thank you very much on your input.

    Another fact on my problem... it only does this with youtube site, all other streaming videos work just fine.

  • Bruce Jones Level 1 (95 points)

    I had the same problem. This worked for me.

    1. Open Safari,

    2. Click Safari from menu tab beside Apple logo,

    3. Go to Safari Extensions,

    4. Search for the  adblock app.then install it..

    5. Re launch Safari

    You should now be able to buffer Youtube videos correctly and you won't see the annoying ads on the right hand side.

  • dickmar Level 1 (0 points)

    Thank you Bruce, So far its working perfect!

  • Bruce Jones Level 1 (95 points)

    Glad it helped you dickmar!

  • Bruce Jones Level 1 (95 points)

    I had the same problem. This worked for me.

    1. Open Safari,

    2. Click Safari from menu tab beside Apple logo,

    3. Go to Safari Extensions,

    4. Search for the  adblock app.then install it..

    5. Re launch Safari

    You should now be able to buffer Youtube videos correctly and you won't see the annoying ads on the right hand side.

  • arielge Level 1 (0 points)

    I've been having the exact same problem and it was driving me crazy...

    I noticed this only happens in videos with google ads (the ones that show the yellow dot at the bottom). By the way, this is not specific to Safari - the same thing happens to me when using Chrome.

    Anyway, now I tried Bruce's solution in Safari, and it works!

    Thank you Bruce!

Previous 1 2 3 4 Next