Previous 1 2 3 4 Next 49 Replies Latest reply: Nov 1, 2013 4:55 AM by robk4 Go to original post
  • JoxyHom Level 1 (0 points)

    Hi,

     

    I had the same issue. Then downloaded this extension, and it works fine:

    http://www.verticalforest.com/youtube5-extension/

    (I didn't tried adblock extension, but I will. )

     

    Janos

  • Blue_Contact Level 1 (0 points)

    Also, and against all advise, signing into the YouTube HTML5 trail

    at “http://www.youtube.com/html5” does seem to solve the problem.. at least with me

     

    Weird!!!

  • Jonathan Dear Level 2 (155 points)

    Signing into or out of the HTML5 trial worked sometimes for me, as did clearing the cache for the browser or Flash. But what seems so far to always work is control clicking on the video and selecting Pop Up, to play the video in a Popup. And I've had the same problem across OS 10.8.2, Flash 11,4,402,287, Safari 6.0.1, Firefox 16.0.2, Chromium 22.0.1229.94 and Opera 12.02.

     

    Will try the Adblock extension next.

     

    Thanks

  • angelovski Level 1 (0 points)

    I had this issue too, and i tried many things (enable or disable HTML5 trial, reinstall flash, update safari etc), but i always had some videos working ok, and some videos not. (I usually was having trouble on videos wih ads on top and from the side). I even after lot unsuccessfull tries, even got used to it, so i was refreshing the url several time, to watch a 2 min video even

     

    I googled about the youtube adds that i had almost always (MacKeeper - BEWARE its a bad software), and a solution i found to get rid of that ads is to install http://glimmerblocker.org.  I did, and it solved my issue with the adds, and solved my issue with the youtube videos stopping after some time play.

     

    Hope it helps you too!

  • teosmat Level 1 (0 points)

    Had exactly the same really annoying problem for a long time, tried dozens of possible solutions but i'm glad i finally found the only one through this post... and it is definately glimmerblocker! onced installed, everything works fine, no youtube stucking anymore. Thanks everyone!

  • Jonathan Dear Level 2 (155 points)

    Whenever a video stops playing in YouTube after about 20-30 seconds, turning on Extensions and the Adblock extension ALWAYS works. You can add it by going to Safari/Safari Extensions/  and it is usually under Most Popular. I don't know if other browsers have something equivalent. And I haven't tried any of the other ad blockers. If anyone knows why this happens or works, I'd really like to know, because it's plagued me for months.

  • Mitch 751 Level 6 (11,525 points)

    What worked for me:


    To delete Safari's icon cache using the Finder, open your user folder, navigate to ~/Library/Safari/ and move this file "webpageIcons.db to the Trash

  • pwaller Level 1 (0 points)

    I've been following this thread as I too have a Youtube Playback problem. I'm using a Macbook Pro OSX 10.6.8 and I did what you suggested and logged in as a different user and it worked fine. (There are 3 users setup on my Mac) Tried a few of the suggestions on this thread but so far with no success. A couple of things that I noticed. When in my account the Youtube window doesn't display the rotating balls as the file is downloading and I also don't always get the pointer indicating where in the video the play point is. Also, initially the correct time for the video is displayed but the moment it starts to play a different time is displayed, usually less than 20 secs and the red bar moves accross to the rhs. Sometimes even out of the window and behind the icons on the rhs displaying similar clips. Also tried logging in in safe mode as you suggested and the problem was the same.

    Hope you might be able to suggest something. Your troubleshooting approach sounded logival!

    Cheers,

    paul.

  • biggywiggymusic Level 1 (0 points)

    As the previous poster just said - I've found youtube works in my guest account, but not in my user account ..

    any ideas how this can be resolved? I have an IMac OSX Mountain Lion 10.8 2  Thanks

  • twodear Level 1 (0 points)

    Ians43 - did you find a solution for your similar problem? My Mac Mini is a mid-2007 which has been upgraded to OSX 10.7.5. Since this upgrade, videos or commercials will play for 3 to 11 seconds and stop. The gray bar continues to progress to indicate that the video is continuing to load, and will eventually load 100% but the video doesn't restart. I can move forward along the gray bar but again, after 3-11 seconds the video stops.

     

    This only happens with YouTube via Safari. Videos and commercials play normally on Google Chrome.

     

    I tried Adblocker, no luck at all with that - no change to the original problem. Upgraded to the newest version of flash player - no change. Upgraded to the newest version of Safari and really got in a jam when Safari ceased working altogether. I had to call Mac Help for that one but they eventually got the latest version of Safari working for me.

     

    Perhaps the easiest thing to do is give up with Safari but Google does not have the same functionality.

     

    Any help here?

  • Aismaiil Level 1 (0 points)

    Hi everyone, I think I found a solution...

     

    I had this other problem first, my RAM was being hogged by Safari or Chrome and I only had around 500-800Mb left from my 13inch MBPr's 8GB of RAM bcuz I always have around 30 to 40 tabs open at once (I like to read a lot of articles). After posting a screen shot of my activity monitor and researching more about it in the macrumors forum, someone replied telling me that it's the flash, pointing out that it had around 90 threads and that I have 600+ mb of swap and that's causing my problems. He suggested I download "click to play" so that I control which flash content is loaded n so none of the tabs would have flash open in the background. Additionally, I switched youtube to HTML5.

     

    It worked perfectly for my RAM problem and perfectly for the youtube problem as well, bcuz it basically replaced the youtube video with click to play, also no video would load on its own unless u click on the play button which is convenient for me so that i don't have 20 videos loading all at the same time and playing at the same time.

     

    Download click to play n see if it works for u

  • Ians43 Level 1 (0 points)

    No I am sorry I never did.  Tried everything suggested but the item below does seem to have merit.  I just bought a new Macbook and it works fine - if an expenisve fix.

  • Aismaiil Level 1 (0 points)

    Actually u'd be surprised, I use Chrome more than Safari and Chrome has a lot of the same features and more! But try the solution I suggested above, download click to play and see if it works...

  • biggywiggymusic Level 1 (0 points)

    I resolved my issue by reinstalling the os - all is working now

  • twodear Level 1 (0 points)

    Thanks to all for your responses.

     

    I don't fully grasp what Aismaiil wrote but understand that Click-to-Play was the answer. Reloading the OS is not a good option for me - it was an on-line upgrade to 10.7.5 and I don't want to go through the hassle of getting a new authorisation. I'll try click to play.

     

    Thanks again