2 Replies Latest reply: Feb 4, 2013 8:08 PM by mrpaulk
Screaming.Pict Level 1 Level 1 (0 points)



I have a problem opening iPhoto and I've exhausted every diagnostic measure I can think of.


The problem is that when I launch iPhoto it hangs.


If I open it normally it tells me I need to update my library and presents a dialog with 'cancel' or 'update'. At that point it hangs- I can't click either of the options.


If I open it holding down OPTION then it asks me what library I want to use.... and hangs without letting me select an option.


If I open it holding down CMD-OPTION then it presents me with a set of diagnostic options...and hangs before I can select any of them.


I have tried repairing permissions & verifying the disk- no problems found and still hangs on launch

I have tried removing the plist preference file out of the ~/Library/Preferences folder- still hangs on launch

I have tried deleting the iPhoto 9.3 app from the Apps folder and reinstalling it using the Mac App Store- still hangs on launch.


There's no message in the console about iPhoto crashing. It's obviously not a photo library problem as it crashes before it even opens the library and it can't be the app itself as I've re-downloaded it. I presume something external to iPhoto is having an issue but I have no way of finding out what that is.


Anyone got any good diagnostic steps I can take?

MacBook Pro, Mac OS X (10.7.4)