Previous 1 2 3 4 5 Next 93 Replies Latest reply: Apr 2, 2015 10:40 PM by sytelus Go to original post
  • Mermaid7777 Level 1 Level 1 (0 points)

    Oh... and some apps disappeared such as FilmOn which I can't find now in the App Store.

  • Carmen Bettina Foorden Level 1 Level 1 (0 points)

    Thank you, Carol. Solved the issue on my new iPhone 5 and my old 3GS which I gave to my elder son. The first solution worked fine, just reseting the settings. Only we need not restart the phones because iOS 6.0.1 does this immediatly after the reset.

  • Clotpiece Level 1 Level 1 (0 points)

    What i did was press home and lock button at the same time for 20-25 seconds to make it reset itself, then sign out of my account and then sign in from the app store. after i press the app that is not downloading, voila, it starts to download. I guess when you confirm your apple id from your itunes on computer to sync a book etc. you need to re-enter your password on your ipad too. this is what i found out anyway.

  • Derek A. Westen Level 1 Level 1 (15 points)

    Had all these problems, but the solution by TylerDurden777 worked: Go to updates tab located in the "App Store" icon.  Select the app that is stuck installing.  It brings you to the app details, reviews, etc. 

     

    Then click on the app icon located at the top left of the screen.  When you do this it places the app icon onto your home screen.  Click on the app again that has been placed on the home screen and it should start installing. (If you already had the app on the home screen you may be able to skip straight to this step, but in my case, the app icon was missing thought it was trying to install.)

     

    Or, after you have added the app to your home screen, you can delete it (press, hold till jiggles, then tap the X). That will delete the hung install process, but without the app.

     

    Later, if you wish, you can redownload. It will ask about purchase, but when you say "yes" it will figure out you have already purchased and give it to you free.

     

    In my case, it is possible that out of date credit card info was involved in the hang, though I doubt it.

  • Em is Level 1 Level 1 (0 points)

    I have also the same problem . I have tried all the above solutions but its not working .. Please helpp :(

  • Em is Level 1 Level 1 (0 points)

    I have tried this . Not working .still waiting .. Plaza help:(

  • wrolison Level 1 Level 1 (0 points)

    Having this issue as well and nothing in this thread has worked.

     

    Ugh!

  • mira_ishak Level 1 Level 1 (0 points)

    i have something similar:

    i have iphone 4 running the latest ios, i think 6.0.1

    when i try to download an app from app store while i am connected on wifi, everything is normal: waiting, loading, installing. however, when i try to download the same app while i am on 3G, it gets stuck on Waiting for a while, then moves right to Installing and installs successfully. it jsut skips to tell me "loading" any explaination?

  • kstr79 Level 1 Level 1 (0 points)

    This helped me. I would perform a hard reset and could not uninstall the application in question or update it OTA or from my PC. I signed out of the iTunes/App Store in Settings and performed a hard reset, then signed into the iTunes/App Store with my Apple ID once again and then I could at least delete the application, which allowed me to work around my issue. Thanks all.

  • allanmacatingrao Level 1 Level 1 (0 points)

    iOS don't allow simultaneous app download. So probably want to check if there are downloads in progress. (e.g in your iBook, iTunes U, Newstand etc.).

     

    Solution:  Stop all active app download including your iBook, itunes U, newstand etc. then retry.

  • SarahSeitz Level 1 Level 1 (0 points)

    This is finally what worked for me.  I was stuck on 2 big apps (one was a bilingual dictionary, nearly 1gb, and the other was a Word a Day foreign language app--500mb--that I've had for over a year).  I pressed and held the dictionary app until it started shaking, and pressed the X.  Deleting the word a day app and losing all 400+ words I had painstakingly added was not an option.  But deleting the giant dictionary and re-syncing allowed the Word a Day app to start normally.

     

    Still haven't tried to fix the dictionary, and I just got the same error message for it again, but at least the crucial one survived thanks to this solution.  Back to the drawing board...

  • Jez_Conrad Level 1 Level 1 (0 points)

    Just tap the icon of the apps that are saying 'waiting'. It effectively unpauses them and changes the status to 'loading'......problem solved.

  • GamerGrrl Level 1 Level 1 (0 points)

    Yeah one app I'm trying to download is stuck on waiting. I've tried restarting my phone and logging in and out of my iTunes account, and unfortunately I can't delete the app either. The odd thing is, the app doesn't show up under the Purchased tab, but when I search for it in the App Store is says 'Installing'.

  • andrewyeoman Level 1 Level 1 (0 points)

    Ok......not being an above average Techno head but reasonably logical I am trying to rectify this problem also and finding it not at all clear or logical!............So..problem

    1 First time user of iphone 4

    2 downloading an application for reading documents(.doc,.xls etc) from iTunes  - called :Office Plus ( its a free application)

    3 Downloaded this on itunes on PC : it appeared ( well the icon did) and it records that it is "downloaded" wehn I check on the iTunes.

    4 On the iphone : Application Icon is dark ( visibile) with words "waiting" under it.

     

    So - what next? - Do I wait? OR go through one of these complex Twister like sequences which others describe here? - Bizarre that these clever people at Apple can't provide "an idiot's guide" to such issues.

     

    I guess its the Twister sequence option I suppose - but a little disappointing having just transferred from Nokia!...tempted to return! as Nokia software is generally more user friendly - well for me anyway.

  • eBry Level 1 Level 1 (0 points)

    After two days struggling with App Updates & Downloads stuck on "waiting...", I realised that one of my video podcast downloads was blocking everything else: all app updates and all iTunes downloads (from iCloud and new purchases).

     

    As soon as I put the download of the culprit video podcast on hold, everything else resumed beautifully (app updates, iTunes downloads).  I finally deleted the infamous video podcast, as I never managed to successfully download it.

     

    The corrupt video podcast file was the first one in the queue, which is logic if it was blocking everything else...

Previous 1 2 3 4 5 Next