Previous 1 2 3 4 5 6 7 Next 99 Replies Latest reply: Aug 22, 2015 9:12 AM by Disgruntled Cannibal Go to original post
  • hljboss Level 1 Level 1 (0 points)

    There's another possible issue that was what caused this same problem for me:  Your iPhone or iPad is full!  If you don't have enough storage space left on your device, apps can sit there in "waiting..." status without giving you an error message telling you why they are not downloading.  No amount of clicking, resetting, deleting, etc. will solve this problem

     

    Just clear out some music, photos or whatever to open up storage space, and then sync your device, and all should be well.

  • limhjf Level 1 Level 1 (0 points)

    I found a pretty neat solution. I went to App Store, under purchases, I tapped on one of the previous apps, it somehow started to download ALL my apps!

     

    Apparently, my apps were ALL stuck at waiting once restored from iCloud in beta 3 of iOS 7. Its fine now.

  • Neto Level 2 Level 2 (270 points)

    If you want to get rid of the "Waiting..." app and you don't get the x to delete it:

     

    Settings -> General -> Usage -> wait the Storage to load, then click show all apps.

     

    Find the app you want to delete, click, delete it and redownload.

  • myla carmina Level 1 Level 1 (0 points)

    Hi, i did already what you've said here but to no avail, not once but it says " cannot conect to i tunes this time" ..:(

  • GloryB Level 1 Level 1 (10 points)

    hljboss, thanks so much. What you said to do worked for me!

  • BNHWin Level 1 Level 1 (0 points)

    I have tried everything in this post, and nothing is working for my 2 apps that are frozen in "Installing".  I have had this iPad mini for les than 2 weeks and had this problem twice now.  The first time I did a factory reset and got rid of everything.  I am trying to avoid it this time. 

     

    This morning my husband tried to download 2 apps via WiFi at Home Depot and it is stuck again. I tried to download them again connected to the computer/iTunes and it switched to being stuck on "Installing" now. And occasionally I can hold down the installing app in "Purchases" in the App Store and it will open the app. But it still won't open clicking the icon and it still says Installing.

    I about ready to send it back and call it defective. NO websites offer anything that will help.
    I can't hold down the app and delete it - no "x" appears.
    Clicking it once to unpause it doesn't work. Clicking it twice doesn't work either.
    Logging out of iTunes and then holding down home/power buttons to reset doesn't work.
    The apps do not show in updates.
    I can install and uninstall them from iTunes on the computer, but they always show "Installing" on the iPad, no change.

    Help please?

  • BobF4321 Level 1 Level 1 (0 points)

    I'm having the same problem with one app... stuck at "installing" and none of the remedies work.  I was hoping an update to the app might help... an update was just issued, but applying the update (via iTunes sync to my Mac) doesn't do anything.   I have a lot of content on my iPad so I would rather not do a reset/restore.  Fortunately this is a non-essential app for me, so I'm going to be patient for a few weeks and upgrade to IOS 7 to see if it handles this case better than IOS 6.  If not, I'm going to open a case with Apple.

  • orubin Level 1 Level 1 (0 points)

    Thanks Demo. Login out, shutdown and restart, logging back in worked for me. Al the WAITING downloads are once again queued up and downloading again. Much appreciated.

  • Raymund campos Level 1 Level 1 (0 points)

    It is very easy sign out you apple id reboot device long press and the x button will be visible press x button

    then reboot

  • rob_kuhn Level 1 Level 1 (5 points)

    @Neto: thanks!!  That worked!  I was just about to perform a complete wipe on my phone and attempt a restore from backup.

  • NewUserOfIPHONE Level 1 Level 1 (0 points)

    I have the same problem with waiting APPS, but have somewhat of a solution.  In my mind, this also fixes the fact that Newstand cannot be removed.

     

    I made a folder on the home screen and called it BadAPPles.  All the broke stuff goes there.

  • Faldor Level 1 Level 1 (0 points)

    A full shutdown solved the problem for me.

    Hold down power button and home button at the same time, until iPhone turns off.  This is supposed to be equivalent to removing the battery, according to Verizon.

    I waited a out 30 seconds, the turned iPhone back on.   Apps stuck in loading cleared from screens and the updated versions were still loaded on iPhone.

  • fazer75 Level 1 Level 1 (0 points)

    For me the problem was solved by downloading any other app in the store. When I entered my iTunes password again, it automatically started to redownload the "waiting..." app.

  • mekds Level 1 Level 1 (0 points)

    I found the solution. You do not need to sync all of them again.  

     

    1. In your iphone, go to setting.

    2. Go to general

    3. Go to Usage

    4. In storage, click show all apps

    5. Click the waiting apps and delete them

    6. Go to the App store and install them again

     

    Good luck!