6 Replies Latest reply: Feb 25, 2013 6:16 AM by Diginin
dcwarner Level 1 Level 1 (5 points)

In finder, in column, list and coverflow views, depending upon the "Favorite" I am viewing, I am unable to adjust the order of the files being shown.  The default seems to be reverse alphabetical. 

 

The favorites in which this occurs are "All My Files", my computer name area and "Documents."  When viewing these, the top row with the column titles appears as a solid white row (with line below it to separate it from the actual file listings) with the names of the columns I chose to view, e.g., Name, Date Created, Size, Kind, etc.  It acts like a header row in numbers by staying visible as the files pass under it, and it is slighly "transparent."

 

When I look at "Desktop" or "Applications" as well as any of the folders contained in "All My Files," my computer name area and "Documents," the top row changes appearance to the "bowed out shaded light on top/darker on bottom" graphic, and a little triangle appears at the right side of each of the columns.   Clicking on the little arrow rearranges the files properly. This "header row" is not slightly "transparent."

 

The question (bug?) is: Why doesn't the "All My Files", my computer name area and "Documents" "header row" not allow changing orders of file display?  And, why, if it can't be fixed, is the default reverse alphabetic?

 

Thank you.

 

Dave


MacBook (13-inch Aluminum Late 2008), Mac OS X (10.7.4)
  • dsimagry Level 4 Level 4 (1,275 points)

    The following may not answer your question, however, it's worth the read...

     

    Mac 101: The Finder

     

         http://support.apple.com/kb/HT2470

  • dcwarner Level 1 Level 1 (5 points)

    dsimagry,

     

    Thanks for pointing out this support item. 

     

    While it did not resolve the problem, the two images do show the difference in "header row" configurations. 

     

    The "All My Files" is one of the windows where the plain/transparent header row is present, while the "name area," pravi in the example, is the kind of row that contains the little triangle that allows the order of the column to be reversed.

     

    Dave

  • dsimagry Level 4 Level 4 (1,275 points)

    My expertise ends here... Hopefully someone comes by with the solution you are looking for.

  • dcwarner Level 1 Level 1 (5 points)

    I called Apple Care to see if someone there knew the reason for this problem, and how to resolved it.

     

    The solution is using the "arrange" button along the top of the Finder window.  Though not intuitive, selecting "None" from the menu of options enables the header column options with the little arrow for selecting ascending and descending.

     

    So, if you wish to arrange files in alphabetical order, select none, click on the arrow to the right of "name" to choose A->Z or Z->A.  If you want to lock that it, go back to the "arrange" button, and click on "name." 

     

    If you're sorting on Date Modified, it works almost the same, though the "Today," "Previous 7 Days" and "Previous 30 Days" subheaders always show up on top, and then all the other files are shown in the order previously selected.

     

    Dave

  • greendragonfly Level 1 Level 1 (0 points)

    Sooo NOT intuitive. But changing to "none" and selecting a variety of sort options in the list at the bottom of "view sort options" gives me a nice variety of sort options in Finder. (Just as good as is was before the last few OSX "improvements". LOL

    Thanks for this piece of information. Very helpful.

  • Diginin Level 1 Level 1 (0 points)

    I have just fixed this situation by going to View->Show View Options and removing Always open in list view and Browse in list view. Then I removed Date Modified; viola, the sort was back to normal. I then re-added Date Modified.

     

    http://d.pr/i/9hF0

     

    This problem was only in my documents folder, hmmmmm.

     

    Hope this helps someone else too.