4 Replies Latest reply: Jul 9, 2012 1:14 PM by cantelli
cantelli Level 1 Level 1 (0 points)

SMC firmware error -causing system nonresponsive to all rescue measures - how to repair ?

 

mac mini late 2009 hardware, osx  10.7.4 latest built. after booting into linux live cds, booting into osx will  regularily fail completely ( fully intact HD not recognized, keyboard input not recognized, osx boot-cds, -dvds, -usb sticks not recognized, pram reset not executable, secure boot not executable,  nvram reset does not change anything.  mac will only boot - automatically into any linux cd inserted into its cd drive.

 

after endless tries - for whatever luck  - i succeeded to boot into osx and selected booting in verbose mode to check for diagnostic information. once back into osx, the mac will boot normally hence (until next linux live cd attempt...) 

 

in verbose mode, the following 2 error messages   appear every time when booting in the long string of white on black screen writing - ( code lines below may contain letter errors as transcribed from blurry screen  photo) firmware corruption ?

 

 

“SMC :: smcInitHelper ERROR: MMIO regMap ==NULL - fall back to old SMC mode

NVDANV50HAL loaded and registered”

 

a few -  lines later:

 

“DSMOS has arrived

  SMC :: smcReadKeyAction ERROR: smcReadData8 failed for key BEMB (kSMCKeyNotFound)

 

my - non-expert - guess: the two error messages relate to some key boot-sequence information missing or being corrupted.  this probably will cause all the strange boot faillures.

 

 

my question to the experts:  how to repair / restore this errors ?

 

any advice that may work is appreciated.

 

( i wanted to restore firmware via apple.com download of firmware repair cds but could not locate any download  for SMC Version (system):1.35f1, does any one have that as an install disk ?


Mac mini, Mac OS X (10.7.4)
  • 1. Re: SMC firmware error - how to restore/repair ?
    John Byrne2 Level 1 Level 1 (5 points)

    I just happend to notice these in my logs as well. They started immediately after installing 10.7.4; which suggests that it isn't a problem with the firmware at all. You don't mention what particular Mac mini you have, but I'd bet on unnecessary verbosity by 10.7.4 in the presence of older hardware missing an new feature. It is annoying, though.

  • 2. Re: SMC firmware error - how to restore/repair ?
    cantelli Level 1 Level 1 (0 points)

    hello john:

     

    thank you for the reply. as i understand it ( sorry i am far from any expert in this) you have the same error messages but no problems resulting from them ?

     

    my firmware version is SMC Version (system):1.35f1 which belonged to the 2009 mini, Model Identifier:          Macmini3,1

     

    i think it was the last mini with integrated cd drive, but i am nit sure.

     

    when i do not boot into any linux cd i dont have any start up problems, but after running ubuntu etc live cds  the whole osx boot routine will fail with the symptons described above and in my earlier post. i some how make it back into booting the machine but that tales multiple starts and close downs and intermediate boots into a linux live cd. i lack the insight to locate the logic in the faillures and the rational ebhind the later reboot successes into OSX, so i associated the error messages with it. which may be utterly wrong.

  • 3. Re: SMC firmware error - how to restore/repair ?
    John Byrne2 Level 1 Level 1 (5 points)

    Yes. I have the same error messages and no problems. I have compressed log files going back to when I installed 10.7.4 to show that the error messages started the first boot after install 10.7.4 and have continued since with no signs of trouble. So I am suggesting the these messages are not indicative of the problem and you may be able to prove that to your satisfaction by looking at when 10.7.4 was installed and seeing if the messages started, then, on your machine as well.

     

    I don't know what to tell you about your actual problem, though. Sorry. I use live CDs from time-to-time and I've never seen this behavior.

     

    When the machine is messed up, is the "option" key at boot working properly and showing you all the bootable disks, but they just don't boot? Then, somehow, without obviously repairing anything you eventually got things back to a good state? I just don't know what the problem might be.

  • 4. Re: SMC firmware error - how to restore/repair ?
    cantelli Level 1 Level 1 (0 points)

    thanks for your consideration of my problem, john.

    when the mini does not boot properly it only shows the grey screen and no "c", "alt" or other keys will whow any effect. no pram or other reset keys will work. it  will not accept any mac os cd or dvd to boot from neither. it will not boot into recovery partion. it will show a black screen and white writing , something like "no boot volume, insert a disk and press any key" ( which i guess is how a linux system behaves if you remove the boot disk ). i will then boot from a linux system and shut down the fully booted linux and after some attempts at such, for reasons beyond my understanding, it will boot up again from the internal osx drive. last time it booted up successfully after several failures, i had newly connected another bootable osx disk via usb and possibly the presence of that disk somehow made the machine recognize its internal system ( there is a similar problem with ubuntu latest built on  some latest generation macs where booting will only work if you have both a main boot system and a second bootable drive with ubuntu connected via usb at the same time present, each alone will not boot up)  maybe the same problem takes temporary control of my mini after booting into ubuntu and trying to boot into osx thereafter.

    all that said, don*t bother further about it. for the moment i keep linux away from the mini, doing which keeps it working normally.  again sincere thanks for trying to help.