2 Replies Latest reply: Jan 28, 2013 8:21 AM by lattesandspas
chris125 Level 1 Level 1 (0 points)

i have no 3rd party firewall,no edit on /private/etc/hosts and timezone is set...What am I missing..Started after update to lion 10.7.4


iMac, Mac OS X (10.7.4)
  • toddwest24 Level 1 Level 1 (0 points)

    I've been trying to get an answer to this problem for MONTHS.  I upgraded both my iMac and my MacBook Pro to Mountain Lion, and ever since, FaceTime and iMessage stopped working.  I got the "Server encountered an error . . ." So, I called Apple "support" and they claimed they haven't heard of this issue.  I said I find it hard to believe since it's apparently a huge problem for tons of users and is all over the Apple forums.  After spending an hour on the phone with "support", they said they had to pass i on to a senior engineer and they'd call me back within 2 days with an answer.  After waiting a week, I decided to go to the place where I should have gone before, the place where all questions can be answered, even those too advanced for Apple, that place . . . YouTube.

     

    Fixing the time issue didn't work for me, nor did any other solution that has been posted on the boards.  Yet after watching a 1:24 video on YouTube, both FaceTime and iMessage now work for me.

     

    Here's the solution which WILL work (assuming date/time is set correctly, and that you are using your own singluar Apple ID, not a shared ID).

     

    1. You do need to first make sure your date/time settings are correct and set to adjust automatically.  But doing just this step will not fix the problem.
    2. Open Finder, click on "Go" at the top menu, then select "Go To Folder"
    3. Type in    /etc     and hit enter
    4. You'll see a file called "hosts".  Drag that file to your desktop.
    5. Right click on that file and open with Text Edit
    6. Select all the text in that file, delete it and replace it with the text below, exactly as it is below.  Then save the new hosts file (just exiting will save it). And then drag that new hosts file back into the /etc folder to replace the old one.  After that, your FaceTime and iMessage will work, no thanks to Apple.

     

    ##

    # Host Database

    #

    # localhost is used to configure the loopback interface

    # when the system is booting. Do not change this entry.

    ##

    127.0.0.1 localhost

    255.255.255.255 broadcasthost

    ::1 localhost

    fe80::1%lo0 localhost


  • lattesandspas Level 1 Level 1 (0 points)

    Tried this and still can't get iMessage or FaceTime to work.  Not sure what I'm missing