7 Replies Latest reply: Jul 4, 2012 7:13 AM by Chris Harris7
Chris Harris7 Level 1 Level 1 (5 points)

I have a vault created on an old Mac Book (this has died and is not accessible to me) that I need to restore onto a different computer with Aperture 3.0 on it.

 

i have tried to restore the vault but get an error that the vault was created with and older version and to import the vault instead. I click import and get the very (un)helpful error message that Aperture was unable to find the necessary information to import the vault.... and nothing.. that's it, no further clue.

 

How can I import this vault?

 

Regards

Chris

  • 1. Re: import vault from older version
    Thomas Emmerich Level 4 Level 4 (3,485 points)

    See if this ApertureExpert Tip can help. It covers the same topic.

  • 2. Re: import vault from older version
    Chris Harris7 Level 1 Level 1 (5 points)

    No that doesn't appear to be the same issue. In that example the dialogue is completely different.

     

    Mine is as I said before and has another button bottom right "import". When I click import I get the message about Aperture not having sufficient information.

     

    I don't think that it is the same issue.

     

    Restarting Aperture doesn't help.

  • 3. Re: import vault from older version
    Kirby Krieger Level 6 Level 6 (11,945 points)

    What's the exact wording of the dialog you're getting?

     

    What version of Aperture was used to create the Vault?

     

    On what media is the Vault now?  How formatted?

     

    Are you importing the Vault into a new, empty Aperture Library?

  • 4. Re: import vault from older version
    Chris Harris7 Level 1 Level 1 (5 points)

    Not in front of the Mac now, but the first dialoge says that I can't restore from the vault because it was created with an older version of Aperture and that I can import instead - There is button second button on the dialogue "import".

     

    I click import.. and get the not enough information message.

     

    Sorry I can't be specific about the exact wording right now.

     

    As for what version of Aperture was used to create the vault - 2 something, no idea exactly what it was and it would have been on a now defunct computer that is on another continent so I'm afraid I can't answer that question.

     

    The vault is on a hard drive, Mac formated - unreadable on windows.

     

    No the Aperture library is not empty.

     

    Sorry about the vague answers.. I can't check the exact details of the formatting until I can get back that mac tomorrow.

  • 5. Re: import vault from older version
    Kirby Krieger Level 6 Level 6 (11,945 points)

    Hi Chris,

     

    Full answers may be helpful  .  Of course, the opposite is possible.

     

    I'd try this:

    - Upgrade Aperture to 3.3.1.

    - Create a new empty Aperture Library ("File➞Switch to Library➞Other/New➞Create New")

    - Restore the Vault ("File➞Vault➞Restore Vault")

     

    Note the exact wording of error messages or other dialogs.  Let us know what happens.  May all your Apertures be open  .

  • 6. Re: import vault from older version
    Frank Caggiano Level 7 Level 7 (23,830 points)

    Following up to what Kirby wrote post screenshots of all the error/warning/information windows you get and the exact sequence of steps you are taking.

     

    Without that we're all just guessing here.

     

    regards

  • 7. Re: import vault from older version
    Chris Harris7 Level 1 Level 1 (5 points)

    Kirby, Thanks - I can't upgrade to 3.3.1 because according to the download page http://support.apple.com/kb/DL1553 that version required OS X 10.7.4 or later. I have OS X 10.6.8 and my version of Aperture is 3.1.2 which I think is as up to date as I can get on that version of OSX. The last time I checked for software updates nothing was download for Aperture as I recall, a couple of months ago.

     

    I can't update that computer (a Mac Mini) again at the moment because it doesn't have internet access. It is installed on a boat, in a marina in deepest darkest Uruguay. I can only get internet access by lugging a laptop (windows) somewhere. I certainly can't upgrade to OS X Lion.

     

    Anyway I tried to follow your instructions with what I have and these are the dialogues that I received.

     

    I created the new library

     

    Then did File - Vault - Restore Library ( note that Restore vault is not an option)

     

    I choose to restore the library

     

    I then get the error message

    "Photos 1 backup" was created by an older version of Aperture, and can not be restored by this version.

     

    To import the contents of the vault,select the import button

     

    I click import, and receive this error message

     

    Library import error

    The library connot be imported because some the data required for import could not be found

     

    The file is on a hard drive which according to the info is "Mac OS extended (journaled)"

     

    Hmmmm just noticed that if I get the info for the vault file it shows as only 4k... is that just showing the folder size or is the vault empty?