5 Replies Latest reply: Jun 28, 2014 7:46 AM by pocketchanged
Maricfromma Level 1 (0 points)

Can I upgrade my current computer? Can I download Lion, or do I have to do it at the Apple Store?


MacBook, Mac OS X (10.5.8)
  • Niel Level 10 (298,451 points)

    You need to purchase a Mac OS X 10.6.3 DVD or install the Lion USB thumbdrive onto a blank drive or partition.

     

    (67581)

  • Maricfromma Level 1 (0 points)

    Thank you so much, Niel. Very helpful.

  • Neville Hillyer Level 4 (1,865 points)

    Many people are happy with OS X 10.5.8 but if you want to update here is my general advice:

     

    To get information about your Mac click the apple (screen top left) and select About this Mac. This will give you your OS number. Then click More Info to see which Processor you have. If it says PowerPC you cannot upgrade to Snow Leopard and above as these OSs are for Intel only. You can discover more about various Macs at: http://www.apple-history.com/

     

    The OS numbers and names are:

    OS X 10.4.x - Tiger

    OS X 10.5.x - Leopard

    OS X 10.6.x - Snow Leopard

    OS X 10.7.x - Lion

    OS X 10.8.x - Mountain Lion

     

    If you have an Intel Mac it is well worth upgrading to Snow Leopard now and then considering other options after that.

     

    You can buy Snow Leopard here:

     

    http://store.apple.com/us/product/MC573Z/A

     

    For details about upgrading this to Lion or Mountain Lion see:

     

    http://store.apple.com/us/product/MD256Z/A

     

    In each case check that your Mac complies with the requirements.

     

    If you are not in the US you should use the Change Country link at the bottom of the page.

  • Maricfromma Level 1 (0 points)

    Neville,

     

    Thank you so much for all this information. My Processor is Intel Core 2 Duo.

    The reason why I want to update is because I would like to install the newest Photoshop and Dreamweaver packages and they require OS 10.6.8 or later. Right now I can runthe older versions of Photoshop, etc. but the system requirements for CS6 version is 10.6.8.

     

    Again, Thank you so very much!

    -Mary

  • pocketchanged Level 1 (0 points)

    Rat's, you are dead right.. pc