6 Replies Latest reply: May 31, 2013 9:28 PM by raksport14
raksport14 Level 1 (0 points)

I was listening to my iPod as I was working out and I noticed that it stopped playing. I looked at the screen and noticed that the typical GUI was gone and instead there was a text-based menu (kinda like DOS) with a variety of options that seemed more than the typical menu options (such as power source, standby, etc.) I couldn't figure out how to control this interface as it didn't seem to respond to touch. It also kept switching to the main boot screen (black background, white apple) and between different menus. A couple of times the normal GUI was restored, but whenever I pressed the power button, the volume control graphic would come on the screen. There seems to be no way to turn off the iPod now and it keeps switching between different menus usually with the boot screen in between.


Anybody have any idea what's going on?


An example of the menu looks like this:


N20 Snowfox (4A0432)
Voltage: 3759 mV


>Standby                              *

  Power                                 $

  Audio                                  |

  Remote                                |

  TV Out                                |

  LCD                                    |

  IO                                        |

  FM                                      |

  Memory                              |

  Touch Panel                        |

  Accel                                  |

  About                                 *

iPod nano
  • Kenichi Watanabe Level 7 (32,908 points)

    It seems to be doing this (diagnostic mode)


    http://www.cultofmac.com/59854/how-to-access-the-new-ipod-nanos-diagnostic-mode- how-to/


    I believe you just do a standard iPod Reset




    to get out of it.

  • raksport14 Level 1 (0 points)

    I figured out towards the end of my post that it was going into diagnostic mode. However, the buttons don't seem to be responding as normal, so I can't do the standard iPod reset.


    I did connect it to my computer to restore the iPod, but now I just get an old version of the don't disconnect/OK to disconnect screen. That's it. If I turn off the iPod or do the restart I still get that those screens.

  • raksport14 Level 1 (0 points)

    Update: I figured out that my iPod keeps putting itself into disk mode and is unable to power off. I believe the reason behind it is that there is an issue with the volume buttons on my iPod where it recognizes them as being depressed, even when they are not. So when I push the power/sleep button it acts as if I'm pressing both the sleep and volume buttons even when I'm not and thus initiating a device restart. This would also account for why my iPod was going into diagnostic mode and why when the GUI did return to normal the couple of times why the volume control appeared. I failed to mention in my initial question post that the issues began after I pressed the volume down button.


    Additionally, I performed several restores and nothing has changed and iTunes seems to think everything went okay, which I believe further supports the volume control error.

  • Kenichi Watanabe Level 7 (32,908 points)

    That does not sound right...  If it's less than one year old (under warranty), you should contact Apple to see about getting it replaced.  If you have an Apple Store nearby, you can make a reservation at the Genius Bar to have it looked at, even if out of warranty.

  • AntonioBermudezMD Level 1 (0 points)

    I have had the exxct same problem but I connected it to my computer and things went smoothly. My ipod didn´t´work for two weeks earlier it just died. I connected it to the power for 2 days before i could restore the ipod. hope this helps

  • raksport14 Level 1 (0 points)

    Thanks for your input Antonio, but I resolved the issue


    I connected it to my computer, but that didn't do anything.


    I took Kenichi's advice and went to the Genius Bar at my local Apple store. It turned out that water had gotten inside my nano and corroded the copper inside. I use the Nano to excercise and clipped it to my shorts and I guess sweat was able to get inside via the charging port. I read on forums that many people had the same issue. Apple didn't cover it as they considered it neglect and something not covered under the warranty, although they tried to sell me one at a discount. Luckily, a family member had an extra Nano I could use.