Previous 1 2 Next 16 Replies Latest reply: Apr 13, 2013 4:16 AM by jbunti
s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)

My Mac Pro has recently started to wake from sleep on its own. This usually happens in the middle of the night, after I've gone to bed. I wake up in the morning and the computer is on.

 

Not sure how/why this is happening. Any ideas?


Mac Pro 2.8 (Early '08), Mac OS X (10.5.2), 10 GB RAM, 74GB 10k Raptor, 2x 750GB RAID, 23" ACD
  • Linc Davis Level 10 Level 10 (158,425 points)

    Launch the Terminal application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    Drag or copy — do not type — the following line into the Terminal window, then press return:

     

    syslog -k Sender kernel -k Message Req Wake

     

    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

     

    Important: The name of your computer will appear in the output. If that information is private (for example, if the computer name contains your own name), edit it out by search-and-replace in a text editor before posting.

  • s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)

    Thanks. Here's what came back:

     

    Jun 28 00:49:41-Mac-Pro-3 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    --- last message repeated 2 times ---

    Jun 28 06:14:06-Mac-Pro-3 kernel[0] <Debug>: Wake reason: EHCI

    --- last message repeated 1 time ---

    Jun 28 23:25:01-Mac-Pro-3 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    --- last message repeated 5 times ---

    Jul  1 06:46:52-Mac-Pro-3 kernel[0] <Debug>: Wake reason: EHCI

    Jul  1 23:02:03-Mac-Pro-3 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    Jul  2 00:50:31-Mac-Pro-4 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    --- last message repeated 2 times ---

    Jul  2 06:01:00-Mac-Pro-4 kernel[0] <Debug>: Wake reason: EHCI

    Jul  2 23:02:19-Mac-Pro-4 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    --- last message repeated 3 times ---

    Jul  3 07:02:22-Mac-Pro-4 kernel[0] <Debug>: Wake reason: LAN1 (Network)

    Jul  3 23:16:01-Mac-Pro-4 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    --- last message repeated 2 times ---

    Jul  4 02:59:41-Mac-Pro-4 kernel[0] <Debug>: Wake reason: LAN1 (Network)

  • Linc Davis Level 10 Level 10 (158,425 points)

    In the Energy Saver preference pane, disable Wake for network access and delete any scheduled wake events.

  • s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)

    Great. I didn't have any scheduled wake events, but "Wake for network access" was enabled. I disabled it, so we'll see if that works.

     

    Thanks for your help.

  • s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)

    Linc,

     

    Your solution worked.

     

    However, now I'm having a different problem.

     

    I decided to schedule a regular, nightly back-up to an internal drive in my Mac Pro. I created a schedule in Energy Saver to wake the computer at 12am each night, and then put it back to sleep at 1am after the backup is complete.

     

    It worked fine the first night; but since then, when I wake up in the morning the computer is on (it wasn't put back to sleep).

     

    I ran the command you suggested in your original reply, and this is what came back:

     

    Jul 21 00:00:02 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    Jul 21 05:13:15 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: EHCI

    Jul 22 00:00:02 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    Jul 22 05:43:47 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: EHCI

    Jul 23 00:00:02 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: RTC (Alarm)

     

    Do you know what EHCI is, and why it's waking my computer?

  • s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)

    I did a little more research, and it seems EHCI is a high-speed USB bus?

     

    What's strange, though, is that this EHCI waking only started after I scheduled the wake/sleep event. It wasn't happening before.

  • Linc Davis Level 10 Level 10 (158,425 points)

    ▹ System Preferences ▹ Bluetooth ▹ Advanced ▹ Allow Bluetooth devices to wake this computer: uncheck.

  • s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)

    Thank you. Unfortunately, that option was already unchecked.

  • Linc Davis Level 10 Level 10 (158,425 points)

    Disconnect all USB devices before going to bed. Test.

  • s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)

    Okay, I disconnected all USB devices before going to bed. The computer was still awake when I woke up. Here's the log:

     

    Jul 19 06:04:05 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: EHCI

    --- last message repeated 1 time ---

    Jul 21 00:00:02 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    Jul 21 05:13:15 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: EHCI

    Jul 22 00:00:02 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    Jul 22 05:43:47 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: EHCI

    Jul 23 00:00:02 Chriss-Mac-Pro-4 kernel[0] <Debug>: Wake reason: RTC (Alarm)

    --- last message repeated 2 times ---

     

    It looks like on the 24th and the 25th there are no entries for why it woke up. Or does "last message repeated 2 times" mean that on the 24th and 25th the wake reason was the RTC (Alarm)?

  • s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)

    I guess the RTC (Alarm) is waking due to the schedule I set. But for some reason it's not going back to sleep as it should.

  • Linc Davis Level 10 Level 10 (158,425 points)

    Does it sleep when idle, if you set a timeout of, say, 5 minutes?

  • s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)

    No, it doesn't. I just set it to sleep in 3 minutes. Went to make a cup of tea, came back, still awake.

  • Linc Davis Level 10 Level 10 (158,425 points)

    Test after each of the following steps that you haven’t already tried:

     

    Step 1

     

    ▹ System Preferences ▹ Print & Scan ▹ Open Print Queue...

    Check all printers for unfinished jobs. Deal with any you find.

     

    Step 2

     

    ▹ System Preferences ▹ Energy Saver ▹ Power Adapter ▹ Wake for network access: uncheck. You may need to unlock the preference pane by clicking the lock icon in the lower left corner and entering your administrator password.

     

    Step 3

     

    ▹ System Preferences ▹ Energy Saver ▹ Schedule… ▹ Start up or wake: uncheck

     

    Step 4

     

    Disconnect all wired peripherals except keyboard, mouse or trackball, and monitor, if applicable.

     

    Step 5

     

    Launch the Activity Monitor application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ If you’re running OS X 10.7 or later, open LaunchPad. Click Utilities, then Activity Monitor in the page that opens.

     

    Select All Processes from the menu in the toolbar of the Activity Monitor window, if not already selected. Enter “powerd” (without the quotes) in the "Filter" text field. Select the powerd process and click the Quit Process button in the toobar (stop-sign icon.) In the sheet that opens, click Force Quit. You’ll be prompted for your administrator password. The process will be relaunched immediately.

     

    Step 6

     

    Boot in safe mode and log in. The instructions provided by Apple are as follows:

     

    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, you can’t boot in safe mode.

     

    Safe mode is much slower to boot and run than normal. Don’t launch any applications at first. If sleep still doesn’t work properly, back up all data and reinstall the OS. After that, if you still have the issue, make a “Genius” appointment at an Apple Store to have the machine tested.

     

    If sleep now works as expected, go on to the next step.

     

    Step 7

     

    Still in safe mode, launch the usual set of applications that are running when you have the problem, including your login items, one at a time, testing after each one. Some applications may not work; skip them. You might be able to identify the cause of the problem this way.

     

    Step 8

     

    If sleep is still working after you’ve launched all the usual applications, reboot as usual (not in safe mode) and test again. If sleep still works, you’re done, at least for the moment.

     

    If you still have the sleep issue after booting out of safe mode, post again.

Previous 1 2 Next