7 Replies Latest reply: Jul 4, 2012 9:40 PM by rkaufmann87
RAWeston Level 1 Level 1 (0 points)

Magic Mouse worked for about 2 weeks - local Apple store says "no problem with the mouse" - any suggestions?

iMac, Mac OS X (10.6.3), 21.5 screen
  • rkaufmann87 Level 9 Level 9 (51,870 points)

    Do you really want some assistance? You haven't posted anything useful to help troubleshoot what problems you might be having.

  • RAWeston Level 1 Level 1 (0 points)

    I'm running Mac OS 10.6.8 and have had this iMac computer for a couple of years. I am considering upgrading to Mountain Lion, but if the Magic Mouse isn't communicating with the computer, then I assume the Magic Track Pad wouldn't either.


    I took the Magic Mouse into a local Apple authorized dealer who determined that the mouse wasn't the problem so, at that point, I just decided it would be easier to use a USB mouse rather than hassle with the computer warranty, etc.


    The computer will recognize the mouse but the cursor will not move hardly at all.


    Thank you for any help you may be able to offer,



  • rkaufmann87 Level 9 Level 9 (51,870 points)

    In your initial post you did not indicate the issue was the MM wasn't communicating with the computer. Do you have a wireless keyboard and if so does it work OK?


    Also be specfic about what trouble shooting you have attempted.

  • RAWeston Level 1 Level 1 (0 points)

    The wireless keyboard works just fine! To the best of my knowledge, I have removed devices which might interfere with the bluetooth connection - cordless phones, etc.


    I also ran the Apple Hardware Checking program, which stated there were no hardware issues.

  • rkaufmann87 Level 9 Level 9 (51,870 points)

    Have you gone into System Preferences - Bluetooth - and checked to see if the MM is paired with the computer, either way I'd select it on the left and disconnect by clicking the - symbol below. Then use:




    to repair the MM.

  • RAWeston Level 1 Level 1 (0 points)

    Ok...... after following your instructions, the mouse is re.... "paired" and connected, but the cursor is still hurky/jurky or doesn't move at all, though the finger-scrolling works.


    The Bluetooth setup will sometimes "find" the MM and sometimes not, but even if the MM is "found", the cursor does not work properly.


    Don't get me wrong, I do appreciate your help, but this is getting frustrating!

  • rkaufmann87 Level 9 Level 9 (51,870 points)

    Try restarting in Safe Mode and resetting both the SMC and PRAM, you can find instructions for all in Google.