7 Replies Latest reply: Dec 12, 2012 12:03 PM by Bob Timmons
kwaara Level 1 Level 1 (0 points)

I'm trying to set up a external HD as a share drive for the first time by connecting it to my Airport Extreme.  I can't see my hard disk where it is supppose to show up in Finder under Shared. There's nothing.  No Shared, no external HD. Anybody know why?  The HD is good, it works when I connect it directly to my imac.  Thanks


iMac, iOS 5.1.1, AirPort Extreme
  • 1. Re: Can't see my hard drive on my AirPort Extreme
    Tesserax Level 8 Level 8 (48,245 points)

    When connected to the AirPort's USB port, does the hard drive show up and recognized properly in the AirPort Utility?

  • 2. Re: Can't see my hard drive on my AirPort Extreme
    kwaara Level 1 Level 1 (0 points)

    No I don't see it there either.  I did notice that when I removed the HD it was hot.  I tested it again directly to my iMac and it still works. Am I suppose to have a seperate power supply for the HD when connected to the AirPort?  It works fine without one when connected to the iMac. 

  • 3. Re: Can't see my hard drive on my AirPort Extreme
    Tesserax Level 8 Level 8 (48,245 points)

    If the drive is not being recognized by the AirPort Utility, it can't be shared out and why you are not seeing it in the Finder. The USB port on the AirPort can support USB bus-driven drives, but may require a powered USB hub be used if the drive draws more power than the port can supply.

  • 4. Re: Can't see my hard drive on my AirPort Extreme
    kwaara Level 1 Level 1 (0 points)

    Okay good information. I'll try a powered HD or connect the one I have to a powered hub and see if that works. Thanks for your help.

  • 5. Re: Can't see my hard drive on my AirPort Extreme
    Benjimang Level 1 Level 1 (0 points)

    Sorry to dig up an old thread, but I'm having the same problems actually. Everything else on my network seems to run fine (2x iPhone 4s', Apple TV and a Macbook Air). The hard drive is a powered drive and I have even tried a powered hub in there too with no luck. It just doesn't show up in Finder or as a partition in the Airport Utility. Is this a sharing issue of some sort? Do I have to set the drive up in any way while connected to my Mac?

     

    BTW, the drive has been formatted in HFS+ Journalled, encrypted, case sensitive. I have turned Time Machine off and deleted the backup folder on that external Hard Drive. I don't want to use it for backing up, just for media sharing.

     

    Cheers,

    Ben

  • 6. Re: Can't see my hard drive on my AirPort Extreme
    Krjstoff Level 1 Level 1 (0 points)

    I'm currently having the same problem.

     

    For a very long time, I've been using my Extreme with a 2TB external WD drive with seperate power supply.

     

    Today I installed two old 2.5" drives ind a RAID1 enclosure, which I want to use for even more redundant back ups (NOT for speed).

     

    But somehow my Extreme fail to see the attached drive.

     

    I've tried ways of powering up and connecting in different stages, but nothing works.

    When I unplug the enclosure from the Extreme and connect it directly to my Macbook, there seems to be nothing wrong. Drive shows up and everything seems to be working.

     

    Anybody got a clue?

  • 7. Re: Can't see my hard drive on my AirPort Extreme
    Bob Timmons Level 9 Level 9 (78,645 points)

    See my answer to your question on the other post.