14 Replies Latest reply: Nov 20, 2013 1:24 AM by whcressall
Adrian Smith4 Level 1 Level 1 (5 points)

If you get an "Operation Not Allowed Message" let me save you some time.

 

I had this happen to me. It's a bug - nothing you could have done to prevent it.

 

There is no work around.

 

It's a bug.

 

I'm affraid you have to quit and relaunch.

 

A pain - certainly.

 

Scream now and scream loudly.

 

No amount of copying, pasting, renaming, preference dumping, permissions fixing will save you.

 

Chances are this happened to you after you shift-deleted a nested sequence (probably by accident)

 

I am told there are other culprits equally frustrating too.

 

Moral of the story - save as you go.

 

Often.

 

Sorry to be the bearer of such bad news - it happened to me on deadline too.

 

Oh well - up all night again re-doing the work that was a mega pain in the bum the first time round.


MacBook Pro, Mac OS X (10.6.7)
  • mishmumken Level 5 Level 5 (4,000 points)

    There is no such bug that I personally know about. Try to repair permissions on all connected drives and use Diskwarrior if you have it. Also make sure all drives are correctly formatted as HFS+.

     

    If the problem persists yo may want to be a little more specific about your particular case.

  • Michael Grenadier Level 7 Level 7 (20,335 points)

    I agree that saving regularly is a good idea.  Also, duplicating your sequence so you can quickly get back to a state that you choose.  But don't you know about the autosave vault?   And you can go to file: restore: from within fcp, or manually open an autosave version from the finder.  If it ain't working (which does occasionally happen), then you probably need to delete your preferences. 

  • Adrian Smith4 Level 1 Level 1 (5 points)

    Oh yes there is... and ithe bug iis well documented in many places. A simple Google search will reveal much.

     

    There are also many reports on it from many experienced editors.

     

    I have 20 years experience working with the BBC and had our own support team trying to fix it too.

     

    Guess what?

    .

    There is nothing you can do.

     

    Hopefully it won't happen to you.

     

    In this instance It probably resulted from deleting a nest while pribably accidently hitting delete at the same time

     

    Upon quiiting and restart the problem is cleared. But until you do that no amount of throwing away preferences, copying and pasting to a new sequence, reparing disk permissions, switching drives, clearing hard drive space or praying to the deity of your choice is going to do a bloody thing.

     

    You're stuck with it mate. Cry, have a beer/cup of tea then call the significant other and tell them it's going to be a late night.

     

    Good luck and thanlks for chiming in.

  • Adrian Smith4 Level 1 Level 1 (5 points)

    I can actually now repeat the problem on demand. If you would like to test it for yourself set up a test sequence with some random clips. Three or four indvidial clips will be enough. Now nest those items and save the sequence - call it "Buggering Test Nest 01."

     

    God - you can tell I'm procastinating can't you (must be on deadline or something).

     

    Now create a second sequence then copy and paste Buggering Test Nest 01 into it. If you prefer you can drag the nest into a bin and then drag it to the timeline (it doesn't matter).

     

    Now say loudly "well I don't like the way these clips are nested I shall delete the sods." Then double click on the nest (which will open the nest as its own sequnce timeline) and delete the clips. Close the now empty nest sequence and look at the new/second sequence we created. You will see the thin strip of remaining empty nest.

     

    Now here is the fiendishly clever part. Accidentally on purpose press shift and delete at the same time ('cos we're human and all make mistakes - except for really snooty gits who are untrustworthy anyway) . The empty nest is deleted. Now try and save the project. Chances are you won't be able to - no matter what you do.

     

    Oh and it also disables the autosave feature  - I tell ya it's the work of the devil.

     

    if you can save it - you obviously haven't effed it up properly.

     

    My point all along has been to advise other users who run into this fairly rare but deadly situation is that there is nothing you can do - and don't do as I did - spend hours trying to figure out a workaround when there isn't one to be had. Just bite the bullet, quit and restart. Then cry as you re-do all the work you lost.

     

    I have heard mumblings about maybe finding a slightly more recent saved version in the autosave vault... in the interest of full disclosure I have not tried that.

     

    There are those who say - "well pros don't make mistakes..."  My advice is to  flee from such people quickly  as they are probably verging on the sociopathic." I learned that tip from working with Nic Roeg many years ago. Fabulous mistakes often lead to incredible work - though more often than not to a bucket of poo.

  • Michael Grenadier Level 7 Level 7 (20,335 points)

    Is there a reason you haven't even checked out the autosave vault?  At most, you'd have lost 1/2 hrs worth of work (by default, fcp will save a backup every 1/2 hr - unless you'd set up some ridiculously long autosave interval). 

     

    I've never known a professional editor that claimed he never made mistakes.  That's one of the reasons non-linear edit systems are such a godsend.  You can make all the mistakes in the world and still do great work.

  • Adrian Smith4 Level 1 Level 1 (5 points)

    As I mentioned I spaced on checking the autosave. As it turned out I only lost about 30 minutes of work (as I do try and save on the fly) but one forgets when immersed in the work. The point is moot as the issue I was posting about regarded the need to quit and restart after a "Operation Not Allowed" message when trying to save. No work around for that.

     

    Once you have quit you can check the autosave (you  might be lucky) or just redo the work lost.

     

    And as for the more snarky variety of media pro - regrettably you come across them all the time in forums (mostly on Creative Cow) who seem delight in hollering "user error..." and "well a pro wouldn't have done this or that..." when some frantic person has just had their system crash and is desperately trying to find a solution. I wish such people would keep their opinions to themselves unless they have an actual solution or practical advice on hand.

     

    Again - the thrust of my post is just to advise anyone who fins themselves in the same situation to save themselves time trying to find a solution to the "Operation Not Allowed" scenario and quit and restart.

     

    Once you have done that you can check your autosave vault (as we have now learned).

     

    Meanwhile, you usually can get here from there. Sometimes you just need a Tardids

     

    Anyway, Michael. nice chatting with you. Good luck with your projects.

     

    Over and out.

  • Ian Mcalpin Level 1 Level 1 (25 points)

    If you haven't quit / restarted and want to save that last 30minutes of work:

     

    - Select your working sequences in the Browser (or everything)

    - Enter Media Manager and

          - Use existing

         - Don't delete unused media

     

    This creates a new project with whatever you were just working on, which you can bring back into your main project after restart.

     

    Doesn't fix the bug, but no reason to lose work.

  • Pavlop Level 1 Level 1 (0 points)

    Try closing the sequence tabs of the project and then saving the file. Worked for me.

  • wafersong Level 1 Level 1 (0 points)

    make a new project, save as another name on desktop,

     

    copy whole bin(include everything) from error project then paste them to new project bin.

     

    and.. just save it.

     

    it worked for me but not sure for your situation.

     

  • reyna09 Level 1 Level 1 (0 points)

    Forget having to start over, this was great suggestion.

     

    Thank you

  • tkjeldsen_dk Level 1 Level 1 (0 points)

    Hi all

     

    im new to Final Cut Pro 7 im not a user of it but supporter in a company that uses it

     

    iv got 4 who is using it

     

    3 of them have no problem but one have, thy all save on the same windows server (NTFS) and again 3 can save but one can not...

     

    there profiles are all the same.

    if you save a text dok it works if you save to the desktop it works you can then drag the file to the server at it works but save to the server from final cut he gets Operation not allowed

     

    im hoping that one of you can help me , none of the solutions listed on other forums or this works

     

    /Thomas

     


  • Michael Grenadier Level 7 Level 7 (20,335 points)

    This problem sounds very different from the original post.  I'd start a new thread with Windows NTSF Network included in the subject so if anyone on this board has any expertise in this area, they'll see it.  I have next to no expertise on this subject, but here are a few thoughts.

     

    Using FCP with a network is never ideal, unless the network has been specifically designed to allow this sort of situation.  Hopefully, you've got an IT person who can sort this out for you. 

     

    Are all the users working with the same MacOS?  Is the hardware the same and do the network connections match?  If not, I'd see if there's a common denominator on all the machines that work.  You might also investigate the network settings in system preferences.  I don't think this is a fcp problem per se.  

     

    Could also be a permissions issue for this specific machine. 

  • tkjeldsen_dk Level 1 Level 1 (0 points)

    thx i open op a new one

  • whcressall Level 1 Level 1 (0 points)

    Wafer, you saved my bacon. Let no one say this isn't a bug because it is. But you were smarter than the bug and for that I thank you.