11 Replies Latest reply: Jul 7, 2012 12:26 PM by Dansyacht
Samphire Level 1 (0 points)

When a TextEdit window is opened the text format menu bar appears behind the dock and cannot be accessed, moved or removed.  When the window is cosdd the format bar disappears.


I can find nothing in Preferences or Help which deals with the problem.

iMac (24-inch Mid 2007), Mac OS X (10.7.4)
  • Dansyacht Level 4 (2,120 points)

    Not sure what you mean by format menu bar in TextEdit.  If something is somehow stuck behind the dock you can hide, move or resize the dock from System Preferences > Dock, move the hidden item, then put the dock back the way you want it.

  • Samphire Level 1 (0 points)

    Thanks for the reply Dansyacht.


    If only it were that simple.   The format menu bar sits towards the lefthand end of the dock with the top of it poking just above the shelf but below the top of the icons so it is not possible to grab it.  However, if you move the dock elsewhere to reveal the bar and then try to drag it to where it would be visible above the dock it is immoveable.   However, Mission Control will allow it to be moved from desktop to desktop where it just springs back to it's original position (but on a different desktop).


    The bar is part of the TextEdit Save box.  Try to save a TextEdit file and when the Save box comes up it is the icon towards the bottom of the box which says <"File format: " + the adjacent menu bar>.  


    It is as though a mutant clone of the Save box icon has escaped in order to rise above its station to try to become a Dock icon.  Sweet but very annoying.

  • Dansyacht Level 4 (2,120 points)

    If this is a problem associated with "Mission Control" then I think you are posting on the wrong forum.  MC is a Lion feature and this is the Snow Leopard forum.  I have no experience with Lion problems.  You should probably repost your question on the Lion forum

  • Samphire Level 1 (0 points)

    I very much doubt that this is a problem with Mission Control.  I only mentioned it to illustrate what happens when you use MC to get to the icon to try to move it.   The same effect of the icon springing back to its original position occurs within the same desktop if the dock is moved to the left or right hand sides of the screen to enable one to see to grab the icon.


    After my last reply I tried quitting TextEdit, removing it from the Dock and then reloading it.  For a time this solved the problem but, this morning, the icon is back where it was.

  • Dansyacht Level 4 (2,120 points)

    I've reread your posting several times and I still cannot understand your problem.  Sorry, it's probably my fault.  Could your post a screen shot or two so I can see what is actually happening?  Screen shot is shift + command + 3.  Alternatively shift + command + 4 will let you grab a portion of the screen.



  • Samphire Level 1 (0 points)



    Thanks for taking the time out to respond.


    In the first screenshot I have outlined the rogue Save box icon(s) in red:






    And below it is shown appearing on the desktop under Mission Control format.  The icon which previously was hiding behind the left end of the dock (see final screenshot) moves across the screen and attaches itself to the top of the TextEdit window but, then, when I move the TextEdit window the icon shoots to the bottom left of the Mission Control screen.  I cannot take a screenshot of this because when the mouse button is released the TextEdit window moves back to its original position and the icon shoots back to re-attach itself to the top of the TextEdit window.   This is true of any windows you try to move while under Mission Control mode - but without a rogue icon.  It is rather similar to the way each open window which appears in Mission Control has its dock icon attached to its base - except the rogue icon attaches itself to the top of the TextEdit window.






    And here it is finally shown arrowed hiding in its normal position behind the dock:



  • macjack Level 9 (50,740 points)

    Dansyacht asked for some help here...


    Try this...


    Go to your Finder "Go" menu hold the option key to choose "Library".

    Then go to Preferences/com.apple.TextEdit.plist and delete that file.

    Relaunch TE.

    Let us know.

  • Samphire Level 1 (0 points)

    Thanks Macjack,


    Your advice seems to have worked.

  • macjack Level 9 (50,740 points)

    Glad to hear that.

    Dansyacht certainly helped you get it solved.

  • Samphire Level 1 (0 points)

    Yes - my thanks to Dansyacht as well.

  • Dansyacht Level 4 (2,120 points)

    Yea,  except my contribution was limited to getting thoroughly confused myself and pleading for help too.