Skip navigation

Safari won't display PDFs

5579 Views 13 Replies Latest reply: Dec 19, 2012 6:04 AM by ROWRBAZZLE! RSS
OS2Guy Level 2 Level 2 (310 points)
Currently Being Moderated
Jul 5, 2012 10:31 AM

I have five Macs - from MacBook Pros to Mac Pros and I have never been able to view a PDF in Safari.  I needed some legal documents and they were placed online as PDFs.  I tried to view them but was presented with a blank black page in Safari and no option to download the PDF.

 

This happens on all five of my Macs.  I went to my neighbor who has a new MacBook Pro and went to the same site and presto!  There were the documents.  I had to download, copy to Flash and bring them home.

 

What is the problem here?  What is it on my systems - which are cloned from one main system - that stops me from viewing or downloading a PDF.  I've removed the Adbobe Acrosbat plugin, as suggested, and any other pdf plugins.  Reinstalled Lion.  Reinstalled Safari - all to no avail.  This is ridiculous!

 

Does anyone have an answer?

 

I can easily view the pdfs on my iPad but there, I cannot download them (and yes, I've tried opening them in iBooks, GoodReader, and the familiar productivity apps. 

 

Where do I go on my system to fix this?

3.2Ghz Mac Pro w/16GRam, 12TBHD, 2 SuperDrives; MBP 2.53GHz w/4G Ram;, iOS 1.x, 2-30" Cinema, HPColorLJ Printer, 12TB Ext HDs, 32G iPhone 4
  • Linc Davis Level 10 Level 10 (107,610 points)
    Currently Being Moderated
    Jul 5, 2012 10:40 AM (in response to OS2Guy)

    Select Help Installed Plug-ins from the Safari menu bar. Besides the following, what plugins are listed?

     

    iPhotoPhotocast

    Java

    QuickTime

    Shockwave Flash

    WebKit built-in PDF

  • Linc Davis Level 10 Level 10 (107,610 points)
    Currently Being Moderated
    Jul 5, 2012 11:15 AM (in response to OS2Guy)

    Back up all data.

     

    Quit Safari. In the Finder, select Go Go to Folder... from the menu bar, or press the key combination shift-command-G. Copy the line of text below into the box that opens, and press return:

     

    /Library/Internet Plug-ins

     

    From the folder that opens, remove any items that have the letters “PDF” in the name. You may be prompted for your login password. Then launch Safari and test.

     

    If you still have the issue, repeat with this line:

     

    ~/Library/Internet Plug-ins

     

    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari again.

  • Linc Davis Level 10 Level 10 (107,610 points)
    Currently Being Moderated
    Jul 5, 2012 11:52 AM (in response to OS2Guy)

    At 11:09 AM, you had not removed the Adobe PDF plugin. If you have since removed it and relaunched Safari, please post that information again.

  • Linc Davis Level 10 Level 10 (107,610 points)
    Currently Being Moderated
    Jul 5, 2012 2:43 PM (in response to OS2Guy)

    Have you again selected Help Installed Plug-ins from the Safari menu bar and verified that no PDF plugin is loaded, other than "WebKit built-in PDF"? You had two different ones before.

  • GParker Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 10, 2012 6:56 PM (in response to Linc Davis)

    Could you please help me with this issue? I tried  the Help>Installed Plug-ins and this is what I have left...

     

    Coupons Inc., Coupon Printing FireFox Plugin

    Coupons Inc., Coupon Printing FireFox Plugin — from file “CouponPrinter-FireFox_v2.plugin”.

    MIME Type          Description          Extensions

    application/couponsinc-moz-printer-plugin-v401          Coupons Inc., Mac FireFox Coupon Printer Manager v401

    application/couponsinc-printer-plugin          Coupons Inc., Mac FireFox Coupon Printer Manager

    Facebook Plug-In

    http://www.facebook.com/fbplugin/ — from file “fbplugin_1_0_3.plugin”.

    MIME Type          Description          Extensions

    application/x-facebook-plugin_1_0_3          Facebook Plug-In

    Facebook Video Calling Plugin

    Facebook Video Calling by Skype — from file “FacebookVideoCalling.bundle”.

    MIME Type          Description          Extensions

    application/skypesdk-plugin          Facebook Video Calling plugin provided by Skype

    Flip4Mac Windows Media Plugin 2.3.8

    The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime. — from file “Flip4Mac WMV Plugin.plugin”.

    MIME Type          Description          Extensions

    application/asx          Windows Media Plugin

    application/x-mplayer2          Windows Media Plugin

    application/x-ms-wmp          Windows Media Plugin

    audio/x-ms-wax          Windows Media Playlist          wax

    audio/x-ms-wma          Windows Media Audio          wma

    video/x-ms-asf          Windows Media Video          asf

    video/x-ms-asf-plugin          Windows Media Plugin

    video/x-ms-asx          Windows Media Playlist          asx

    video/x-ms-wm          Windows Media Video          wm

    video/x-ms-wmp          Windows Media Video          wmp

    video/x-ms-wmv          Windows Media Video          wmv

    video/x-ms-wmx          Windows Media Playlist          wmx

    video/x-ms-wvx          Windows Media Playlist          wvx

    Garmin Communicator Plug-in Version 2.9.3.0

    Garmin Communicator Plug-in Version 2.9.3.0 — from file “GarminGpsControl.plugin”.

    MIME Type          Description          Extensions

    application/vnd-garmin.mygarmin          Garmin GPS Control          mygarmin

    Musicnotes

    Musicnotes Viewer plugin 1.18.6 http://www.musicnotes.com — from file “Musicnotes.plugin”.

    MIME Type          Description          Extensions

    application/x-musicnotes          Musicnotes          mtd,mgt

    Silverlight Plug-In

    4.0.51204.0 — from file “Silverlight.plugin”.

    MIME Type          Description          Extensions

    application/x-silverlight          Microsoft Silverlight          xaml

    application/x-silverlight-2          Microsoft Silverlight          xaml

  • Carole Aldrich Calculating status...
    Currently Being Moderated
    Sep 25, 2012 1:47 PM (in response to OS2Guy)

    Where do you find the plug-ins to remove them? I've looked in the Libraries and Application Support folders. Have searched the hard drive, but come up with nothing. Theres are a number of Acrobat Plug-ins installed, but I can't figure out where they are to get rid of them. Please help.

  • Blake Pilgreen Calculating status...
    Currently Being Moderated
    Oct 8, 2012 2:36 PM (in response to Carole Aldrich)

    I was unable to view or print a .pdf from Safari. I uninstalled Acrobat viewer. Still no luck. I Then re-installed Acrobat Viewer X. Still no luck.

     

    Finally, I did a spotlight search for this single file:

    AdobePDFViewerNPAPI.plugin

     

    It was located here: Macintosh HD/Library/Internet Plug-Ins

     

    Found it, then promptly deleted it. Restarted Safari and now everything works fine.

     

    Thanks for the help everyone!

  • spacebender Calculating status...
    Currently Being Moderated
    Nov 23, 2012 12:52 PM (in response to Linc Davis)

    Thank you so much, Linc!  Peeking in the second location (~/Library/Internet Plug-ins) led to the solution, as my Schubert plugin apparently won't work with OS 10.7.5.

     

    PDF Browser Plugin.plugin

  • ROWRBAZZLE! Calculating status...
    Currently Being Moderated
    Dec 19, 2012 6:04 AM (in response to Blake Pilgreen)

    Thanks for this post. Was having similar trouble with loading pdf into Safari being broken since I installed new Adobe Reader (XI). Deleting AdobePDFViewerNPAPI.plugin and restart of Safari fixed the problem.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.