Previous 1 2 3 Next 33 Replies Latest reply: Mar 7, 2013 10:42 AM by DileepVarala
TKDigiCom Level 1 (5 points)

Hi All,


In 1 sentence:

I have a brand new MBP-R and I have found that external USB 3 drives do not work!



I have the base MBP-R, all updates installed.

I've bought and tried, 2 '11-'12 Seagate GoFlex Desk 3TB, 1 Mid '12 Seagate GoFlex Desk 3TB (white box), and 1 Western Digital My Book 3TB.

After formatting any of the Seagate's to Mac OS then ejecting the HD, none of them will re-mount.

After formatting the WD to Mac OS it will only operate at USB 2 speeds. I did not test the speed before formatting to Mac OS.


I've bought each of the HD's at Best Buy, and I have spent an hour with the Geek Squad working on the issue with no success.


I have spent over 3 hours with Genius’s at 2 different Apple stores with no success. No one at apple supposedly had heard of this problem. We did test a Seagate drive on 2 other MBP that the Apple store had on display and the drive would not mount to either MBP-R.


When I say the drives would not mount I mean that they do not show up in Finder or in Disc Utility.


Sometimes (not all the time) the drive is visible in the System Report.


One genius said the problem may be fixed in Mountain Lion… but it may not.


Basically I’ve spent thousands of $’s on a defective product with advertised features that that do not work. I am very disappointed in Apple.


BTW all the drives worked on my Windows PC!



MacBook Pro with Retina display, Mac OS X (10.7.4)
Previous 1 2 3 Next