Previous 1 2 3 Next 33 Replies Latest reply: Mar 7, 2013 10:42 AM by DileepVarala Go to original post
  • clintonfrombirmingham Level 7 (30,000 points)

    It was supposed to address USB 3.0 problems, but I haven't seen anyone - yet - post to see if it actually resolved the external drive/hubs/etc., problems.



  • TKDigiCom Level 1 (5 points)

    I didnt even know there was an update until I read this thread.


    I installed the update and restarted, but I returned all the USB 3 drives I bought because they didn't work.


    Hopefully someone else with USB 3 drives can chime in.


    I was going to wait for Mountain Lion, but I might go pickup a drive this weekend, If I do I'll share my experiance.

  • Trailgoer Level 1 (0 points)

    I am having the same problem on all my USB 3 drives and I am using some from Western Digital and Seagate.


    I have done the updates mentioned.  I am incredibly frustrated as I bought the Retina partially because of the USB 3 drives and now one of them won't mount on my old MacBook Pro.  I really hope this is solved in Mountain Lion.


    I am rather surprised that Apple released these when there is such a problem.  Or is just those of us with USB 3 problems have defective machines?

  • clintonfrombirmingham Level 7 (30,000 points)



    So you're saying that one of your USB 3.0 external storage devices will mount? The WD or the Seagate? From what I've read here, there are some problems with WD USB 3.0 drives so I'm assuming that it's the Seagate that is mounting?


    I was really hoping - for all of you haveing USB 3.0 problems - that the July 18th software update would fix all of the problems. It seems to have fixed some, but not all. I'm sure that I've pointed you to the Apple tech document about working with USB 3.0, but if I haven't, here it is.


    Please let me know which drive is working.





  • akuska Level 1 (0 points)

    Oddly enough, on my 2012 MacBook Air, my sole USB 3.0 device (a cheap no-name HDD enclosure that I bought from NewEgg) is working fine and giving me near-200MB/s read and write speeds on an Intel SSD both before and after the update. I think this may be an issue with flaky drivers by the peripheral manufacturers.

  • MacKyver Level 1 (5 points)

    I have a couple of USB3.0 external drives that are still flaky even after the recent update, randomly disconnecting nad the only way to get it back is to unplug the cable and plug in again.


    At some point, my system crashed and in the first few lines of the crash report, I noticed something that refers to Lacie, of which USB3.0 driver I installed earlier:


    System uptime in nanoseconds: 90600418123379

    last loaded kext at 90544426038390:     1.3 (addr 0xffffff7face4b000, size 61440)

    last unloaded kext at 87082198082017: com.lacie.driver.LaCie_RemoteComms     1.0.1 (addr 0xffffff7face44000, size 8192)

    loaded kexts:

    com.lacie.driver.LaCie_RemoteComms     1.0.1


    Could this be the cause of the USB3.0 issues? I have unistalled the driver using Lacie's uninstaller but it seems there are still traces of its "stuff" on the system.

  • psedog Level 1 (0 points)

    I noticed before I applied the patch that my drive was working fine in Snow Leopard. After the update it's working as well. Not sure what happened.

  • clintonfrombirmingham Level 7 (30,000 points)

    Use the free app "EasyFind", free from the App Store to search for "lacie" and delete any files that it finds. That will be one way to determine if it is, in fact, some remnant LaCie drivers holding you hostage.



  • Trailgoer Level 1 (0 points)

    Hello Clinton


    The Western Digitals struggle more than the Seagate but neither mount all the time. 


    It is strange as both seem to mount sometimes then will all of a sudden disappear and then will not mount.  There doesn't seem to be any consistency with this.


    However, once any of my hard drives disappears while still being connected, then it seems to need to cool down and 'rest' for hours before they will mount even on my old Mac Book Pro or Mac Mini through USB 2. 


    The Western Digitals will be inaccessible for longer periods of time so as of a couple days ago, I stopped using the Western Digitals on the Retina until things seem to improve.

  • TKDigiCom Level 1 (5 points)

    Well I picked up a brand new Segate Desk 3TB today.


    It mounted right out of th box, I used disk utility to reformat it to Mac OS Journaled, edjected and it remounted fine! Tried both ports multiple times, with and without other devices connected and it all works. I'm seeing low 170 MB/s RW speeds.


    It seems this update made USB 3 work on my MBPr!


    One note this Segate mounted as Segate Backup + Desk Media

    All other Segates I tried mounted as Segate GoFlex Desk Media including one that's over a year old that has worked from day 1.

  • Purd Level 1 (70 points)

    MIne is a Buffalo 1TB USB 3.0 external HDD. It work fine on MBP-R. No problem at all

  • twairball Level 1 (0 points)

    Hi Guys -- really appreciate the posts in this thread, I spent 4+ hours after playing with brand new Retina Pro (Lion) trying to figure out why my Razer Abyssus mouse wouldnt work.


    * 150mA mouse doesn't work in either left or right USB ports. System->Mouse doesn't find it. System Report doesnt see it either. Lights up and everything, and works fine on 2008 MBP


    * 100mA mouse works fine.


    * 7/18 patch did NOT resolve this.


    * Seems like USB3 ports are selective.

  • EJViper Level 1 (0 points)

    I seem to be in this same boat and it's frustrating.


    I have a new MBP-R (OS X 10.8.1 - 15" - 2.6GHz - 16 GB)


    I plugged in my Western Digital USB 3.0 Passport Portable HDD and it worked just fine, for a while, then I couldn't get it to read it again. I went on my pc and reformated the HDD to exFAT and it worked again for a while, then It wouldn't show up on disk utility or finder, neither does on the "System Report".


    I plug in my older usb 2.0 Western Digital Passport and works perfectly and it doesn't stop working all of a sudden like the 3.0 does. I even playedback a movie from it and held just fine.


    I have been searching around and I can't find a way to fix this. I can't find an update of fix on apple support either.

  • hyderali91 Level 1 (10 points)

    I also have a Western Digital USB 3.0 drive that just wouldn't work in USB3 mode (worked fine when hooked up to a USB 2 cable). A buddy of mine has the exact same model drive and to my surprise my rMBP connected to it just fine. I then tried using his cable on my drive and it actually worked!


    I've since ordered a new cable from Amazon, and my drive works great. Seems to connect every time

  • junkyardrocker Level 1 (0 points)

    I have a toshiba usb 3.0 hard disk that won't work. Not on lion and not on montain lion with all updates available. But it works fine (at least it's being mounted) on snow leopard.