1 2 3 Previous Next 33 Replies Latest reply: Mar 7, 2013 10:42 AM by DileepVarala
TKDigiCom Level 1 Level 1 (5 points)

Hi All,

 

In 1 sentence:

I have a brand new MBP-R and I have found that external USB 3 drives do not work!

 

Details:

I have the base MBP-R, all updates installed.

I've bought and tried, 2 '11-'12 Seagate GoFlex Desk 3TB, 1 Mid '12 Seagate GoFlex Desk 3TB (white box), and 1 Western Digital My Book 3TB.

After formatting any of the Seagate's to Mac OS then ejecting the HD, none of them will re-mount.

After formatting the WD to Mac OS it will only operate at USB 2 speeds. I did not test the speed before formatting to Mac OS.

 

I've bought each of the HD's at Best Buy, and I have spent an hour with the Geek Squad working on the issue with no success.

 

I have spent over 3 hours with Genius’s at 2 different Apple stores with no success. No one at apple supposedly had heard of this problem. We did test a Seagate drive on 2 other MBP that the Apple store had on display and the drive would not mount to either MBP-R.

 

When I say the drives would not mount I mean that they do not show up in Finder or in Disc Utility.

 

Sometimes (not all the time) the drive is visible in the System Report.

 

One genius said the problem may be fixed in Mountain Lion… but it may not.

 

Basically I’ve spent thousands of $’s on a defective product with advertised features that that do not work. I am very disappointed in Apple.

 

BTW all the drives worked on my Windows PC!

 

Tim


MacBook Pro with Retina display, Mac OS X (10.7.4)
  • 1. Re: USB 3 on MacBook Pro-R Does Not Work!
    BGreg Level 6 Level 6 (17,500 points)

    Since this is a new system, have you called Apple Support? You have 90 days of phone support, and they may have insights that the genius's dont have.

  • 2. Re: USB 3 on MacBook Pro-R Does Not Work!
    TKDigiCom Level 1 Level 1 (5 points)

    Haha ya I left that out. I have AppleCare too.

     

    On the phone they first told me my drive(s) weren't USB 3 and that was the problem. Then when I assured them the drives were USB 3 they escilated my call to someone who wasn't insulting.

     

    The escilted support was not able to solve the issue and just blamed the drive(s) for being faulty.

     

    Tim

  • 3. Re: USB 3 on MacBook Pro-R Does Not Work!
    Bimmer 7 Series Level 6 Level 6 (10,270 points)

    I'm just guessing on this one.

     

    Is it possible that your MBP-R USB port does not have enough power to make your external drives work?

     

    If you have one, try hooking up a powered USB hub, plug your external drive to the HUB and see if it mounts on your MBP-R.

     

    Again, that is only a guess.

  • 4. Re: USB 3 on MacBook Pro-R Does Not Work!
    TKDigiCom Level 1 Level 1 (5 points)

    I suppose it's possible but the drives were plugged in to 110 so I don't think power via USB would be an issue. When plugged into 110 does a drive still need power from the USB or just a signal to wake and data?

     

    I do not have a USB hub to try.

     

    I have no desire to buy a USB hub as it would just slow down the transfer speed with mutiple things plugged into one hub.

  • 5. Re: USB 3 on MacBook Pro-R Does Not Work!
    Bimmer 7 Series Level 6 Level 6 (10,270 points)

    Your external drives are fine then.  I didn't know they were powered drives.

     

    I thought they were being powered by the Retina's USB ports.....

     

    You don't need a HUB.  I think it's an issue with your MBP-R USB port.

     

    My suggestion is to take it to the genius bar and show them in person what your Retina is doing.

     

    Good luck...

  • 6. Re: USB 3 on MacBook Pro-R Does Not Work!
    TKDigiCom Level 1 Level 1 (5 points)

    Thanks Bimmer!

     

    I've been to 2 Apple stores and both Genius Bars... they really tried but couldn't fix it either.

  • 7. Re: USB 3 on MacBook Pro-R Does Not Work!
    Bimmer 7 Series Level 6 Level 6 (10,270 points)

    You're welcome.......

     

    Sorry i couldn't much help.....

     

    I ordered a Retina and have 2-1/2 weeks left before I get it.  I hope I don't have the same issue since my external is not a powered one like yours.

     

    Have a good day....

  • 8. Re: USB 3 on MacBook Pro-R Does Not Work!
    keg55 Level 5 Level 5 (5,925 points)

    Try some of the solutions at this link.

     

    My USB 3 ports worked right off the bat. However, after doing a speed test with a USB 3 (WD My Passport Essential) in the left port and a USB 2 in the right, the right port stopped identifying USB 3. All I did was unplug the USB 3 cable from the right port, unplugged the physical USB 3 drive from the cable, plugged the USB 3 cable into the right port and finally plugged the USB 3 drive into the cable. Opened System Report and the port showed USB 3 again.

     

    The above worked for me. There are other solutions in the link I provided. I don't know if any of that link will help with the issues you're experience with the drives not showing up. Check the "About this Mac / More Info / System Report / USB (under hardware)" and see if the drive(s) show up under any of the USB buses.

  • 9. Re: USB 3 on MacBook Pro-R Does Not Work!
    peterjay45 Level 1 Level 1 (35 points)

    If I am reading the last page of this thread correctly, https://discussions.apple.com/thread/4044696?start=45&tstart=0, Keg55 found that by removing the USB cable from his drive, plugging it into the USB 3 port and then into the drive caused it to be recognized and function correctly.  Not sure if this would assist your situation and you may have tried this already.

     

    peter

     

    I see Keg55 has already responded to this. 

  • 10. Re: USB 3 on MacBook Pro-R Does Not Work!
    TKDigiCom Level 1 Level 1 (5 points)

    Thanks Keg55 and PeterJay.

     

    I read and tried that before posting this thread.

     

    The drive does show up in System Report under USB 3 Super Speed, but not in Finder or Disc Utility.

    This solution may work to recognise the WD as USB 3 insted of 2 but I don't have that drive any more.

     

    I have tried known good cables, even switching the USB bases on the Seagate's, allong everything mentioned in that link, nothing has worked.

     

    One other thing that has been tried many times is holding CMD+OPT+S+P on start up for 2 chimes to reset the ram. That didn't work either.

     

    Tim

  • 11. Re: USB 3 on MacBook Pro-R Does Not Work!
    keg55 Level 5 Level 5 (5,925 points)

    Well, sorry to hear that. There's another user (Solorboy123) in the discussion thread that peterjay45 provided who is having the same issue as you. The flipping drive is just not showing up in Finder or Disk Utilities, but shows up in System Report. You might want to keep an eye on that thread too in case he fines a solution.

  • 12. Re: USB 3 on MacBook Pro-R Does Not Work!
    psedog Level 1 Level 1 (0 points)

    I have a 2012 Seagate GoFlex Desk 2TB and it refuses to work on Lion. I have loaded the latest DP of Mountain Lion and it works pretty well with speeds of 130MB read and write. I honestly think that these laptops were never supposed to run Lion, but Mountain Lion wasn't ready at launch. Anxiously waiting for ML to come out officially

    MBPr 2012-07-01 at 9.37.46 PM.png

  • 13. Re: USB 3 on MacBook Pro-R Does Not Work!
    MacKyver Level 1 Level 1 (5 points)

    Hi peterjay45, I tried all the solutions posted in that thread, but my freaking Lacie USB3.0 drive connected via ExpressCard34 just wouldn't show up in Finder or Disk Utility even though System Report says it's connected!!

     

    How frustrating.

  • 14. Re: USB 3 on MacBook Pro-R Does Not Work!
    akuska Level 1 Level 1 (0 points)

    Did yesterday's software update address this?

1 2 3 Previous Next