Previous 1 2 3 4 Next 58 Replies Latest reply: Oct 15, 2015 4:07 AM by WilsonLaidlaw Go to original post
  • Bart Gibb Level 1 Level 1

    This "Connection failed" problem has been driving me crazy. Tried everything, but nothing worked...until this. Thank you! Now if I could just get Pages to work again...

  • anne-mettefromårhus c Level 1 Level 1

    This worked for me!! Mountain Lion is downloading !

  • jrusch1 Level 1 Level 1

    Hi. Same problem of no App Store and other "trust" issues, but a combination of things worked to clear it up.


    First I tried the blog post instructions referenced above but they didn't work. Then I tried setting my date and time prefs to automatically update, as mentioned (it had been unchecked), but that didn't work either. I then went at the Keychain Access certificate approach one more time. What I did was not mentioned in the blog instructions, but someone else had mentioned System Roots, so I clicked on System Roots in the left hand column of KeyChain Access, then Certificates below that. I *then* noticed some blue plusses on some certificates I hadn't noticed before, and cleaned them all up (Set them to default, per the instructions). I had thought I had got them all, but I hadn't done the System Roots ones, because they're not mentioned by the blog.


    This worked at last. I don't know whether the date thing mattered in conjunction with the rest, but it didn't hurt. Thanks everyone for contibuting.


    Safari now presents secure websites correctly and Mountain Lion is now downloading!

  • Plain Stone Level 1 Level 1

    Hi, I have had the same issue since Lion. I couldn't upgrade to Mt. Lion. I upgraded after a clean install and it worked until I migrated my applicaitons. Long story... Anyway, I saw your post and when I went into the keychain>system roots/certificates, I also found about 8 blue + certificates. However, when I attempted to change them to "system default" I found they wouldn't "stick". When I'd return and look at them, they had all reverted to "always trust", as before. So then, upon the kind suggestion of my new "best friend" at Apple tech support, we changed them to "never trust". The certificate would change to red, and when I reopened each certificate, they had stayed.  Then when I changed them back to "system default" they remained. I rebooted and YEA! now the app store works and I'm downloading updates!!

  • realtorjosh Level 1 Level 1

    Fixed. I took the Mac home (I was using it at work) & logged in to my network. For some unknown reason putting it on a different network solved the issue. It now works everywhere including at work.

  • yma Level 1 Level 1

    Thanks for this!  None of the other solutions worked for me either, but cleaning up the certificates in system roots did.  Yay!

  • Saltykov Level 1 Level 1

    After trying some other suggestions to solve the connection problem, a couple of hours with Apple and a reinstall of system software, I finally came across your post. And it worked!  Thanks.

  • amphitryon Level 1 Level 1

    This worked for me! Thank you!

  • rsnunes Level 1 Level 1

    This method solved my issue!


    Thank you



    from another thread in this forum.

    Now to do this follow this:


    1. Open Key chain access in the Utilities folder
    2. Search for "class 3 public" without quotes
    3. select all the certificates on the list by clicking and holding the cmd key (apple key)
    4. right click selection and choose get info
    5. in the windows that open go one-by-one and click on Trust at the top of the list
    6. From the drop down menu choose "Always trust"
    7. Close window and enter your password if asked
    8. Repeat for all certificates
    9. Close Key Chain Access
  • jmelowry Level 1 Level 1

    Toggling "set date and time automatically" did the trick for me.

  • slazio Level 1 Level 1

    Could NOT figure this issue out on my iMac, but remittancegirl's solution worked like a charm.  Thanks!

  • kylie1981 Level 1 Level 1

    Yep, I got a new macbook air... my pro works fine..... couldn't connect to itunes store or app store.... tried everything else (as I couldn't go elsewhere to try another network) nothing helped, but then der I tried connecting using my iphone personal hotspot and it worked! Disconnected hotspot went back to home network and walla it SEEMS to be fine now???? Very strange! I've spent hours trying to fix it!

  • Bigmac111 Level 1 Level 1

    Worked like a charm.  Thanks!

  • 7ecapilot Level 1 Level 1

    alfredo87, thank you very much. Changing the Class 3 certificates to Always Trust fixed this issue for me. I had deleted all of my certificates and then began manually accepting them when I returned to certain websites (financial, entertainment, etc.). I have also been having a little trouble with the iTunes Store also. So, this seems to have fixed both problems. Wow! Now I have that iPhoto and XCode updates. Nice!

  • Hadil3 Level 1 Level 1