Previous 1 2 3 Next 44 Replies Latest reply: Jul 2, 2014 6:25 PM by JVCMQ Go to original post
  • HowlingF Level 1 Level 1 (0 points)

    I tried Iton's fix as well (disabled "wireless QoS (WMM)") but did not have success. 

     

    FredRx, like you I suspected that wired and wireless devices somehow stopped identifying and communicating with each other through my router, but I just put together a test that has me feeling less confident. 

     

    I considered 4 scenarios for devices communicating on my network: (1) wired sending/wired receiving; (2) wireless sending/wireless receiving; (3) wired sending/wireless receiving; (4) wireless sending/wired receiving.  Then I assessed each as follows:

     

    - (1) seems to work fine (I can stream from itunes to Denon when both PC and Denon are wired; furthermore, the Denon shows up on my PC's list of network devices when both are wired)

     

    - (2) seems to work fine (I can print from wireless PC to wireless printer with no problem; both shop up on my PC's list of network devices when both are wireless)

     

    - (3) seems to work fine (I can access wired Denon from wireless PC's browser using IP address (this means Denon is sending and PC is receiving, right?); However, the Denon does not show up on my PC's list of network devices)

     

    - (4) does not seem to work. (I can't stream from itunes (or iphone) to Denon when PC (or iphone) is wireless and Denon is wired; furthermore, the Denon does not show up on my PC's list of network devices (nor can iphone identify it as a network device) when the PC (or iphone) is wireless and the Denon is wired).

     

    So I just tried to re-create another situation on my network where I had wireless sending and wired receiving: I connected my PC using ethernet and at the same time disabled my PC's wireless, so that my PC"s only connection to the network was through a hardwire.  With the PC now "hardwire only" (and the Denon still "hardwire only"), I can, as expected, still stream from itunes to the Denon using Airplay.  Also, the Denon shows up as a network device in my PC's list of network devices. 

     

    Then I connected my wife's computer to the network wirelessly and went to her "Network and Sharing Center."  If there was a persistent problem with scenario (4), my theory was that neither my PC nor the Denon should show up on my wife's list of network devices, because both of these devices now have the same "harwire only" connection to the network, whereas my wife is connected wirelessly.  But when I went to my wife's network and sharing center, my PC shows up as a network device, but the Denon does not. 

     

    So it seems that a wireless device can see one "hardwire only" connection (the PC) but not the other (the Denon), which seems to suggest that there is not a persistent problem with scenario (4), but rather the problem is limited to the Denon/Airplay situation.  This doesn't rule out a router issue by any stretch, but maybe it suggests this could still be an Airplay or Denon issue and not a router issue.

  • FredRx Level 1 Level 1 (30 points)

    Good call.  I'd be surprised if there aren't already some ongoing discussions related to these issues.

  • jgweiner Level 1 Level 1 (5 points)

    In case you all didn't find the resolution to the wired/wireless issue here it is.  I too have Verizon FIOS and experienced the same exact symptoms as described above (except that I have a Pioneer VSX-1122 and not a Denon).  Simply disabling IGMP Proxy immediately fixed all of my problems.  Not sure why everything worked fine to begin with and then stopped but in any event, it's resolved.

     

    • If using a Verizon Actiontec router .... on the router, go to Advanced (accept the warning) and go to the IGMP Proxy menu and disable IGMP Proxy which should resolve the issue.  The issue here generally only presents when the AVR is wired directly to the Actiontec router and the iDevice is connected wirelessly.  Note however, that if streaming IPTV, disabling this proxy will also disable the IPTV connection, so in that case you'll need to leave IGMP enabled and place an ethernet switch between the Actiontec and the rest of the network.
  • HowlingF Level 1 Level 1 (0 points)

    Thanks very, very much.  I recently "solved" this problem by putting an Airport Express between the receiver and the Actiontec router.  (Now a sunk cost unfortunately, though I may try your solution and see whether I can offload it).  I have the Denon wired to the Airport Express, and the Airport Express wired to the Actiontec router.  The result is two networks (a Fios network and Apple network) and two Airplay streaming destinations (the Denon and the Airport Express, the latter of which is wasted for not being connected to any speakers).  I had all my iOS devices forget the Verizon network and learn the Apple network, and, immediately, the Airplay icon re-appeared and it's been stable now going on two weeks. 

     

    In any event, I will pass your information along to the countless others I've engaged on this subject. Again, I really appreciate it.  Thank you.

  • Claibo Level 1 Level 1 (0 points)

    Thank you very much for this....I have been struggling with this for a while and this worked!!

  • Johnkos Level 1 Level 1 (0 points)

    My recent experience was I added an Linksys ip camera to the network. I lost all AirPlay but not Internet.  I removed the camera and all devices showed up with AirPlay again. So some device on the network may be the issue.

  • Aloke Level 1 Level 1 (0 points)

    Oddly enough, in my case with Windows PC's, Netgear WNDR3800 router and 2 Netgear switches, the Airplay icon is now reliably available by unchecking "Disable IGMP Proxying" (ie, enabling IGMP Proxy) setting on my router WAN setup page.

    Could be a coincidence ....

  • rogue03 Level 1 Level 1 (0 points)

    After 12 hours of trying to figure this out I stummbled on to this post, Thanks much!! I upgraded Verizon routers yesterday and this morning I couldn't figure out why my airplay didn't work anymore, glad you posted this.

  • rgazzara Level 1 Level 1 (0 points)

    OMG!!  IT WORKED!!

     

    I disabled the IGMP Proxy on my Verizon FiOS router and now I can connect to my stereo through my Airport Express AND the Remote App on my Apple iPod Touch works again.  I can play my iTunes library on my stereo again.

     

    I have been trying to solve this problem for MONTHS with no solution.  I tried everything.

     

    jgweiner, thanks a million, you are a genius.

  • ElanX Level 1 Level 1 (0 points)

    Thanks for the IGMP Proxy tip. My AirPlay stopped working seemingly out-of-the-blue. I thought maybe the FiOS router auto-updated firmware. Someone mentioned an IP Camera being the issue, and I do have some, but didn't make any changes with them. Oh well, works now.

     

    What are the downsides to the disabled IGMP Proxy?

  • Jscharps Level 1 Level 1 (0 points)

    Hello everyone,

     

    I had the same problem.  iTunes on Mac, iPhone, and iPad, wouldn't recognize pioneer vsx1021 receiver via airplay.  This all began when I purchased a new wireless router. (Cisco EA 2700).  Receiver was direct wired to wireless router.  Pioneer and Cisco techs were no help!   I decided to restore router to factory settings and start all over.  Once I did this, I noticed that all my apple products could recognize my pioneer receiver via airplay.  (Yeah).  However, after getting all of my components connected to the Internet, I did my final step of changing the SSID name to my 5.0 ghz band so i could view the two different wireless networks.  To my amazement I lost the airplay recognition to my receiver again!   It seems the problem is with routers with dual band capabilities.  After diagnosing this problem, I called cisco and spoke with a level 2 tech.  We did the following:

     

    1.  Opened the wireless setting on my router

    2.   Changed "channel width" from auto to 20 MHz only

    3.  Changed "channel" from auto to channel 9.

    4.  Applied settings

    5.  Unplugged power to router.

    6. Waited 30 seconds and reconnected power to router.

     

    Problem solved!   I can now do airplay from all my apple products to my pioneer receiver!

     

    Hope this helps everyone!  

  • Uldix Level 1 Level 1 (0 points)

    Hello,

    We have few iPhones in our family, few days ago found that all have same problem - Airplay icon dissapeared.

    We have a Linksys router without function IGMP (at least I did not found it), tried to restart router but it did not help, some minutes later my son logged in router and refreshed settings and we found that this was helpfull.

    Anyway thanks to your discussion I started to looking for problem in router, not in iPhones.

    Thank you all.

  • jcairn Level 1 Level 1 (0 points)

    Not exactly the same problem, but had a similar issue.

    I had to replace my integrated DSL modem/router/wireless, and bought the Actiontec GT784WN.  Its router software seems to be very similar to other Actiontec models.

    After putting in the router, I lost all my Airplay and home sharing on the network.  I read lots of posts, and tried the following, with device restarts in between each step:

     

    • Disable IGMP - Still no airplay/home sharing
    • Disable 802.11b on Wireless Radio settings - Still no airplay/home sharing
    • Disable WPS - Still no airplay/home sharing
    • Change wireless security setting to WPA Personal / AES (formerly WPA-WPA2 Personal / BOTH)

     

    The last change worked - all Airplay and home sharing is back online.

  • andiamo71 Level 1 Level 1 (0 points)

    Wow...this has been driving me crazy.  I had the same Airplay issue with my new Harmon Kardon AVR 1700 receiver.  It was seeing my HTPC, which is wired, but not my iPhone or Macbook Pro on wifi.  I also have FIOS and disabled IGMP and voila! Instantly Airplay is showing up on my iPhone and Macbook Pro. Also, the Harmon Kardon app that I downloaded for my iPhone-which wasn't finding the receiver before-now is finding it.  This seems to have been the needle in the haystack that I couldn't find to fix the problem.  Thanks!