2 Replies Latest reply: Jul 7, 2012 3:36 PM by renOC
renOC Level 1 Level 1 (0 points)

I have a Mac Mini running Server 10.5.8.  It has 12 active mailboxes, no quotas and one user mailbox indicating -1072  Several days ago the server started hanging when that user's account started accumulating repetitive connections that fail to timeout and it soon hits the connection limit haltingth email service.  After searching the Apple forums and the larger web, I suspect the user's cyrus mailbox got corrupted during a failed IMAP sync (he is at a remote location with spotty service).


So far I have tried reconstructing the sngle user's mailbox with both recommended methods:


sudo /usr/bin/cyrus/bin/reconstruct -r user/(short name)


sudo mailbfr -m


Both methods hang before completion at a certain folder in the user's mailbox.  Perhaps relevant is the folder count in this user's mailbox is very large (the folder it hangs on is #126 of unknown total).


All other users mailboxes are OK and the server appears to run as expected when this user's account is off.  I want to fix the one user mailbox without losing data or messing with the other user's stuff. any suggestions are greatly appreciated.

Mac mini, Mac OS X (10.5.8), 4 Servers, 8 Workstations, 5 iOS
  • renOC Level 1 Level 1 (0 points)

    Another detail that may be helpful...  the folder that it hangs on according to mailbfr -s is "Notes"

  • renOC Level 1 Level 1 (0 points)

    Looks like I may have solved it using a combination of Pterobyte's great advice in the forum, the mailbfr tool from Topicdesk and some creative cut and paste.


    1.  Stop the services.

    2.  Move the offending mailbox folder to the desktop (after permission changes) didn't delete it right away in case I needed it later.

    3.  Opened the hung client (offline) and copied the messages out of the offending folder to a local "On my MAC" folder.

    4.  Ran mailbfr -m username again and this time it succeeded (it restored the offending folder, empty) .  Followed it up with the recommended mailbfr actions to fix the quotas and permissions.


    So far it appears to be working.