11 Replies Latest reply: Jan 5, 2013 5:00 PM by alexandr0id
STWriter Level 1 (5 points)

My iSight [BUILT-IN] camera keeps being reported as "There is no camera connected" in 'Photo Booth', though it Does show up in the USB configuration of System Profiler, and most times still functions OK using Google Video Chat. (for the first 'known' time, it did not work for Google this past week)


So far, resetting the SMC has corrected the problem, but only for a few hours.


Is there a COMMAND I can give the MacBook to do what the SMC "fixes"?


Why is it being controlled by "System Preferences - Other - Flash Player"   instead of "Hardware"??  It seems that I Can Not just set it to "Block" because this also asks if I want Google Mail to be "allowed", which is my video chat method.



There are NO other users (a TEST account is set up for when I sent it to Apple last year, but that is Not Used); I simply would like to sometimes run Photo Booth to image the room or do a new profile pic, but this Constant Problem stops that.



System is Snow Lepard 10.6.8, all updates installed as of June 2012


USB High-Speed Bus:


  Host Controller Location:          Built-in USB

  Host Controller Driver:          AppleUSBEHCI

  PCI Device ID:          0x2836

  PCI Revision ID:          0x0003

  PCI Vendor ID:          0x8086

  Bus Number:          0xfd


Built-in iSight:


  Product ID:          0x8501

  Vendor ID:          0x05ac  (Apple Inc.)

  Version:           1.89

  Speed:          Up to 480 Mb/sec

  Manufacturer:          Micron

  Location ID:          0xfd400000 / 2

  Current Available (mA):          500

  Current Required (mA):          100

  • Baby Boomer (USofA) Level 9 (57,297 points)

    http://support.apple.com/kb/HT2411 "Your camera is in use by another application" message



    my isight camera is not working-not recognized with photo booth or ichat





    1. Click on Macintosh HD on the top right of your desktop (or whatever else you’ve called your Harddrive) 2. Click through System > Library > LaunchDaemons 3. Now look for the file com.apple.cmio.VDCAssistant.plist  - and send it to trash.  http://www.appleware.co.uk/2008/12/03/isight-camera-fix.html





    Also, check out EZJim's Website.

  • STWriter Level 1 (5 points)

    This did NOT help -- no such file (VDCA....) found in LaunchDaemons.


    I have looked through (every file??) the folders and not even found the USB devices listed in these configuration files. (The MAC has 2 connectors for external devices, PLUS it puts the camera on USB. Why can't that be found?) System Profiler is the ONLY place it shows.


    The camera worked yesterday for a GMAIL video chat, but PHOTO BOOTH (a built-in Apple program) does not think there is a camera connected (it IS built-in).


    Adonea (a 'theft tracking' program) uses the camera at random and send my location to their cloud. Seems to function fine. MOST times GMAIL works fine.


    But I can see NO reason for PHOTO BOOTH to not 'see' the camera, when it is not being used by Adonea.


    I did the SMC reset, and though Adonea was First to use the camera, Photo Booth WAS able to use it.


    This whole thing sounds looks an OS problem to me (30 yrs experience with computers).

  • Baby Boomer (USofA) Level 9 (57,297 points)

    No solution found on EZJim's website?

  • STWriter Level 1 (5 points)

    Not even close - those articles are for EXTERNAL cameras.


    Apparently, since the file you referenced does not exist on my MAC, we may not be talking about the same OS version.


    I MIGHT be able to search through to find something about IINTERNAL camera. I see he mentions iLife 06 -- I have iWork and iMovie 08, so I should be able to get it to function. (I Tried - no function so far)


    His reccomendation of "TweakerSoft" is useless too -- it is for iPhones; ro to draw vectors. NOTHING about iSight.


    As I said before - "Is there a COMMAND I can give the MacBook to do what the SMC "fixes"? That might get it to work.


    Remember that Apple's "PhotoBooth Help" is worthless - been there, CAN NOT do that since it is worthless.


    I am finding out that, as I suspected after having a MAC for a year, that Apple's Help is garbage, and that there are MANY things you CAN NOT DO unless you pruchase EXTRA software (and maybe not even then).

  • STWriter Level 1 (5 points)

    I found iMovie help -- says if I have the builtin iSight, just click on the IMPORT (movie camera icon).

    I did - it does NOT know the camera is connected. SAME as my original problem.

  • Baby Boomer (USofA) Level 9 (57,297 points)

    Not even close - those articles are for EXTERNAL cameras.

    You must have blinked when you got to this part:

    Click THIS LINK for specifics related to the Built-In iSight in the new Macs.


    System is Snow Lepard 10.6.8

    Other things to try.....


    #1 - Open up a new account to see if your problems re-appear. 

    #2 - Boot up from the DVD that originally came w/your computer and run Intel-based Macs: Using Apple Hardware Test to rule out hardware issues.  If any problems/errors pop up, your best bet would be to take your computer to your local Apple Store and/or an AASP.  If you have AppleCare, give them a call.


    "Is there a COMMAND I can give the MacBook to do what the SMC "fixes"? That might get it to work.

    Sorry, I am not familiar with terminal commands.  You may wish to ask this question over on the SL forums.

  • STWriter Level 1 (5 points)

    I did miss the "Built-in" link at first, but before I finished the reply (the "Tweaker" stuff was there), I had gone through all he said there.


    I have run diagonstics (not yesterday, but recently, some time after this showed up) and NO problems found.


    I just can not understand how Apple will 'give up control' of the camera and mic to Adobe Flash (Jobs was dropping Adobe as "buggy and virus prone").


    It just does not show up in "System Preferences - Hardware" and SHOULD !! It IS a much "hardware" as the display and keyboard, even if it is run through the USB.


    I have thought of deleting it and see if that fixes things, but then I would not be able to do ANY video chats cause the browsers use it ( to best I understand it ) -- so would not be able to re-test.


    I guess I need a "hacker-grade" assistant - someone who plays with UNIX and so might know where to find the files that control 'low-level functions'.


    But thanks for trying.

  • alepoulos Level 1 (0 points)


    I just wanted to say that i'm having the same issue with a mid 2007 black MacBook.

    Mine is actually a bit odd, every time i start up the computer works fine and isight too, but if i close the lid and it goes to sleep the isight fails after. Sometimes it's the first time after i close the lid, sometimes is the seventh. I can tell isight is not working because as soon as i start up photobooth the green ligth turns on, but it doesn't when it's failing.


    I still haven't discovered if it's a hardware or software problem but i'm guessing it's kind of a combination between both.


    Any help you can give with this information? System profiler is the same as mentioned before and i have tried most stuff in every post mentioned above. This problem has started a while ago now so i have been visiting more disscussion posts.


    Thank you in advance.

  • Makyr Level 1 (0 points)

    Save your time and visit an apple store....Just got back after my third visit for the same issue-hardware prob they saaid-created by the apple store on first!

  • STWriter Level 1 (5 points)


    My machine was sent in early 2011 for a 'super-drive' replacement. No other problems.


    I can't be sure that this has not been broken sine I bought in 2007, and just recently showed because of how I use it, or my SW upgrade.


    SO - What did they find/fix? Because I want to know the cost first. And they probably won't know how to even determine the problem.



  • alexandr0id Level 1 (0 points)

    I had the same problem on MacBook - Photobooth would say that camera is not connected, but it would work in Skype, for example.


    It looks like that in my case Chrome browser and probably Flash plugin in it was the curlpit. I exited Chrome, then restarted Photo Booth and camera started working ok. Starting Chrome after that did not impair it, but if you exit Photo Booth and start Chrome first, then camera remains "locked".


    Hope this helps! Basically, I would try to exit all applications before starting Photo Booth. If there is a suspicion that Flash may be running still, a Terminal command 'ps aux | grep -i flash' should show it.