10 Replies Latest reply: Jul 9, 2012 6:35 AM by dashdash dot
dashdash dot Level 1 Level 1 (0 points)

Right clicking Mac HD it says 240 of 270G are full, but when I run Omnidisksweeper it says that there are only 160G occupied (Wich is the right value!). Where are the other Gb?


Thanks in advance!!

MacBook Pro, Mac OS X (10.7.4)
  • baltwo Level 9 Level 9 (62,210 points)

    More than likely taken up by local snapshots. Details in http://support.apple.com/kb/HT4878

  • dashdash dot Level 1 Level 1 (0 points)

    In that case, how can I delete those snapshots?

    I send you a screenshot of my storage status...




    Captura de ecrã 2012-07-8, às 21.32.21.png

    Áudio - Audio

    Filmes - Movies

    Fotografias - Photos

    Aplicações - Aplications

    Cópias de segurança - Backups

    Diversos - Others


    If the snapshots are the backups, in that case the problem must be another thing...

  • baltwo Level 9 Level 9 (62,210 points)

    I don't use TM, have a desktop machine, so they don't run, and all I can suggest is to peruse Pondini's TM FAQs for starters.

  • dashdash dot Level 1 Level 1 (0 points)

    I think the problem isn't the snapshots because if (according to the link you provided) pink lines are for external HD backups and grey lines for internal backups, than, there are internal backups only of today, all other lines (dates) are in pink.


    Have any other idea?


    Don't know if it helps, but recently my Gps was always saying it was full. Using omnisweeper I've found a file called .Trashes on it that I removed and I recovered the 2G of it!! It also happens on my microSD card on the phone when I connect it to my Mac... all I do is remove that file and space is again free!

    (I´m new at Mac)


    Thanks for help

  • baltwo Level 9 Level 9 (62,210 points)

    Removing .Trashes is a dangerous thing, especially when you're new and don't know what's going on. You'll have to wait for a TM guru to pop in, to resolve your full disk issue.


    Since you're a newcomer to the Mac, see these:

    Switching from Windows to Mac OS X,
    Basic Tutorials on using a Mac,
    Mac 101: Mac Essentials,
    Mac OS X keyboard shortcuts,
    Anatomy of a Mac,
    Switching to Mac Superguide, and
    Switching to the Mac: The Missing Manual, Lion Edition.


    Additionally, *Texas Mac Man* recommends:


    Quick Assist,
    Welcome to the Switch To A Mac Guides,
    Take Control E-books, and
    A guide for switching to a Mac.

  • drewrockshard Level 1 Level 1 (5 points)

    baltwo wrote:


    More than likely taken up by local snapshots. Details in http://support.apple.com/kb/HT4878

    It can't be due to local snapshots.  Lion's Time Machine will delete local snapshots from an hours worth, to the whole thing, if disk space is needed by the OS or any other application other than Time Machine.


    You need to figure out what that "other" stuff is.  What I'd do is either run an exhaustive du on the system to find large files (such as sudo du -k / | sort -rn | head -10), which could take awhile, or download this software called "Daisy Disk 2" - http://www.daisydiskapp.com/


    Daisy Disk 2 is annoyware (meaning that you have to wait about 30 seconds on startup before you can click on the "test out" button, unless of course, you purchase the software) but it's free from there.  It's probably faster than using the command from above and it will basically give you a drill down from your largest files/folders on down so that you can see what is actually taking up space on your drive.  I've used it to clean up alot of my system, from old music folders, to dmg images that I've created, all the way to downloaded dmg's that I've failed to cleanup (I really need to configure my Hazel installation).  By the way, when you run Daisy Disk, I just uncompress the dmg image and run it from my downloads folder and I DO NOT move it into my applications folder.  I'd run it as a utility every now and again, and for me, there is no reason to fully install it.


    I'd give that a try and report your findings. 


    Again, it shouldn't be your local snapshots no matter what, even if they were enabled.

  • dashdash dot Level 1 Level 1 (0 points)



    I will try daisydisk but I already tried Omnidisksweeper and, as you can see on the images below, there is a discrepancy from Machintosh HD (saying that 240Gb are occupied) and Omnidisksweeper (saying only 160G).


    Omnisdiskweeper doesn't show the other occupied 80G, and all the files I can see are those I need... and I can't find at all those 80G, and certainly weren't created by me.



    Capacidade - capacity

    disponível - available

    usado - used

    Captura de ecrã 2012-07-9, às 12.24.04.pngCaptura de ecrã 2012-07-9, às 12.51.33.png

  • dashdash dot Level 1 Level 1 (0 points)

    I've used Daisydisk (great tool, thanks!)


    It found 72G of hidden space, but can't delete it. This is the message it shows: "Unfortunately, Daisydisk is unable to locate these data. They are not accessible to users."


    Any idea on how to find and delete it?

  • drewrockshard Level 1 Level 1 (5 points)

    You may have already done this, but I'll check just in case.  In Daisy Disk, where it shows your drives there is a scan button that you probably clicked to run.  There's also a drop down arrow that you could have clicked, and if you click it, theres another option to "Scan as Administrator", and if you click it, it will ask for your admin password.  If you enter your admin password, it should scan everything as administrator, and you might be able to figure out what the space is and possibly delete it.


    If this doesn't work, would you at least be able to post where the large files are located on the filesystem, such as what base directory and what the filenames are?

  • dashdash dot Level 1 Level 1 (0 points)

    I've Just solved my problem


    I've done as you said right at first time, the good thing was that for the first time I've seen that hidden space thing (although not being able to delete it).


    Made some search and this solved my problem:

    Captura de ecrã 2012-07-9, às 14.26.45.png

    from: http://forums.macrumors.com/showthread.php?t=1310197


    Anyway, without Daisydisk I would not be there yet, thanks for your great hint!! Omnidisksweeper ain't that good...


    Thanks a lot for helping!!