Skip navigation

Adobe Flash is not working in Safari (5.1.7 Snow Leopard)

89325 Views 64 Replies Latest reply: Mar 11, 2014 2:14 AM by appleisnewtome RSS
  • areutryingtolosecustomers? Level 1 Level 1 (0 points)

    I've had this trouble, it just resolved somehow, but recently I had an embarrassing situation... the magic mouse jumps all around and when i was in Safari preferences I had accidently unchecked "enable internet plug-ins", while not realizing this i spent time and time again reinstalling the flash plug-in, repaired disc permissions etc, then finally checked my Safari preferences and noticed the problem DUH. Works fine again.

  • mevannorden Level 1 Level 1 (0 points)

    I have been having this problem for several months, and read pages 2-4 of this thread.  The first comment on page two mentioned an earlier comment that worked, so I finally went back to the first page and found the following:

     

     

     

    Open Safari's preferences dialog and check again that no extensions are enabled. If they aren't, click Privacy > Remove All Website Data. Open the Flash preference pane in System Preferences and click Storage > Delete All and Advanced > Delete All. Test.

     

    The above worked for me.  I was unable to view any flash video using Safari, and was having to use Google Chrome.  I also couldn't upload pictures on facebook using the flash uploader, and that works also.  Thanks Linc Davis.

     

    Mark

  • mevannorden Level 1 Level 1 (0 points)

    This solved my problem.  Thanks!

     

    mark

  • Puckstop Level 1 Level 1 (0 points)

    I ran into an issue this evening where I was unable to play embedded videos on Facebook when running Safari (Safari v6.0.2, Mac Pro running OSX 10.7.5, Flash v11,5,502,110).  Videos directly on YouTube and CNN.com were viewable just fine.

     

    Using Linc's solution (Removing / Deleting all data) solved my issue and videos are now viewable directly from Facebook once again.  Thanks!

  • dsugden Level 1 Level 1 (0 points)

    Many thanks to all the contributions (over four pages). My problem was that Safari [5.1.7 on 10.6.8] had suddenly stopped playing YouTube videos. Firefox played them, but not Safari.

     

    Having checked most of the recommendations (except those too techie for me) I re-downloaded Flash Player and Shockwave Player.

     

    Success!

     

    Thanks again.

     

    David

  • technonovice Level 1 Level 1 (5 points)

    Thank you seamusberkeley.  A quick solution to a long-standing problem.

  • mothermaryme Level 1 Level 1 (0 points)

    Thank you so much Semus. For some reason my Flash Player stopped working this morning  and I was constantly being told to download Flash Player, which I kept doing. No amount of uninstalling and reinstalling worked or changing suggested settings.

    Having a feeling of hopelessness I thought I would come back to my computer ( IMac OS X 10.6.8) and try one more time before I went to bed ( 00.15 am) to see if there was an answer to be found.

    Hey presto!!!!

    I found your post. So simple. Magic. I am soooooo grateful.

    Now I know who to seek out when I have a problem

  • burdenelizabeth Level 1 Level 1 (0 points)

    areyoutryingtolosecustomers: Thank you for your post.  I had uninstalled, reinstalled, etc and nothing worked. The problem was what you mentioned--Web content: enable plugins was unchecked.  Simple fix! All working now.

  • kwxr2000 Level 1 Level 1 (0 points)

    Seriously, SeamusBerkelyfineart, THANK YOU. 

     

    Didn't have flash for months on Safari.  Felt like living in PC world...

     

    Safari 5.1.7

    Flash 11

    never worked, uninstalled flash, deleted safari, etc ad nauseum.  Your simple method worked.

  • Neil Holdway Level 1 Level 1 (10 points)

    What if you don't have a Flash pane in the System Preferences?

     

    I've been trying to install the latest Flash as instructed and keep getting the error upon installation.

  • jdwariya Level 1 Level 1 (0 points)

    Went through these four pages and finally worked out a solution. Figured I'd memorialize it just in case it happens to help anyone else in the future.

     

    Using: MacBook Air (2009), Software OSX 10.8.3

     

    What ultimately worked:

    1) First used Linc Davis' suggestion (from page 1 of this thread):

    "Jul 10, 2012 8:05 PM (in response to tubiechik17)

    Open Safari's preferences dialog and check again that no extensions are enabled. If they aren't, click Privacy > Remove All Website Data. Open the Flash preference pane in System Preferences and click Storage > Delete All and Advanced > Delete All. Test."

     

    1A) ****NOTE: may be self explanatory for everyone else but I made sure to check both boxes under this setting: "Delete All Site Data and Settings" AND "Delete All Audio and Video License Files"****

     

    2) Uninstalled all of my Adobe Reader, Flashware and Shockwave software/applications.

     

    3) Performed step 1 (+1A) again - I don't know if this is really necessary, but I'm just "ocd" and did it again. . .

     

    4) Reinstalled all of the uninstalled Adobe items.

     

    5) Restarted everything. Followed through on prompts. Worked like a charm!

     

    I'm no expert, but I know I was getting really frustrated and I wanted to put this out there just in case it helps anyone else who might have gotten through the 4 pages of tips and was in the same situation! Hope this helps!!!

  • Shykin_82 Level 1 Level 1 (0 points)

    That's good!

     

    Mine resolved by Unistalling Adobe Flash Player then you should check if it has been completely unistalled then you can reinstall it.

    Make sure you delete these two folders before reinstalling it:

    • <home directory>/Library/Preferences/Macromedia/Flash\ Player
    • <home directory>/Library/Caches/Adobe/Flash\ Player

    Don't forget to reset!!

     

    I hope it will resolve your problem too.

  • mrcnrg Level 1 Level 1 (0 points)

    Whenever my mbp 15" 10.6.8 goes sluggish (which happens from time to time as I never turn it off and re-boot, only sleep it) or things in general don't work as they are supposed to, I start the terminal app and key in a sudo command that I will come to later. This command will clean out your system from a lot of garbage that it does not need. Usually some of it is taken care of automatically by the system itself, but only when the computer is started and/or at 3 o'clock in the morning once a week and once a month. But most people don't have their computers sitting idle at 3am on their desktop - they are most likely sleeping, like their owners.

     

    Important to notice when you do this operation is that you key in the script exactly as written. The reason is as you are giving your computer a sudo command, you are digging around in the inner core of your computer and you don't want to tell it do something that you regret later.

     

    Ok, here it goes - and yes, it solved my Flash not working in Safari problem.

     

    1.     Open Terminal, located in the Macintosh HD > Applications > Utilities folder.

    2.     At the Terminal prompt, type the following, exactly as written:

     

              sudo periodic daily weekly monthly

     

    3.     Press Return.

    4.     Type your Admin password when prompted, then press Return.


    All three scripts will run in sequence. There is no visual feedback while the scripts execute. You will know they are completed when the Terminal prompt returns.

     

    If you want to know more about maintenance scripts for OSX, go here

    http://www.thexlab.com/faqs/maintscripts.html#Anchor-Manually-49575

    MacBook Pro, Mac OS X (10.6.8)
  • That Bloke Rob Level 1 Level 1 (0 points)

    Thank you! Same problem here for the last two days!!

     

    Safari Preferences > Security > tick "Allow All Other Plugins"

     

    SOLVED!

  • iamimp Level 1 Level 1 (0 points)

    Searching for 'flash won't work in safari'...

     

    FRIDAY 23rd AUGUST, 2013

     

    SAFARI Version 6.0.5 (7536.30.1)

     

    I can confirm that this works:

     

    "Finally figured out solution to same problem on MacBookPro running 10.8.

     

    Safari>Preferences>Security> check 'Enable plug-ins' on.

     

    Flash now working"

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.