11 Replies Latest reply: Jul 19, 2012 5:32 PM by SoundguyRob
SoundguyRob Level 1 Level 1 (0 points)

I have an older Powerbook G4 867. ('Twas my first mac-**sniff**) abt 4 years ago, I was on my couch surfing and the screen went black. I never got it to reboot. A while later I got it to boot out of the blue. It worked fine, ran some software updates but when went back to the same problem when it rebboted for updates.

Today, I decided to pull it out ofthe closet and give it a try. It booted right up! First thing I tried was going onto Disk Utilities and ran all the checks and it showed no problems with the HD.

Ran 4-5 OS X and Java updates, a hand full of office 2004 updates fine. Rebooted every time. I was going to dig up the original OS X discs and boot into the disc and check any thing there. I set it down with the screen open, letting the battery charge while I cooked dinner. I glanced over at it periodically and it was charging and the screen was dimming slowly. After dinner it would not wake, and went into the same symptoms:

 

When hitting power, you hear a slight click.

Nothing starts, no screen, no welcome chime, etc.

The machine acts like it is powered on, since the CAPS Lock light toggles on and off.

Have to hold Power for 10 seconds then caps lock-and machine "shuts gown" Theres a slight noise when this happens

 

I researched here and tried the following:

Tried the PMU reset.

I can't do the PRAM since it never goes into start up.

Tried the NVRAM, again, nothing happens-etc.

 

I am thinking its toast. Thoughts?


PowerBook, Mac OS X (10.4.11)
  • BGreg Level 6 Level 6 (17,500 points)

    You've tried a safe boot by holding the shift key down when you boot? 

  • old comm guy Level 4 Level 4 (2,235 points)

    OK, some things come to mind here.  First suspect is the internal PRAM./clock/backup battery.  We'll get to that in a moment.

     

    The first thing you should try is a PMU reset.  That button is under the keyboard.  That may be all that is needed.

     

    Now, we need to deal with batteries.  First off, how many green LEDs light on the main battery when you press the test button?  When on the charger, do you have the amber/green indication at the plug, as appropriate?  If you can get the battery to full charge, we might be able to kick-start the internal backup battery by shutting down the computer, connecting to the AC adapter and then removing the main battery and leaving things for at least 8-10 hours in that condition.  That will attempt to force charge the backup battery.  A weak or failed internal backup on that particular machine can cause some maddening behaviors.

     

    The backup battery may be tested by putting a running system to sleep, disconnecting the AC adapter and then removing the main battery for five seconds.  If the machine stays in sleep and then can be waked, the backup battery is serviceable.  If the machine shuts down, then the backup battery is discharged or plain kaput.  I have seen reports of the backup batteries keeling over in five years or so, although I have one TiBook that is over nine years old and the backup battery is still working fine, meaning I'm batting 0.500 on backup batteries.

     

    Oh, and a good source for main batteries is OWC.  Recommended by others as well, and the one I got from them a year or two ago is chugging along just fine.

  • SoundguyRob Level 1 Level 1 (0 points)

    Thanks to both of you for your replies. First, Bgreg, yes I tried all forms of booting- Since its not responding to anything I can't do a safe boot.

    I think I should have renamed my post as "Can't reset PMU on ...."

    4 years ago I was trying to fix this since it was my only mac. Bought 3 since then so it was in the closet. Therefore, I believe one of the battery issues are causing the problem, like OCG mentions. Everything was dead and it fired right up. Went back to the problem when the battery(ies) finished charging-while cooking dinner.

     

    So, PMU. I tried to do this 4 years ago. Read on the web that there is a reset under the keyboard. disassembled the keyboard, and apparently there is one more latch/screw in the middle holding in on there. I can't get the entire keyboard to come up. BUT, under the top-right side, there is NO reset button.

    I tried shift+option+command+power. It doesn't respond to that either. I guess if I could get it to boot normally, I could go back and do this.

    So, if I do the shift+option+command+power- it makes the quiet click, and I can see the num lock/caps lock lights. I have to hold power to kill it.

    If I undo the battery in this mode, and/or pull the power, it dies instantly.

    I think I am closer in the last 24 hours to diagnosing the problem.

    Thoughts? Rob

  • SoundguyRob Level 1 Level 1 (0 points)

    I am really frustrated since I cant find an accurate description on removing my keyboard. None of the options on the manuals or described here resemble my machine. Since it says to remove screws under XX and XX then lift, Well I did that and bent the keyboard. Theres another with a "Keyboard lock" This doesnt exist. Mine has a series of screws. I cant find the center screw so I can't pull the entire keyboard off the machine. I can see under most of the keyboard and there isn't a reset of any kind.

    I will have to find a replacemnt keyboard if I get this thing working.

    12" Powerbook G4 867. All the searches and guides show info for either the 15 or the DVI. I guess since it is not an iPad or retina display, these options aren't important anymore.

  • dalstott Level 4 Level 4 (2,625 points)
  • old comm guy Level 4 Level 4 (2,235 points)

    There's no button on the 12 inch machine, so you have to do the shift-control-option-power simultaneous button mash, release,  then wait 5 seconds before pressing the power button to try the start.  (That five seconds is supposed to allow the PMU to initialize completely.)

     

    Your PowerBook may nor have an internal backup battery, as not all 12 inch models had such a device.

  • SoundguyRob Level 1 Level 1 (0 points)

    Yes, I found the correct info on iFixit. Gonna try and get it working THEN worry about the keyboard.

    I have a friend is a Apple Certified- (Hardware, I dont remember the tag) He had me run a couple of things and thinks the PRAM battery died. Gonna upate ASAP. Thanks, Rob

  • SoundguyRob Level 1 Level 1 (0 points)

    Old Comm Guy- Since I can't seem to find one on any parts site- I assume I dont have an internal PRAM battery? If so, makes me wonder what is causing my issue?

  • dalstott Level 4 Level 4 (2,625 points)

    Like the original iBook the 12" G4 powerbooks didn't have a PRAM battery.

    These machines, just like G3 and G4 iBooks do not use PRAM batteries,

    they use power from the main battery and a capacitor on the logic board to maintain the clock.

     

    http://support.apple.com/kb/HT2295

  • old comm guy Level 4 Level 4 (2,235 points)

    SoundguyRob wrote:

     

    Old Comm Guy- Since I can't seem to find one on any parts site- I assume I dont have an internal PRAM battery? If so, makes me wonder what is causing my issue?

    Well, as noted, there is no backup battery indicated in the exploded drawing in the shop manual.  There is a "Sleep Board" (922-5659) depicted which is apparently the sleep light board.

     

    Let's back up a step and make sure that the main battery is fully charged (all green LEDs light when the test button is pushed) and the charge indicator on the power adapter cable is green when plugged into the machine.  Second data point: if the main battery is removed and the machine is on the power adapter, will the machine come up?  (Thinking here is that possibly the main battery has tanked after being in the closet for four years and as it was being charged, it failed in a bad way such that it is diverting running power from the power adapter input.  Removing the battery is one of the shop manual steps in troubleshooting startup problems.)

  • SoundguyRob Level 1 Level 1 (0 points)

    Battery- Fully charged, Will not power on with battery removed. I will say this-it fired up when the battery was dead. I actually wiggled the charger cable at the base 'cause it turned a different shade of Amber- (?) I have another charger somewhere that was left in my office when I used this machine, somewhere in the house.

    Both times when it powered on it says the date needs to be adjusted. The battery is holding a charge, another thing that makes me wonder.

    I went thru the battery removal/power drain-etc 4 years ago. So far I can get a battery for a whopping $20-$100. I found a few resources for the keyboard replacement. So, I could get this working again for $50(ish) and have a browser in my kitchen. It's just a little puzzling, all of the symptoms matched up to the dead internal battery....