Previous 1 2 3 Next 35 Replies Latest reply: Feb 9, 2015 8:08 PM by Razgut Go to original post Branched to a new discussion.
  • elgy03 Level 1 Level 1 (0 points)

    I can't sync my iPod Classic (I'm on Mac OS X Mountain Lion 10.8.2, iTunes 11.0.2 (26)). One of the troubleshooting steps is to uninstall and reinstall iTunes (see http://www.apple.com/support/ipod/five_rs/classic/#), but I can find no documentation or instructions on how to do this, and simply dragging the app to the trash yields an error message.

    If we're no longer supposed to try uninstalling iTunes, I wish the good folks at Apple would correct their troubleshooting tool. (If anybody can send me the link to give feedback, I'll gladly do so.)

    I'll next try your suggestion, The Other Shahab.

  • The Other Shahab Level 1 Level 1 (10 points)

    Elgy03, best of luck. So far my suggestion has worked for me and others. If there's any clarity that you need, ask away and I'll be glad to help.

  • elgy03 Level 1 Level 1 (0 points)

    "Mannually manage music and videos" wasn't on by defualt on my system. When I checked it, "Sync only checked songs and videos" became unavailable. Take-away: check "Sync only checked songs and videos" first, if possible.

     

    Also, I suggest selecting all of the music in your library and unchecking it BEFORE you connect the problem iPod. In my case, every time I connect the iPod I'm troubleshooting, my system performance slows to a crawl (i.e., spinning rainbow circle of death, 2+ minutes response time between clicks), so whatever I can do without the iPod connected to troubleshoot is best.

  • elgy03 Level 1 Level 1 (0 points)

    I'm on Mac OS X Mountain Lion 10.8.2, iTunes 11.0.2 (26).

     

    I want to uninstall iTunes because I keep getting the following error message when I try to sync my iPod Classic:

    The iPod "___" cannot be synced because it cannot be read from or written to.

    (See attached screen shot.)

    iPodClassicSyncErr19Feb13-3.png

    The Apple Support troubleshooting step I've gotten to tells me to uninstall iTunes.

     

    I hope that answers your questions? Any advice?

  • ugotz Level 1 Level 1 (0 points)

    See website that helps.   Http://HowToUninstalliTunes.com.

  • elgy03 Level 1 Level 1 (0 points)

    Alas, no luck. Looks like I'll have to take my iPod in to an Apple Store. Hopefully a Genius can make some progress.

  • optimusrime Level 1 Level 1 (0 points)

    I have had the same issues with all of my devices (iphone 5, ipad 2, itouch) and recieved the same error message.  So I don't think it is your devices.  I am assuming this is a software issue with itunes.  I hope a solution is made very soon, because contacting the apple support line has been no help.  They saw my issue through their mirroring software and are supposedly calling me back tomorrow, because they are just as confused as me. 

  • Beewl Level 1 Level 1 (0 points)

    I follwed all the steps, but i couldn't remove iTunes until I did this:

     

    • Launch Terminal from the Utilities folder within Applications
    • Type the following commands:
    • cd /Applications/
      This brings you into the Applications directory, the next command deletes iTunes itself:
      sudo rm -rf iTunes.app/
    • Enter the Administrator password to confirm
  • vietna Level 1 Level 1 (0 points)

    This isn't working for me!

     

    Last login: Wed Aug  7 20:48:11 on ttys000

    gabymagic:~ gabrielawcislo$ cd /Applications/

    gabymagic:Applications gabrielawcislo$ sudo rm -rf iTunes.app

    gabymagic:Applications gabrielawcislo$ sudo rm -rf iTunes.app

    gabymagic:Applications gabrielawcislo$ sudo rm -rf iTunes.app/

    gabymagic:Applications gabrielawcislo$

     

     

    Please help

  • fireteller Level 1 Level 1 (0 points)

    @vietna, I'm guessing that worked even though you didn't get any response.  However you should have receive d a response from 'sudo' asking for your admin password. I just followed @beewl's steps and it worked fine (as to removing the app).

     

    To debug try just 'rm -rf iTu[tab]'

     

    Hit tab to confirm that it compleaste the to iTunes if not, then you are in the wrong directory or you have succesffuly remived the folder already. Also i fit is ther you should git a buch of lines tha tsay "...: Permission denied"

     

    What are your results?

  • David Richards2 Level 1 Level 1 (0 points)

    Just finished putting itunes 11 in the trash.     How good it feels....what a heap of rubbish. When I asked support for help got a load af gobbledegook back.

     

    Anyway, put all yer songs on an external HD.    Then click the itunes application, go to finder and click "info".  Right down the bottom is a padlock/  Unclick it using yer password and select "read and write."

     

    OK now you can thro old Itunes 11 in the trash.  Leave it to stew there. Go to the top right hand corner of yer desktop, click it and write "itunes" in it.  Now anything that appears in that list to do with itunes...trash it.   Don"t be scared "cos all yer songs are in the exteral HD...remember?

     

    Go to Google and ask how to install itunes 9.2.1 ( back to sanity.)

     

    Download and install it.   Oh Happy Days.  Drop your music from the external HD into a new playlist and watch the action.   Just go to itunes preferences and knock off anything that makes itunes a nuisance to you.

     

    If I have left anything out just put it under here.  Don"t blow yer Mac up and don"t be scared of it  :-)    Dave in Western Australia...Onya Cobber....

  • Docjr08 Level 1 Level 1 (35 points)

    In case anyone is still interested in removing iTunes (e.g. Installed iTunes 11.1 beta 2 and wants to roll back to 11.0.5 (at the time of this writing)

     

    Open the Terminal, sudo up with the following command

     

    sudo -i

     

    If you are the only user enter your password otherwise type the computer's administrator password.

     

    then type the following

     

    rm -r -f /Applications/iTunes.app/

     

    Download iTunes, if you haven't already, and run the installer. It should reinstall without whining that a newer version is already installed.

     

    Cheers GL.

  • KevinVu12 Level 1 Level 1 (0 points)

    My version is OS X 10.8.5

    just because my iTunes have some problem, such as it changed to another language

  • m0thr4 Level 1 Level 1 (95 points)

    rm -rf is the most dangerous Unix command combination of all... and one of the reasons is the -f switch, which tells it to:

     

    • delete without any prompting or confirmation
    • ignore whether or not the file exists or not
    • ignore whether the file is a folder* that "contains" other files

     

     

    *  yes, folders (or directories) are just files

  • m0thr4 Level 1 Level 1 (95 points)

    There's actually a bit more you need to do. 

     

    sudo rm -rf /Applications/iTunes.app/

    sudo rm -rf /System/Library/Extensions/AppleMobileDevice.kext/

     

    Restart your computer

     

    Download and install iTunes