9 Replies Latest reply: Jan 20, 2013 1:39 AM by Denson895
agent17 Level 1 Level 1 (0 points)

hi guys, recent mac convert here, but very frustrated. please read carefully, this is not just another .mod to imovie question.

 

i've tried to explain in detail what happened to me. maybe something in the sequence of events caused my issue...

 

ok, i have a load of vids from jvc everio originally saved on pc as .mods. i changed file extensions to .mpg so i could use them. no problem.

 

had my imac a few months and decided to revisit the old vids and edit them in imovie.

 

1) realised i could not import the mpgs to imovie, so i used handbrake to convert mpg to mp4 (if i remember rightly), then imported to imovie. worked, but handbrake took a looongg looonngg time. i think the file size was much bigger too, not sure now.

 

2) found a fix on this forum where i created an archive exactly same folder structure as jvc camera has. changed a couple of the mpgs back to mods and imported successfully. happy days. did it much much quicker than using handbrake to convert first.

 

3) had to close imovie and restart every time i did one though so i could organise the events one at a time easily. but no problem.

 

ok, so everything absolutely fine. until...

 

at some point imovie imported iphoto vids. after that, imovie crashed on startup with a message about one particular iphoto vid and asking if i should ignore it or not. i tried yes and no options hundreds of times. no joy.

 

i also deleted the com.apple.iMovieApp.plist several times following advice i found here also. no luck.

 

4) i discovered that a handful of the iphoto vids were avi's. i deleted (moved) them from iphoto and (at last) i got imovie started again. maybe this tip alone will help solve someone else's problem?

 

5) went back to my 'fake' camera archive, dumped a couple of .mods in, tried to import as before, imovie crashes. every time. every single time.

 

6) imovie does not import the clip, it hangs on importing thumbnails. i checked the .mods were ok by changing back to .mpg and playing in mplayerx. everything fine. interestingly, in imovie import window, it shows the clips as 0s and some of them it allows me to play in preview but without sound, others just crash imovie it the moment i press play in that preview pane.

 

ok, what else i have i tried:

 

7) deleted imovie and re-installed (shut down imac first and re-booted before re-installing). does exactly the same. i should note here that imovie works fine with the movies previously imported. it is just the camera archive .mods that have stopped getting imported.

 

8) i have tried renaming the files with various combinations, e.g. MOV1A1.MOD, MOV6F2.MOD etc., etc.. - important point here is that this is what i did first with no issues. it appeared i could name them anything as long as i copied the number/letter/number format, and they imported without issue.

 

so here i am, 3 days in, my back is killing me sitting at this computer with barely no sleep. this is madness!

 

can someone please tell me how to trick my imovie back into accepting the .MODS via the camera archive scenario?

 

or what i've done wrong to cause all this grief?

 

one thing i haven't tried is to put the files back on camera. well i did try and i couldn't work out how to do it. thought maybe if i just imported via usb, as i have done without issue, it would accept my older files. but like i say, i could not do it.

 

one last thing - all the .MODS were done with same jvc everio camera.

 

anyone out there able to help me? please?

 

mike


iMovie '11, Mac OS X (10.7.4)
  • agent17 Level 1 Level 1 (0 points)

    can anyone please help?

  • AppleMan1958 Level 7 Level 7 (27,395 points)

    I would suggest that you try a free app called MPEG Streamcliip. http://www.squared5.com/svideo/mpeg-streamclip-mac.html

     

    Drag the mod file into MPEG Streamclip.

    Then FILE/EXPORT USING QUICKTIME

    Choose Apple Intermediate Codec as the codec.

     

    You should be able to then import into iMovie using FILE/IMPORT MOVIE.

  • agent17 Level 1 Level 1 (0 points)

    i just downloaded it to try but it's taking even longer than handbrake. in fact it looks like it is taking about twice as long as handbrake does...

     

    so, thanks for the input, but it doesn't really improve my situation nor solve my issue.

     

    what i really need is to find out how  imovie camera archive import function got 'broken'?

     

    this worked perfectly for about 10 vids before it started crashing. very fast, very convenient.

     

    i just want to get imovie back to doing what i got it to do originally.

     

    anyone else have any suggestions?

  • agent17 Level 1 Level 1 (0 points)

    bump!

     

    i spent 1 hour and 20 minutes on phone to apple, and still no solution.

     

    then did the data capture thing on my imac and am waiting to hear results.

     

    personally, i do not hold out much hope from that, and am desperately hoping someone else on here has more insight into this issue.

     

    if anyone has any more ideas, please please please share them.

     

    mike

  • agent17 Level 1 Level 1 (0 points)

    sorry if i am boring anyone keeping my own thread going, but i take back the comment i don't hold out much hope from apple.

     

    they talked me through a restore thing and now imovie has stopped crashing and successfully (almost) imports .MOD's as before.

     

    one small problem. there is now no sound.

     

    i'll throw the question out there and hope someone is listening:

     

    does anyone know why i have no sound on importing .MOD when i did before?

     

    before i have a breakdown myself...

  • agent17 Level 1 Level 1 (0 points)

    ok, well seeing as i am the only talking about this, i'll share my latest update from the apple tech which will hopefully help some of you.

     

    there IS an issue with sound on the latest version of imovie, which they are looking to fix now.

     

    unfortunately, i do not have installation disks so i cannot roll back to version 9.0.4 which i'm told is ok, and would explain why i got this working in the first place. how i wish i had not updated a few days ago...

     

    so, for anyone wanting to import .MOD without changing file extension to .mpg and losing screen size, or converting  via handbrake/streamclip, the best way to do it is in fact via the camera archive folder as i did it, which is much faster than converting and works perfectly. using an older version of imovie of course.

     

    until the update, i'll leave this forum to more important things than my crappy old vids.

     

    of course, i will be back to let you know, in the interests of sharing information.

     

    peace x

  • Denson895 Level 1 Level 1 (0 points)

    All you need is a conversion program to get you from .mod files to .mov or .dv files.

    Give Google a try. After that, just copy files from the HD using USB to your local machine (or scratch disk) and convert. You should then be able to import into whatever version of iMovie/FCE you like.

    MOD Video Converter for Mac may be what you need. Have a look at that first.

  • agent17 Level 1 Level 1 (0 points)

    Sorry, but I've already stated clearly I can convert but I do not wish to.

     

    Apple have resolved the conflict in latest iMovie and it works perfectly again now, using the method I explained in my original post.

     

    I strongly recommend anyone else to use the 'proper' way as it is works flawlessly and simply without the need to download any third party software which, in my experience, takes much longer and often causes issues.

  • Denson895 Level 1 Level 1 (0 points)

    In my personal experience,the freeware always have some problems more or less.its quality can not be guaranteed. like iMovie, general issues include: hanging while opening movies, delays when adding music or photos, odd system hangs while trying to edit video and sometimes. startup crash, unusual slowdowns, hang ups, iMovie not seeing the iPhoto library, etc....But you can trust yourself