Previous 1 6 7 8 9 10 Next 237 Replies Latest reply: Oct 6, 2014 8:21 AM by cooldaddybeck Go to original post Branched to a new discussion.
  • juergendersoftwaremeister Level 1 Level 1 (0 points)

    Hi, could you tell me exactly how you accessed the option to enter an IP address as I cannot seem to find this.  Also, how did you know which IP address to enter?

     

    Thanks.

  • sott3 Level 1 Level 1 (0 points)

    Here is what I did to fix my Apple TV by setting a static IP:

    1. Go to Settings -> General -> Network -> Wi-Fi
    2. Select your Wi-Fi network so you get the "Wi-Fi Configuration" screen
    3. Select Configure IP
    4. Switch it from Automatic to Manual
    5. At the "Configure IP" screen, set your IP address. I pulled up the network settings on my iPad (which was successfully connected to my Wi-Fi network) to get an idea of what to put here. You can check the ip status of any of your Wi-Fi connected devices to get most of this info. The ip address you enter here will depend on your router. My iPad had an ip of 192.168.0.9 and a subnet mask of 255.255.255.0. So my Wi-Fi network consists of ip addresses 192.168.0.1 to 192.168.0.254 .  I wanted to stay away from the low end there since my router will continue to assign those addresses as new Wi-Fi devices come into my network. So I went with the ip 198.168.0.200. You may know specifically which ip addresses your router is assigning and can stay away from that range.
    6. Set your subnet mask. It's most likely 255.255.255.0. Same as your other Wi-Fi devices.
    7. Set your Router. This is the ip address of your router on your Wi-Fi network. Same as your other Wi-Fi devices. Some devices might refer to this as your Gateway.
    8. At the Configure DNS screen, enter the ip address of your DNS server. Again, copy this from your other Wi-Fi devices. If you are stuck, you can put in Google's DNS server address which is 8.8.8.8.
    9. Try connecting again to your Wi-Fi network

     

    So in my case, it appears that something with update 5.1 prevented my Apple TV from getting an IP address any longer from my router (which is acting as my DHCP server). I know people mentioned that it worked if they turned off security on their Wi-Fi, so maybe it's an issue with getting automatic addresses and WPA2 encryption. I have seen in the past where Wi-Fi clients would not get an ip address from a router if they were made by different vendors. In this case, my router from Bright House cable is assigning IP addresses. This worked fine though until 5.1.

     

    So setting a static ip may just help in my particular case. As I said before, the Apple TV was seeing my Wi-Fi- network but just wasn't pulling an IP address. If you are having a similar issue, it may be worth a try to use a static address.

     

    Obivously this is a WORKAROUND. Apple needs to issue an update to fix this so we can all use Automatic ip addressing and not mess with static ip addresses.

  • juergendersoftwaremeister Level 1 Level 1 (0 points)

    Thanks so much for taking the time to provide such a detailed explanation, I appreciate that.

     

    Sadly my ATV is not even finding the network, so entering the IP address is not possible.  If I manage to advance to that stage I will follow your steps and see how it goes.

     

    Thanks again.

  • Hello my friends Level 1 Level 1 (0 points)

    Apple needs to fix this issue, I was on the phone with them all day.  The only thing that work is to get a replacement.  I got my Apple TV replace because it was under warranty.  I am not doing the update on my new Apple TV.   My Apple TV is working great without the update.

  • stw1958 Level 1 Level 1 (0 points)

    hi,

     

    just followed your procedure,i now can use wi-fi to access all the apps etc.

     

    many thanks for your help.

  • Maria Fernanda Affonseca Level 1 Level 1 (145 points)

    My ATV suddenly stopped seing any wifi network! All other devices are connected to my network and browsing the internet. But Apple TV doesn't see mine or any other network. This issue began tonight suddenly also after update to 5.1.

     

    Any other thoughts on how to fix this?

  • JohnD314 Level 1 Level 1 (0 points)

    I am having the same problem with ATV.    Yesterday it was working working fine, but tonight it will not connect to the internet although it does recognise my wifi network (after I put in the password for this).  I tried to follow the excellent explanation by sott3 but ATV seems to require more digits than there are in my IP,  Subnet Mask and Router.  I tried leaving the extra digits at zeros but it still does not accept this.    Also it asks for DNS despite the fact that it says N/A to this.

     

    Over the last few weeks there has been one problem after another with Apple,  first the maps, then the bug with the new version of iPhoto and now this new problem with ATV.   Until a few weeks ago I would not have anything said against Apple, I have been 100% pleased with all the Apple products I have had in the last 4 years and have recommenred their products to many people.  Now everything seems to changing and to use a common expression the apple seems to be going pear shaped.   They are making a profit of billions of dollars which they get from us their custoners but I would ask if they are properly testing products and updates before they are released. 

     

    I suppose we shall have to wait until they release yet another fix to this latest bug.  I hope it will not be long as it makes my subscription to Netflix somewhat a waste of money as I cannot watch it.  Sorry for the grumble but this is how I feel.

  • JohnD314 Level 1 Level 1 (0 points)

    This is an update to my previous posting.  After switching off and switching on again ATV has reverted to accepting the nework setting automatically without any intervention from me !

  • Maria Fernanda Affonseca Level 1 Level 1 (145 points)

    I have tried to switch it off, on, restore, restart, everything...and it still doesn't work!

    It stopped suddenly last night and never connected to wifi again!

    APPLE, HELLO, HELP US!!!

  • JohnD314 Level 1 Level 1 (0 points)

    Maria, did you try putting in the IP address and other settings?

  • Mexicomark Level 1 Level 1 (0 points)

    I have all the same issues. I tried inputting ip manually and nothing. All my other devices connect but not atv. It just won't connect to my router

  • Mexicomark Level 1 Level 1 (0 points)

    Also tried Connecting via Ethernet cable .....nada

  • Maria Fernanda Affonseca Level 1 Level 1 (145 points)

    No, I can't get to that step because mine doesn't even find any wifi networks to begin with!!!!

    It's like it's not even looking for networks...

    Any other suggestions?

  • Archangel9732 Level 1 Level 1 (0 points)

    I am having the same problem. Oct 11th, everything was fine, Oct 12 I turn on my AppleTV and it was disconnected from my network. I tried logging back in but it kept saying my ID and Password were wrong (they weren't) I tried several times, nothing. I called Apple and all I got was a response saying I needed to purchase a 1 time tech support for $19.99 (are they kidding me?) they send out a bad update and then try to charge me to fix it?.

     

    Like many of you I'm an avid Apple user, all my tech is Apple, I certainly hope this is NOT a sign of things to come. I miss Steve already........don't forget Apple, we your customers, made you the wealthiest buisness in the history of the world.....we can make you the poorest, now please fix this......

  • JohnD314 Level 1 Level 1 (0 points)

    Maria, I don't know what else I can suggest.  I had to put in the password of my wifi connection, although it was automatically recognising the wifi. 

Previous 1 6 7 8 9 10 Next